Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Senior Member ModelCitizen's Avatar
    Join Date
    May 2005
    Location
    Sussex UK
    Posts
    3,156

    Locked out of my own Slimserver (password in prefs)?

    I've just set up a a username and password for access to my SlimServer. I must have mistyped it as I can't now access my own SlimServer.
    Is there some place in SlimServer.pref where I can remove the protection? If so, where?

    No, I am not embarrased.

    Thanks

    MC
    Somewhere, something incredible is waiting to be known
    Last.fm/user/ModelCitizen

  2. #2
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,531
    Quote Originally Posted by ModelCitizen View Post
    I've just set up a a username and password for access to my SlimServer. I must have mistyped it as I can't now access my own SlimServer.
    Is there some place in SlimServer.pref where I can remove the protection? If so, where?
    I see entries in my prefs file of:

    password: ''
    username: ''

    I'd be willing to bet that's it.

  3. #3
    Senior Member ModelCitizen's Avatar
    Join Date
    May 2005
    Location
    Sussex UK
    Posts
    3,156
    Do you have a password and username set up for your SlimServer JJ?

    All I can find on a search in my SlimServer.pref for "password" are two entries:

    csrfProtectionLevel: 1
    dbpassword: ''
    dbsource: dbi:mysql:hostname=127.0.0.1;port=9092;database=%s

    and

    noGenreFilter: 0
    password: ''
    persistPlaylists: 1

    Neither or them look like the thing I think I'm looking for.... and if they are... I have no idea what to do with them!

    MC
    Somewhere, something incredible is waiting to be known
    Last.fm/user/ModelCitizen

  4. #4
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,531
    Quote Originally Posted by ModelCitizen View Post
    Do you have a password and username set up for your SlimServer JJ?
    No, but I just tested setting a password. There's another field - authorize - that enables it. Just set it to 0 and it won't matter what the username and password are.

    authorize: 0

  5. #5
    Senior Member ModelCitizen's Avatar
    Join Date
    May 2005
    Location
    Sussex UK
    Posts
    3,156
    Thanks a lot for this JJ. I've now got access to my SlimServer, but not in the way one might expect. I searched SlimServer.pref for "authorize" and found:

    allowedHosts: 127.0.0.1,192.168.1.10
    artfolder: ''
    audiodir: ''
    authorize: 0
    browseagelimit: 100
    bufferSecs: 3

    I would have expected authorise to be set to 1, not zero.
    I stopped SlimServer and reset it to 1, re-started SlimServer but was still locked out. I then stopped SlimServer again and changed "authorize" back to zero. This time when I restarted SlimServer I had access.

    Unles there's something unseen going on it looks like there may be some sort of bug around this area.

    I still don't understand why my SlimServer.pref does not have a simple listing:

    password: ''
    username: ''

    whereas yours does. I'm on 6.5.2 on Windows. Maybe your version is different?

    Anyway, again, thanks.

    MC
    Somewhere, something incredible is waiting to be known
    Last.fm/user/ModelCitizen

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •