Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    Senior Member
    Join Date
    Sep 2005
    Location
    Kingston, Ontario
    Posts
    773

    Help with some debugging please!

    Hi,
    My Slimserver has picked up the habit of just stopping for no apparent reason. I can re-start it from the slimtray with no problems whatsoever, though. I think it might have to do with some plugins I've been playing around with lately, namely Fileviewer.pm, SaverSwitcher.pm (which I had trouble installing, so maybe there is still something funny going on?), or possibly lastfm, although I think this one was running for quite a while without causing trouble. Can anybody direct me to which debugging routine might provide an indication of what is going on that causes the server to stop?

    Thanks,

    Nick
    Wireless SB3, Denon DRA-F101, Mission M31 loudspeakers
    WinXP SP2 Slimserver, SMC WBR14g router
    http://www.last.fm/user/nicketynick/

  2. #2
    NOT a Slim Devices Employee kdf's Avatar
    Join Date
    Apr 2005
    Posts
    9,493

    Help with some debugging please!

    Quoting nicketynick
    <nicketynick.2mucjb1172877601 (AT) no-mx (DOT) forums.slimdevices.com>:

    Can anybody direct me to
    > which debugging routine might provide an indication of what is going on
    > that causes the server to stop?


    If you are on Windows, check the Event Viewer for information about
    the crash: start->settings=>control panel->administration tools

    to dig further, stop the server and open a command prompt:

    start->programs->accessories->command prompt. run the following:

    c:\program files\slimserver\server\slim.exe --d_plugins --d_source

    That will show you plugin and playback activity so that you have some
    idea of what the server is doing when it stops, as well as any
    messages that can't be trapped by the event viewer.

    if you aren't on windows, then skip the event viewer and open a
    command-line, running slimserver.pl --d_plugins --d_source instead.

    -kdf

  3. #3
    Quote Originally Posted by nicketynick View Post
    Hi,
    My Slimserver has picked up the habit of just stopping for no apparent reason. I can re-start it from the slimtray with no problems whatsoever, though. I think it might have to do with some plugins I've been playing around with lately, namely Fileviewer.pm, SaverSwitcher.pm (which I had trouble installing, so maybe there is still something funny going on?)
    The latest official release of SaverSwitcher definitely has some known bugs -- mainly for cases where someone has chosen SaverSwitcher as a screensaver but hasn't made the appropriate 1/9 saver "active". The bugs related to that tend to be CPU-hogging bugs, though, not crashing bugs (to the best of my knowledge). I think I've fixed those bugs, but haven't done enough testing to feel comfortable with a new release. Anyway, as I said, I'm not aware of any fatal/crashing bugs since release 1.5.

    If you find anything wrong that looks like SaverSwitcher, please let me know and I'll do my best to fix the problem ASAP.

    Good luck,

    Peter

  4. #4
    NOT a Slim Devices Employee kdf's Avatar
    Join Date
    Apr 2005
    Posts
    9,493

    Help with some debugging please!

    Quoting nicketynick
    <nicketynick.2n01eb1173143101 (AT) no-mx (DOT) forums.slimdevices.com>:

    >
    > Hi kdf,
    > Well, here's what I see in the Event Viewer corresponding pretty
    > closely with a Slimserver stoppage. Make any sense?
    > C:\PROGRA~1\SLIMSE~1\server\Bin\MSWIN3~1\mysqld.ex e: Normal shutdown


    "normal" isn't really expected

    I would have expected something to do with slim.exe in there
    somewhere. Are you using any antivirus software? This has a known
    issue with mysqld, which can be fixed by telling your AV software to
    ignore *.MYI and *.MYD files.

    -kdf

  5. #5
    Senior Member
    Join Date
    Sep 2005
    Location
    Kingston, Ontario
    Posts
    773
    Hi kdf,
    Well, here's what I see in the Event Viewer corresponding pretty closely with a Slimserver stoppage. Make any sense?
    C:\PROGRA~1\SLIMSE~1\server\Bin\MSWIN3~1\mysqld.ex e: Normal shutdown

    I haven't tried the more intensive logging yet.

    Peter, thanks for the assurances with SaverSwitcher. So far, don't think it's to blame!
    Wireless SB3, Denon DRA-F101, Mission M31 loudspeakers
    WinXP SP2 Slimserver, SMC WBR14g router
    http://www.last.fm/user/nicketynick/

  6. #6
    Senior Member
    Join Date
    Sep 2005
    Location
    Kingston, Ontario
    Posts
    773
    Thanks kdf,

    Sure is hard to read these fora when the response gets posted before the question! Or are you psychic?
    Anyway, I'm running McAfee - I've seen the advice on the mysq* files before - I'll do it now while I'm thinking about it and see what happens!
    Wireless SB3, Denon DRA-F101, Mission M31 loudspeakers
    WinXP SP2 Slimserver, SMC WBR14g router
    http://www.last.fm/user/nicketynick/

  7. #7
    Senior Member
    Join Date
    Sep 2005
    Location
    Kingston, Ontario
    Posts
    773
    Hmmm..... can't find where McAfee allows me to ignore specific file types - I can scan "all files", or "Program files and documents only". Not sure if this is very helpful....
    Has anybody else tried to do this with McAfee? It's McAfee Security Center 7.2
    Wireless SB3, Denon DRA-F101, Mission M31 loudspeakers
    WinXP SP2 Slimserver, SMC WBR14g router
    http://www.last.fm/user/nicketynick/

  8. #8
    Senior Member
    Join Date
    Sep 2005
    Location
    Kingston, Ontario
    Posts
    773

    DNS refreshing ip???

    I checked my router log to see if I could see anything corresponding to my server magically stopping, and have this:

    2007/03/18 10:14:45 : Wireless MAC address 00:04:E2:F0:B8:03 has connected with the device
    2007/03/18 10:14:38 : Wireless MAC address 00:04:20:06:32:92 has connected with the device
    2007/03/18 10:14:37 : Wireless MAC address 00:04:20:06:33:7A has connected with the device
    2007/03/18 10:14:37 : Secondary DNS address x.x.x.x
    2007/03/18 10:14:37 : Primary DNS address x.x.x.x
    2007/03/18 10:14:37 : local Secondary DNS address x.x.x.x
    2007/03/18 10:14:37 : local Primary DNS address x.x.x.x
    2007/03/18 10:14:37 : local IP address x.x.x.x
    2007/03/18 10:14:37 : Username and Password : OK
    2007/03/18 10:14:37 : PPPoE starts PPP...
    2007/03/18 10:14:37 : PPPoE receive PADS
    2007/03/18 10:14:37 : PPPoE sending PADR
    2007/03/18 10:14:37 : PPPoE receive PADO
    2007/03/18 10:14:25 : PPPoE sending PADI
    2007/03/18 10:14:25 : WLAN TEST....................PASS
    2007/03/18 10:14:25 : WAN ETHER TEST...........PASS
    2007/03/18 10:14:25 : FLASH TEST....................PASS
    2007/03/18 10:14:25 : DRAM TEST.....................PASS
    2007/03/18 10:14:25 : PPPoE sending PADI
    2007/03/18 10:14:25 : PPPoE Start...

    I've x-ed out the ip's - I hope leaving the MACs is OK - but you lot are trustworthy anyway! The MACs include both SB3s and the server-machine, but it won't reconnect since the server is mysteriously stopped!

    Anyway, all that I can think that I've done to cause things to behave differently than before is open the ports through the firewall to troubleshoot remote access. Does this make any sense? What else would cause the server to stop when the ip refreshes?
    Any thoughts appreciated!
    Thanks,
    Nick
    Wireless SB3, Denon DRA-F101, Mission M31 loudspeakers
    WinXP SP2 Slimserver, SMC WBR14g router
    http://www.last.fm/user/nicketynick/

  9. #9
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,992
    Did you check the C:\Program Files\SlimServer\server\Cache\mysql-error-txt.log file to see if there any interesting messages.

  10. #10
    Senior Member
    Join Date
    Sep 2005
    Location
    Kingston, Ontario
    Posts
    773
    Quote Originally Posted by bpa View Post
    Did you check the C:\Program Files\SlimServer\server\Cache\mysql-error-txt.log file to see if there any interesting messages.
    Thanks bpa - searching for that file right now - does it disappear/re-write when the server is restarted? ie. do I have to wait for it to stop again before I can find this file?
    Wireless SB3, Denon DRA-F101, Mission M31 loudspeakers
    WinXP SP2 Slimserver, SMC WBR14g router
    http://www.last.fm/user/nicketynick/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •