Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7
  1. #1

    Problems with Rhapsody

    I am having problems switching between Rhapsody and Squeezebox. After upgrading to 6.5.1 everything seemed to be okay until this evening. Now everytime I try to switch between the two I am asked to upgrade my firmware. This is exactly why I switched to 6.5.1(Lord knows it wasn't the stability provided by the new firmware). Any ideas how I can prevent this?

  2. #2
    NOT a Slim Devices Employee kdf's Avatar
    Join Date
    Apr 2005
    Posts
    9,493

    Problems with Rhapsody

    The firmware was upgraded to fix some playback issues, some involving
    Rhapsody. This firmware is also included with the 6.5.2 builds found
    here:

    http://www.slimdevices.com/dev_nightly.html
    -kdf


  3. #3
    I understand the upgrades but why can I no longer switch between Rhapsody and slimserver without upgrading firmware every time? Things have been working fine until last night and I have changed no settings so I can't figure out what to do next.

  4. #4
    Former Squeezebox Guy andyg's Avatar
    Join Date
    Jan 2006
    Location
    Pittsburgh, PA
    Posts
    7,396
    We have two options when it comes to Rhapsody firmware bugs:

    1. Don't fix the bug until we can test and release 6.5.2.
    2. Fix the bugs ASAP and cause a firmware mismatch between the latest released 6.5.1 and SN.

    We chose #2 because the Rhapsody bugs were pretty serious, and we figured people would rather play Rhapsody without crashing.

    If the firmware mismatch bothers you, you can install 6.5.2 which should be just as stable as 6.5.1.

  5. #5
    Thanks. That is exactly what I will do. I didn't realize that the upgrade was necessary to resolve the situation. I have not had any problems with 6.5.1 so hopefully the same will hold true for 6.5.2.

  6. #6
    Senior Member
    Join Date
    Nov 2005
    Location
    Berlin, DE
    Posts
    1,904
    Quote Originally Posted by andyg View Post
    We have two options when it comes to Rhapsody firmware bugs:

    1. Don't fix the bug until we can test and release 6.5.2.
    2. Fix the bugs ASAP and cause a firmware mismatch between the latest released 6.5.1 and SN.

    We chose #2 because the Rhapsody bugs were pretty serious, and we figured people would rather play Rhapsody without crashing.

    If the firmware mismatch bothers you, you can install 6.5.2 which should be just as stable as 6.5.1.
    Or you could drop the updated firmware into the Firmware/ directory on your 6.5.1 slimserver, that way you don't have to upgrade to a nightly release.

  7. #7
    Senior Member
    Join Date
    Oct 2005
    Posts
    7,103
    Quote Originally Posted by SuperQ View Post
    Or you could drop the updated firmware into the Firmware/ directory on your 6.5.1 slimserver, that way you don't have to upgrade to a nightly release.
    Careful...that will probably work in this case but it may not always work. Certain SlimServer versions are paired with a certain firmware version, using combinations outside of this may produce unpredictable behavior.

    In this case it'll probably work fine as the firmware changes affect only Rhapsody, but don't try this with the latest firmware and something before SlimServer 6.5.0.
    Current: SB2, Boom (PQP3 - late beta, PQP1 - early beta), SBC (early beta), Squeezebox Radio (PB1 - early beta), Squeezebox Touch (late beta)
    Selling: Transporter
    Sold: SB3, Duet

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •