Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Junior Member
    Join Date
    Aug 2006
    Posts
    18

    Radio Stations Playing but Music Files Arn't

    Hi,

    This is a bit weird and I'm sure its probably a Windows XP / OS fluck up but do any of you have any ideas please?

    All was fine Ive had no problems innearly a year and have two squeeseboxes. The other day I foolishly installed a new version Windows of Media Player on my PC. Anyway I coudn't get it to do what I wanted so I uninstalled it . Since that point Ive had no problems playing radio stations but if I try to play a music file slimserver says its playing it and the squeezbox shows its title and scrolls 'now playing, track title ect' Only it isn't actually playing? Its just holding it at the start of the track and doing nothing in silence.

    I have taken my PC back to an earlier restore point and just in case installed the new version of slimserver (6.5.1) and updated firmware on my slimservers. I've even done a special dance but no luck.

    Its really annoying..... Has this or anything similar happened to you?

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Posts
    7,103
    I think something similar was happening here:

    http://forums.slimdevices.com/showthread.php?t=32651
    Current: SB2, Boom (PQP3 - late beta, PQP1 - early beta), SBC (early beta), Squeezebox Radio (PB1 - early beta), Squeezebox Touch (late beta)
    Selling: Transporter
    Sold: SB3, Duet

  3. #3
    Junior Member
    Join Date
    Aug 2006
    Posts
    18
    Thanks Mark I will try that tonight. It did stop working before I installed the new server though and before the XP rollback.

    You never though these creatures are funny things.. will let you know.

  4. #4
    Junior Member
    Join Date
    Aug 2006
    Posts
    18

    Still Have Music File Playing Problems..

    Hi,

    This problem is still with me. Radio is fine. New recordings are fine. All my music files recorded last year simply wont play.

    The fix of replacing the socketwrapper did work... for a while then the problem re-occured for no apparent reason.

    So I 'repaired-re-installed' my copy of XP and re-installed slimserver etc and that fixed it... and then it re-occured again nearly immediately.

    So I then re-stalled Win XP completely from scratch but the problem is still there on the new install. It's absolutely vexing.

    I've rolled back numerous full versions of slim server (and socketwrappers)and it makes no difference.

    I belive that its affecting all of the music files that were originally recorded using ITunes (whih is 210 out of 214 albums! Music Files that I recently added using FLAC / Winamp are fine as well as any radio streaming

    Any final suggestions as I really dont want to re-encode all my albums.. ? especially as a good many of them came off CD's that left with the ex.... I cant really ask to borrow them all again now can I.

    -T

  5. #5
    Senior Member
    Join Date
    Feb 2007
    Posts
    489
    If you problem is only with m4a files, then the maybe it is related to the transcoding ?

    http://wiki.slimdevices.com/index.cgi?Transcoding
    http://wiki.slimdevices.com/index.cgi?AAC

  6. #6
    Junior Member
    Join Date
    Aug 2006
    Posts
    18

    Ah well

    Hi,

    Thanks for the advice. I followed the links and installed 'Lame' It hasn't worked.

    Still no music. C'mon chaps (and ladies) I know one of you can do this. I'll do anything to get it working again... well .. almost...

    Thanks

    -T

  7. #7
    Senior Member SteveEast's Avatar
    Join Date
    Feb 2006
    Location
    Minneapolis, MN
    Posts
    599
    Try playing the track with the debugging option d_source enabled. Post the results here.

    Steve.

  8. #8
    Junior Member
    Join Date
    Aug 2006
    Posts
    18

    Ok

    Is this enough or would you like more..?

    e
    2007-03-01 23:29:32.4716 Song queue is now 11,10,9,8,7,6,5,4,3,2,1,0,13,12,11,10,9,8,7,6,5,4, 3,2,1,0,13,12,11,10,9,8,7,6,5,4,3,2,1,0,13,12,11,1 0,9,8,7,6,5,4,3,2,1,0,13,12,11,10,9,8,7,6,5,4,3,2, 1,0,13,12,11,10,9,8,7,6,5,4,3,2,1,0,13,12,11,10,9, 8,7,6,5,4,3,2,1,0,13,12,11,10,9,8,7,6,5,4,3,2,1,0, 13,12,11,10,9,8,7,6,5,4,3,2,1,0,13,12,11,10,9,8,7, 6,5,4,3,2,1,0,13,12,11,10,9,8,7,6,5,4,3,2,1,0,13,1 2,11,10,9,8,7,6,5,4,3,2,1,0,13,12,11,10,9,8,7,6,5, 4,3,2,1,0,13,12,11,10,9,8,7,6,5,4,3,2,1,0,13,12,11 ,10,9,8,7,6,5,4,3,2,1,0,13,12,11,10,9,8,7,6,5,4,3, 2,1,0,13,12,11,10,9,8,7,6,5,4,3,2,1,0,13,12,11,10, 9,8,7,6,5,4,3,2,1,0,13,12,11,10,9,8,7,6,5,4,3,2,1, 0,13,12,11,10,9,8,7,6,5,4,3,2,1,0,13,12,11,10,9,8, 7,6,5,4,3,2,1,0,13,12,11,10,9,8,7,6,5,4,3,2,1,0,13 ,12,11,10,9,8,7,6,5,4,3,2,1,0,13,12,11,10,9,8,7,6, 5,4,3,2,1,0,13,12,11,10,9,8,7,6,5,4,3,2,1,0,13,12, 11,10,9,8,7,6,5,4,3,2,1,0,13,12,11,10,9,8,7,6,5,4, 3,2,1,0
    2007-03-01 23:29:32.4718 **skipahead: restarting
    2007-03-01 23:29:32.4719 00:04:20:07:3c:88: Switching to mode play from playout-play
    2007-03-01 23:29:32.4768 openSong on: file:///C:/Documents%20and%20Settings/Tristan/My%20Documents/My%20Music/Base%20Ibiza%202004%20(Disc%202)/2-12%20Dancin%20(Fuzzy%20Hair%20Mix).m4a
    2007-03-01 23:29:32.4779 openSong: duration: [298] size: [4766738] endian [] offset: [0] for file:///C:/Documents%20and%20Settings/Tristan/My%20Documents/My%20Music/Base%20Ibiza%202004%20(Disc%202)/2-12%20Dancin%20(Fuzzy%20Hair%20Mix).m4a
    2007-03-01 23:29:32.4785 undermax = 1, type = mov, squeezebox2 = 00:04:20:07:3c:88
    2007-03-01 23:29:32.4787 checking formats for: mov-wma-squeezebox2-00:04:20:07:3c:88
    2007-03-01 23:29:32.4788 checking formats for: mov-wma-*-00:04:20:07:3c:88
    2007-03-01 23:29:32.4789 checking formats for: mov-wma-squeezebox2-*
    2007-03-01 23:29:32.4790 checking formats for: mov-wma-*-*
    2007-03-01 23:29:32.4791 checking formats for: mov-ogg-squeezebox2-00:04:20:07:3c:88
    2007-03-01 23:29:32.4792 checking formats for: mov-ogg-*-00:04:20:07:3c:88
    2007-03-01 23:29:32.4793 checking formats for: mov-ogg-squeezebox2-*
    2007-03-01 23:29:32.4793 checking formats for: mov-ogg-*-*
    2007-03-01 23:29:32.4795 checking formats for: mov-flc-squeezebox2-00:04:20:07:3c:88
    2007-03-01 23:29:32.4795 checking formats for: mov-flc-*-00:04:20:07:3c:88
    2007-03-01 23:29:32.4796 checking formats for: mov-flc-squeezebox2-*
    2007-03-01 23:29:32.4797 checking formats for: mov-flc-*-*
    2007-03-01 23:29:32.4798 Checking to see if mov-flc-*-* is enabled
    2007-03-01 23:29:32.4799 enabled
    2007-03-01 23:29:32.4800 Found command: [mov123] $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 -
    2007-03-01 23:29:32.4802 Matched Format: flc Type: mov Command: [mov123] $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 -
    2007-03-01 23:29:32.4803 openSong: this is an mov file: file:///C:/Documents%20and%20Settings/Tristan/My%20Documents/My%20Music/Base%20Ibiza%202004%20(Disc%202)/2-12%20Dancin%20(Fuzzy%20Hair%20Mix).m4a
    2007-03-01 23:29:32.4803 file type: mov format: flc inrate: 125 maxRate: 0
    2007-03-01 23:29:32.4804 command: [mov123] $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 -
    2007-03-01 23:29:32.4814 Using command for conversion: "C:\PROGRA~1\SLIMSE~1\server\Bin\MSWin32-x86-multi-thread\mov123.exe" "C:\Documents and Settings\Tristan\My Documents\My Music\Base Ibiza 2004 (Disc 2)\2-12 Dancin (Fuzzy Hair Mix).m4a" | "C:\PROGRA~1\SLIMSE~1\server\Bin\MSWin32-x86-multi-thread\flac.exe" -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 - |
    2007-03-01 23:29:32.4831 Launching process with command: "C:\PROGRA~1\SLIMSE~1\server\Bin\MSWin32-x86-multi-thread\socketwrapper.exe" -o 1106 -c "\"C:\PROGRA~1\SLIMSE~1\server\Bin\MSWin32-x86-multi-thread\mov123.exe\" \"C:\Documents and Settings\Tristan\My Documents\My Music\Base Ibiza 2004 (Disc 2)\2-12 Dancin (Fuzzy Hair Mix).m4a\" | \"C:\PROGRA~1\SLIMSE~1\server\Bin\MSWin32-x86-multi-thread\flac.exe\" -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 - |"
    2007-03-01 23:29:32.4862 openSong: Streaming with format: flc
    2007-03-01 23:29:32.5197 00:04:20:07:3c:88 New play mode: play
    2007-03-01 23:29:32.5268 00:04:20:07:3c:88: Current playmode: play
    2007-03-01 23:29:32.5290 Pipeline reader connected
    2007-03-01 23:29:32.5379 readlen undef: (Unknown error)10054
    2007-03-01 23:29:32.5381 end of file or error on socket, opening next song, (song pos: 0(tell says: . 0), totalbytes: 0)
    2007-03-01 23:29:32.5382 Didn't stream any bytes for this song, so just mark it as played
    2007-03-01 23:29:32.5383 opening next song...
    2007-03-01 23:29:32.5389 the next song is number 12, was 11
    2007-03-01 23:29:32.5395 undermax = 1, type = mov, squeezebox2 = 00:04:20:07:3c:88
    2007-03-01 23:29:32.5397 checking formats for: mov-wma-squeezebox2-00:04:20:07:3c:88
    2007-03-01 23:29:32.5398 checking formats for: mov-wma-*-00:04:20:07:3c:88
    2007-03-01 23:29:32.5399 checking formats for: mov-wma-squeezebox2-*
    2007-03-01 23:29:32.5400 checking formats for: mov-wma-*-*
    2007-03-01 23:29:32.5401 checking formats for: mov-ogg-squeezebox2-00:04:20:07:3c:88
    2007-03-01 23:29:32.5402 checking formats for: mov-ogg-*-00:04:20:07:3c:88
    2007-03-01 23:29:32.5403 checking formats for: mov-ogg-squeezebox2-*
    2007-03-01 23:29:32.5404 checking formats for: mov-ogg-*-*
    2007-03-01 23:29:32.5405 checking formats for: mov-flc-squeezebox2-00:04:20:07:3c:88
    2007-03-01 23:29:32.5406 checking formats for: mov-flc-*-00:04:20:07:3c:88
    2007-03-01 23:29:32.5407 checking formats for: mov-flc-squeezebox2-*
    2007-03-01 23:29:32.5407 checking formats for: mov-flc-*-*
    2007-03-01 23:29:32.5408 Checking to see if mov-flc-*-* is enabled
    2007-03-01 23:29:32.5409 enabled
    2007-03-01 23:29:32.5410 Found command: [mov123] $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 -
    2007-03-01 23:29:32.5412 Matched Format: flc Type: mov Command: [mov123] $FILE$ | [flac] -cs --totally-silent --compression-level-0 --endian big --sign signed --channels 2 --bps 16 --sample-rate 44100 -
    2007-03-01 23:29:32.5413 playing out before starting next song. (old format: flc, new: flc)
    2007-03-01 23:29:32.5415 00:04:20:07:3c:88: Switching to mode playout-play from play
    2007-03-01 23:29:32.5417 00:04:20:07:3c:88 New play mode: playout-play
    2007-03-01 23:29:32.5426 00:04:20:07:3c:88: Current playmode: playout-play
    2007-03-01 23:29:32.5427 No pending chunks - we're dropping the streaming connection
    2007-03-01 23:29:32.5432 00:04:20:07:3c:88: Can't opennext, returning no chunk.
    2007-03-01 23:29:32.5485 00:04:20:07:3c:88: Decoder underrun while this mode: playout-play
    2007-03-01 23:29:32.5487 the next song is number 12, was 11
    2007-03-01 23:29:32.5490 **skipahead: opening next song
    2007-03-01 23:29:32.5491 opening next song...
    2007-03-01 23:29:32.5492 the next song is number 12, was 11
    2007-03-01 23:29:32.5497 undermax = 1, type = mov, squeezebox2 = 00:04:20:07:3c:88
    2007-03-01 23:29:32.5500 checking formats for: mov-wma-squeezebox2-00:04:20:07:3c:88
    2007-03-01 23:29:32.5501 checking formats for: mov-wma-*-00:04:20:07:3c:88
    2007-03-01 23:29:32.5501 checking formats for: mov-wma-squeezebox2-*
    2007-03-01 23:29:32.5502 checking formats for: mov-wma-*-*
    2007-03-01 23:29:32.5503 checking formats for: mov-ogg-squeezebox2-00:04:20:07:3c:88
    2007-03-01 23:29:32.5504 checking formats for: mov-ogg-*-00:04:20:07:3c:88
    2007-03-01 23:29:32.5505 checking formats for: mov-ogg-squeezebox2-*
    2007-03-01 23:29:32.5506 checking formats for: mov-ogg-*-*
    2007-03-01 23:29:32.5507 checking formats for: mov-flc-squeezebox2-00:04:20:07:3c:88
    2007-03-01 23:29:32.5508 checking formats for: mov-flc-*-00:04:20:07:3c:88
    2007-03-01 23:29:32.5509 checking formats for: mov-flc-squeezebox2-*
    2007-03-01 23:29:32.5510 checking formats for: mov-flc-*-*
    2007-03-01 23:29:32.5511 Checking to see if mov-flc-*-* is enabled
    2007-03-01 23:29:32.5511 enabled

  9. #9
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,990
    The error in your log
    Code:
    2007-03-01 23:29:32.5290 Pipeline reader connected
    2007-03-01 23:29:32.5379 readlen undef: (Unknown error)10054
    This is typical of security s/w (e.g. Firewall AV) blocking socketwrapper from working. The Ian Cook revised socketwrapper fixes this problem for many users but sometimes it is a case of adding entries in the security s/w.

    What security s/w are you using ? Norton, NOD32, McAfee, ZoneAlarm ?

  10. #10
    Junior Member
    Join Date
    Aug 2006
    Posts
    18

    Hmm

    Hi, Thanks,

    Im using none of those. I'm using (Grisoft)AVG Free edition. Which I was using before this happened. I haven't installed any other blockers though of course Win XP is using its firewall.

    As I said before though it may not be relevant to your point some files eg. new ones taken from CD using Flac are working.

    Closer?

    -T

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •