Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Dec 2006
    Posts
    4

    error starting 6.5

    I get the following error when trying to run ./slimserver.pl:

    slimserver@KURO-BOX:/usr/local/SlimServer_v6.5.0$ ./slimserver.pl
    070126 13:48:23 [ERROR] Error message file '/usr/local/SlimServer_v6.5.0/MySQL/errmsg.sys' had only 463 error messages,
    but it should contain at least 472 error messages.
    Check that the above file is the right version for this program!
    070126 13:48:23 [ERROR] Aborting

    Any ideas?

    Thanks!

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,002

    error starting 6.5

    > '/usr/local/SlimServer_v6.5.0/MySQL/errmsg.sys' had only 463 error
    > messages,
    > but it should contain at least 472 error messages.
    > Check that the above file is the right version for this program!


    Did you do this? How did you install?

    --

    Michael

    -----------------------------------------------------------------
    http://www.herger.net/SlimCD - your SlimServer on a CD
    http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

  3. #3
    Junior Member
    Join Date
    Dec 2006
    Posts
    4
    I installed this from the perl source code tar.gz archive. I'm not sure if there was anything else that needs to be done.

  4. #4
    formerly known as Fletch
    Join Date
    May 2005
    Posts
    2,245
    Quote Originally Posted by dbgurevich View Post
    I get the following error when trying to run ./slimserver.pl:

    slimserver@KURO-BOX:/usr/local/SlimServer_v6.5.0$ ./slimserver.pl
    070126 13:48:23 [ERROR] Error message file '/usr/local/SlimServer_v6.5.0/MySQL/errmsg.sys' had only 463 error messages,
    but it should contain at least 472 error messages.
    Check that the above file is the right version for this program!
    070126 13:48:23 [ERROR] Aborting
    Is this x86_64?

    Find the system version of errmsg.sys (probably in /usr/share/mysql/english) and copy it to /usr/local/SlimServer_v6.5.0/MySQL/.

  5. #5
    Junior Member
    Join Date
    Dec 2006
    Posts
    4
    Hi,
    This is a PowerPC CPU (MPC 8241 (MPC8241LZQ266D)). So maybe the message file has to be CPU-specific? I'll try to look into this...
    Thank you very much for the suggestion.
    --
    david

  6. #6
    formerly known as Fletch
    Join Date
    May 2005
    Posts
    2,245
    Quote Originally Posted by dbgurevich View Post
    This is a PowerPC CPU (MPC 8241 (MPC8241LZQ266D)). So maybe the message file has to be CPU-specific? I'll try to look into this...
    This is a bug that affects non-i386, I was just guessing x86_64. BTW, I reported this last week as http://bugs.slimdevices.com/show_bug.cgi?id=4615.

    The solution I posted earlier should solve the problem.

  7. #7
    Junior Member
    Join Date
    Dec 2006
    Posts
    4
    Yes, this was the problem and the solution. I copied the errmsg.sys from the mysql installation (the one I compiled from source for this platform) into the slimserver/MySql directory and it solved the problem. Thanks!

  8. #8
    Junior Member
    Join Date
    Apr 2006
    Posts
    7
    A big shouted THANK YOU for this thread.

    Just got my Mac Mini working after ages of hair tearing, ready for my 5 yr olds party when it stops scanning. (party started and 30000 track to scan!)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •