Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1

    Debian & Slimserver

    Hi

    I used to run slimserver on my windows workstation, but now i built a Debian server, ok here is the problem:

    1. I downloaded the .rpm file from slimdevices.com,
    2. alien -i .rpm file
    3. manually started slimserver.pl
    problem, how do i make this server starts automaticly?
    and is this the correct way to install slimserver?

    My setup:
    Debian 312, 2 external NTFS USB HD with music.

  2. #2
    Junior Member
    Join Date
    Apr 2005
    Posts
    5
    If you don't mind running the latest 6.5 Beta version (which seems pretty stable now), you could just install the Debian version directly from the repository.

    Add the following line to your /etc/apt/sources.list file:

    deb http://debian.slimdevices.com stable main

    then:

    sudo apt-get update
    sudo apt-get install slimserver

    (perform as root rather than use sudo if you prefer).

    This should set up the startup scripts for you so that the server starts on boot. You can manually start up with:

    sudo /etc/init.d/slimserver start

  3. #3
    Quote Originally Posted by kjolley
    If you don't mind running the latest 6.5 Beta version (which seems pretty stable now), you could just install the Debian version directly from the repository.

    Add the following line to your /etc/apt/sources.list file:

    deb http://debian.slimdevices.com stable main

    then:

    sudo apt-get update
    sudo apt-get install slimserver

    (perform as root rather than use sudo if you prefer).

    This should set up the startup scripts for you so that the server starts on boot. You can manually start up with:

    sudo /etc/init.d/slimserver start
    Thanks for fast reply.

    How do i remove the one i installed with alien -i .rpm?

  4. #4
    Junior Member
    Join Date
    Apr 2005
    Posts
    5
    You should be able to get rid of it with:

    sudo apt-get remove slimserver

  5. #5
    Quote Originally Posted by kjolley
    You should be able to get rid of it with:

    sudo apt-get remove slimserver
    Ok

    Now i removed slimserver
    Code:
    apt-get remove slimserver
    then i installed it from apt-get
    Code:
    apt-get install slimserver
    everything went great installing.

    then i started my web browser and did server:9000 and
    slimserver page got up. but when i was selecting the
    music folder /mnt/mp3/musikk i git this up:
    New value for Music Folder rejected:

    Oops - "/mnt/mp3/musikk" doesn't seem to be a valid directory. Try again.

    Code:
    b--ill:/mnt/mp3# ls -al
    totalt 8
    dr-x------  1 root root   4096 2006-07-26 21:53 .
    drwxr-xr-x  4 root root   4096 2004-01-01 21:03 ..
    dr-x------  1 root root 110592 2006-07-23 14:13 musikk
    dr-x------  1 root root      0 2006-06-04 22:43 RECYCLER
    dr-x------  1 root root   4096 2006-06-04 21:40 System Volume Information
    b--ill:/mnt/mp3#
    and all the files are in there..

    any clue on what to do now, i just played with slimserver, so there should be nothing wrong with my music.

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,666

    Re: Debian & Slimserver

    > dr-x------ 1 root root 110592 2006-07-23 14:13 musikk

    Only root is allowed to access that folder. You'll have to add something
    like "mode=777" to the mount's option string for the disks.

    --

    Michael

    -----------------------------------------------------------
    Help translate SlimServer by using the
    StringEditor Plugin (http://www.herger.net/slim/)

  7. #7
    Quote Originally Posted by mherger
    > dr-x------ 1 root root 110592 2006-07-23 14:13 musikk

    Only root is allowed to access that folder. You'll have to add something
    like "mode=777" to the mount's option string for the disks.

    --

    Michael

    -----------------------------------------------------------
    Help translate SlimServer by using the
    StringEditor Plugin (http://www.herger.net/slim/)

    I solved it with put the external hd back in my XP workstation and mv all mp3s to /mp3/ instead of /mp3/musikk/

    I havent tested that "mode=777".

    But do you know how to get the external hds to auto mount, as i don't want them powered on all the time, i tried through /etc/fstab with these lines:
    Code:
    /dev/sda1       /mnt/film       auto    rw,users,auto,umask=0222 0 0
    /dev/sdb1       /mnt/mp3        auto    rw,users,auto,umask=0222 0 0
    But no luck.. :/

  8. #8
    Member aweller's Avatar
    Join Date
    Aug 2006
    Location
    Fremantle, Australia
    Posts
    43
    I am having a similar problem: after recently upgrading to Ubuntu Dapper my music folder is rejected:

    "New value for Music Folder rejected:
    Oops - "/media/LACIE/Media/Music" doesn't seem to be a valid directory. Try again."

    I added following the line to my /etc/apt/sources.list file:

    deb http://debian.slimdevices.com stable main

    then did:

    sudo aptitude update
    sudo aptitude install slimserver

    and it has installed (6.5b1) with all dependencies and starts without any problems. I have also tried running it though Firefox as root with "sudo firefox" to no effect.

    I have noticed though that I have no "/etc/slimserver.pref" file - perhaps this is my problem?!?

    Thanks, Andy

  9. #9
    Senior Member snarlydwarf's Avatar
    Join Date
    Jul 2005
    Location
    Oregon
    Posts
    3,674
    If you're using the 6.5b1 deb, the preference file is in /etc/slimserver/

    As for why you are getting an invalid directory, what does 'ls -l /media/LACIE/Media/Music' say? Are you sure that directory is correct and readable by the user 'slimserver'?

  10. #10
    Member aweller's Avatar
    Join Date
    Aug 2006
    Location
    Fremantle, Australia
    Posts
    43
    OK, I see '/etc/slimserver/' now with pref file.

    'ls -l /media/LACIE/Media/Music' is correct - it just lists all my music folders, no problem.

    Whether it's readable by user 'slimserver' - ah?! I have no idea?! Do I need to create a 'slimserver' user?

    OK, just checked... In System>Administration>Users and Groups user 'slimserver' is listed. If I edit and allow this user 'Enable access to external storage devices automatically' and 'Execute system administration tasks' still nothing:

    "New value for Music Folder rejected:
    Oops - "/media/LACIE/Media/Music" doesn't seem to be a valid directory. Try again."

    I should add that my external (Lacie) disk with all my music on is plain old FAT32.

    Strange...?!?
    Last edited by aweller; 2006-08-06 at 08:19.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •