Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Simon Tennant
    Guest

    AlienBBC: "No Items found in playlist"

    I have a problem with the current version of slimserver 6.5b1 on Debian
    working with AlienBBC. When selecting a BBC item to play, there is a
    slight pause and then a message: "No items in playlist" is shown.

    Here's the log:

    > 2006-07-17 14:03:03.9800 PlayableAODItem: Trying to get stream for: http://www.bbc.co.uk/radio/aod/netwo.../live.shtml?fm
    > 2006-07-17 14:03:03.9803 Going to parse: http://www.bbc.co.uk/radio/aod/netwo.../live.shtml?fm
    > 2006-07-17 14:03:03.9804 Trying to open protocol stream for http://www.bbc.co.uk/radio/aod/netwo.../live.shtml?fm
    > 2006-07-17 14:03:03.9805 Found handler for http://www.bbc.co.uk/radio/aod/netwo.../live.shtml?fm - using Slim::Player::Protocols::HTTP
    > 2006-07-17 14:03:04.8319 PlayableAODItem got: http://www.bbc.co.uk/radio4/realplayer/media/fmg2.rpm
    > 2006-07-17 14:03:04.8329 AlienBBC Playing : Radio 4 Listen Live FM(http://www.bbc.co.uk/radio4/realplayer/media/fmg2.rpm)
    > 2006-07-17 14:03:04.8658 00:04:20:09:01:01: Switching to mode stop from stop
    > 2006-07-17 14:03:04.8661 Already in playmode stop : ignoring mode change
    > 2006-07-17 14:03:04.8663 Adding song index 0 to song queue
    > 2006-07-17 14:03:04.8664 Clearing out song queue first
    > 2006-07-17 14:03:04.8665 Song queue is now 0


    The "Switching to mode stop from stop" looks worrying.

    I have checked that mplayer is playable, my convert.conf is setup. The
    firewall is not logging any problems.

    Any ideas on how to further debug this?

    S.
    --
    Simon Tennant ________________ http://imaginator.com/~simon/contact

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,911
    To get more messages try d_plugins and d_source.

    Also try to increase Radio station timeout from 5 to 20 under Server Settings/ Network

  3. #3
    Simon Tennant
    Guest

    Re: AlienBBC: "No Items found in playlist"

    bpa wrote:
    > To get more messages try d_plugins and d_source.


    I was already running with those option - I have however enabled
    d_source_v which shows some extra debugging information although nothing
    that looks like a solutions.

    > Also try to increase Radio station timeout from 5 to 20 under Server
    > Settings/ Network


    The "No items found in playlist" message occurrs within a second of me
    hitting play. Here's the extra debug information encase anyone has an idea:

    > 2006-07-18 11:13:15.9868 PlayableAODItem: Trying to get stream for: http://www.bbc.co.uk/radio/aod/netwo...ria/live.shtml
    > 2006-07-18 11:13:15.9870 Going to parse: http://www.bbc.co.uk/radio/aod/netwo...ria/live.shtml
    > 2006-07-18 11:13:15.9871 Trying to open protocol stream for http://www.bbc.co.uk/radio/aod/netwo...ria/live.shtml
    > 2006-07-18 11:13:15.9872 Found handler for http://www.bbc.co.uk/radio/aod/netwo...ria/live.shtml - using Slim::Player::Protocols::HTTP
    > 2006-07-18 11:13:16.2689 PlayableAODItem got: http://www.bbc.co.uk/england/realmed...io/cumbria.rpm
    > 2006-07-18 11:13:16.2698 AlienBBC Playing : Radio Cumbria Listen Live(http://www.bbc.co.uk/england/realmed...io/cumbria.rpm)
    > 2006-07-18 11:13:16.4179 00:04:20:09:01:01: Switching to mode stop from stop
    > 2006-07-18 11:13:16.4183 Backtrace:
    >
    > frame 0: Slim::Player::Source:laymode (/usr/share/perl5/Slim/Control/Commands.pm line 858)
    > frame 1: Slim::Control::Commands:laylistXitemCommand (/usr/share/perl5/Slim/Control/Request.pm line 1405)
    > frame 2: (eval) (/usr/share/perl5/Slim/Control/Request.pm line 1405)
    > frame 3: Slim::Control::Request::execute (/usr/share/perl5/Slim/Control/Request.pm line 731)
    > frame 4: Slim::Control::Request::executeRequest (/usr/share/slimserver/Plugins/Alien/Plugin.pm line 840)
    > frame 5: Plugins::Alien::Plugin:lay (/usr/share/slimserver/Plugins/Alien/Plugin.pm line 617)
    > frame 6: Plugins::Alien::Plugin::__ANON__ (/usr/share/perl5/Slim/Hardware/IR.pm line 737)
    > frame 7: Slim::Hardware::IR::executeButton (/usr/share/perl5/Slim/Control/Commands.pm line 141)
    > frame 8: Slim::Control::Commands::buttonCommand (/usr/share/perl5/Slim/Control/Request.pm line 1405)
    > frame 9: (eval) (/usr/share/perl5/Slim/Control/Request.pm line 1405)
    > frame 10: Slim::Control::Request::execute (/usr/share/perl5/Slim/Control/Request.pm line 731)
    > frame 11: Slim::Control::Request::executeRequest (/usr/share/perl5/Slim/Player/Client.pm line 1012)
    > frame 12: Slim::Player::Client::execute (/usr/share/perl5/Slim/Hardware/IR.pm line 750)
    > frame 13: Slim::Hardware::IR:rocessCode (/usr/share/perl5/Slim/Hardware/IR.pm line 613)
    > frame 14: Slim::Hardware::IR::releaseCode (/usr/share/perl5/Slim/Hardware/IR.pm line 501)
    > frame 15: Slim::Hardware::IR::checkRelease (/usr/share/perl5/Slim/Utils/Timers.pm line 143)
    > frame 16: Slim::Utils::Timers::checkTimers (/usr/sbin/slimserver line 502)
    > frame 17: main::idle (/usr/sbin/slimserver line 452)
    > frame 18: main::main (/usr/sbin/slimserver line 1048)
    >
    > 2006-07-18 11:13:16.4183 Already in playmode stop : ignoring mode change
    > 2006-07-18 11:13:16.4185 Adding song index 0 to song queue
    > 2006-07-18 11:13:16.4186 Clearing out song queue first
    > 2006-07-18 11:13:16.4186 Song queue is now 0
    > 2006-07-18 11:13:16.6567 Adding song index 0 to song queue
    > 2006-07-18 11:13:16.6569 Clearing out song queue first
    > 2006-07-18 11:13:16.6570 Song queue is now 0


    S.

    --
    Simon Tennant ________________ http://imaginator.com/~simon/contact

  4. #4
    Simon Tennant
    Guest

    Re: AlienBBC: "No Items found in playlist"

    Simon Tennant wrote:
    > blah blah blah


    Apologies for following up my own post: Looks like my problem was with
    mplayer:

    > /opt/mplayer/bin/mplayer -vo null http://www.bbc.co.uk/radio4/realplayer/media/fmg2.rpm [11:29am/07-18-06]
    > MPlayer dev-CVS-060108-13:50-4.0.3 (C) 2000-2006 MPlayer Team
    > CPU: Advanced Micro Devices Athlon 64 Newcastle,Winchester,San Diego,Venice; Sempron Palermo (Family: 15, Stepping: 2)
    > SSE2 supported but disabled
    > 3DNow supported but disabled
    > 3DNowExt supported but disabled
    > CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
    > Compiled for x86 CPU with extensions: MMX MMX2 SSE
    >
    >
    > Linux RTC init error in ioctl (rtc_irqp_set 1024): Invalid argument
    > Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
    > Playing http://www.bbc.co.uk/radio4/realplayer/media/fmg2.rpm.
    > STREAM_HTTP(1), URL: http://www.bbc.co.uk/radio4/realplayer/media/fmg2.rpm
    > Resolving www.bbc.co.uk for AF_INET6...
    > Couldn't resolve name for AF_INET6: www.bbc.co.uk
    > Resolving www.bbc.co.uk for AF_INET...
    > Connecting to server www.bbc.co.uk[212.58.227.75]: 80...
    > Cache size set to 320 KBytes
    > Cache fill: 0.02% (73 bytes)
    > Win32 LoadLibrary failed to load: avisynth.dll, /usr/lib/win32/avisynth.dll, /usr/local/lib/win32/avisynth.dll
    >
    >
    > Exiting... (End of file)


    But where to get avisynth for debian? Anyone have it showing up as a
    package?

    S.
    --
    Simon Tennant ________________ http://imaginator.com/~simon/contact

  5. #5
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,911
    A couple of things:

    1. The avisynth error is because you are trying to play a playlist - this is the proper version of your command
    Code:
    /opt/mplayer/bin/mplayer -vo null -cache 128 -playlist http://www.bbc.co.uk/radio4/realplayer/media/fmg2.rpm
    This should playback OK unless you haven't loaded the RealAudio codecs library (i.e. racook) which may be required with this version of Mplayer.

    2. Your version of Mplayer is old, it has some bugs and missing features which may affect AlienBBC playback. You should either rebuild to the latest release 1.0pre8 or try a prebuilt version from here
    http://rpm.greysector.net/mplayer/downloads.html

  6. #6
    Simon Tennant
    Guest

    Re: AlienBBC: "No Items found in playlist"

    Thanks BPA.

    > /opt/mplayer/bin/mplayer -vo null -cache 128 -playlist http://www.bbc.co.uk/radio4/realplayer/media/fmg2.rpm


    mplayer playback works fine now. Indeed the version I compiled has
    worked fine in the past too until I decided to re-install the slimserver
    package.

    I have done some more tests and it appears that mplayer.sh is never
    being called by the plugin. Tested by adding a:

    "touch /tmp/slim.test"

    to mplayer.sh.

    Indeed, when I go to play a stream, the failure is instant, too short
    for any external program to be called let alone buffering occurring.

    Should I be seeing an AlienBBC plugin listed in "Server Settings >
    Plugins"? At the moment there is no AlienBBC plugin listed there but
    browsing the AlienBBC menu on the Squeezebox works and I can see the
    plugin parsing the BBC website data.

    S.
    --
    Simon Tennant ________________ http://imaginator.com/~simon/contact

  7. #7
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,911
    Mplayer.sh has some echo statement so that when slimserver is run (not a daemon) from a command line you'll see these messages.

    Assuming slimserver can run other apps (e.g. sox) in the Bin directory, check the ownership and permissions on Mplayer.sh
    in case slimserver is not being allowed to run mplayer.sh.

    There should be an AlienBBC entry in Server Setting to allow the user to enable/disable menus. Since it is not there then I think
    your AlienBBC installation is faulty - this may also be the reason for mplayer.sh not being run.

    To see what might be giving problem, start slimserver from a command line (shell) with the d_plugins and d_source options.

  8. #8
    Simon Tennant
    Guest

    Re: AlienBBC: "No Items found in playlist"

    To follow-up on my previous posts, I had not installed the additions to
    the "types.conf" file. This meant that the slimserver didn't know how
    to interpret the rpm mime type and extract the RTSP stream from within.

    The "No items found in playlist" is now solved.

    Thanks to all for their help.

    s.
    --
    Simon Tennant ________________ http://imaginator.com/~simon/contact

  9. #9
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,911
    That's odd - all the additions are in a file custom-types.conf and it should be installed correctly.

    For 6.3 it should be in the slimserver directory and for 6.5 the file should be in the Alien directory.

  10. #10
    Junior Member
    Join Date
    Sep 2006
    Posts
    5
    Quote Originally Posted by Simon Tennant View Post
    ...I had not installed the additions to
    the "types.conf" file. [/url]
    Help!

    I have the same problem (but I can see AlienBBC in Slimserver.
    I have looked at custom-types.conf and yes the entry for real looks incomplete i.e a ?.
    You seem to have solved this but what did you enter????


    -----------------------------------------------------------
    # AlienBBC types

    ################################################## #######################
    #ID Suffix Mime Content-Type Server File Type#
    ################################################## #######################
    rtsppl rm,ram,rpm ? playlist
    rtsp rtsp: ? audio
    smilpl smil application/smil playlist
    -----------------------------------------------------------------


    SlimServer Version: 6.5.0 - 9916 - Debian - EN - iso-8859-1
    Server IP address: 192.168.1.5
    Perl Version: 5.8.4 i386-linux-thread-multi
    MySQL Version: 4.1.11-Debian_4sarge7

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •