Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1
    Senior Member gbruzzo's Avatar
    Join Date
    Jan 2006
    Location
    London
    Posts
    444

    Problems running slimserver 6.3.0 on Linkstation II

    Hi all,

    I have very recently tried to install slimserver 6.3.0 on the LS II (with mipsel processor) with openlink 0.52b, Devtools and MipselSlimServerModules installed, and have been encountering series of issues.

    1) the slimserver.pl does not start, because there seems to be a perl module missing, that is I get

    Starting SlimServer: The following modules failed to load: Digest::SHA1"

    2) in another part of the forum, it was suggested to run build-perl-modules.pl in \slimserver\Bin : the perl script runs fine until it stops, saying

    Configuring..
    /usr/bin/perl Makefile.PL
    Up/Downgrade complete.
    Building..
    Up/Downgrade complete.
    make: *** [Makefile] Error 1
    Can't stat blib: No such file or directory
    at ./build-perl-modules.pl line 282
    Couldn't find a valid dynamic library for Compress-Zlib-1.33.tar.gz - something
    is wrong. Exiting!

    4) I tried a suggestion given to me, that is to set up a link as follows

    cd /usr/bin
    ln -s gcc cc

    and rerun the perl script.

    5) still, I get the same problem. In another forum, I seem to remember someone pointing out, that "make" maybe missing from my LS II.

    Question: has anyone encountered this specific problem? Has anyone got a suggestion?

    I suspect the main issue may have a lot to do with my misunderstanding of Linux...please be patient!


    Thank you very much in advance,

    Giacomo

  2. #2
    Senior Member aubuti's Avatar
    Join Date
    Oct 2005
    Posts
    8,832
    If you installed the development tools correctly then you should have 'make'. It's hard to figure out where you might have gone wrong, but it's at least easy to confirm whether or not you have make on your system. At the command line type "which make" (without the quotes) and if it responds with something like "/usr/bin/make" then make is installed on your system and the problem lies elsewhere. If it just comes back to the prompt, or says something like "make not found in ......" then you don't have make.

    Good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •