Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    Senior Member Craig's Avatar
    Join Date
    Apr 2005
    Location
    Leeds, UK
    Posts
    867

    Missing Disc # in 6.5

    I just noticed that the track ordering on double albums is messed up. Viewing a track shows that the disc # is not being picked up in 6.5 but it is in 6.2.

    This is with flacs and the tags appear to be ok.

    Craig

  2. #2
    I don't have that problem using 'DISCNUMBER'.

    SlimServer Version: 6.5b1 - 7422 - Windows XP - EN - cp1252

  3. #3
    Senior Member Craig's Avatar
    Join Date
    Apr 2005
    Location
    Leeds, UK
    Posts
    867
    I've always used DISCNUMBER = 1 of 2 and it's worked ok, I've just changed some DISCNUMBER tags to just 1 or 2 and they were picked up as disc # but disc 2 was sorted first !!

    The same files are being read fine in 6.2.2 so something has changed somewhere.

    Craig

  4. #4
    Strange. I just use 'DISCNUMBER = 1' etc., but disc 1 gets displayed first.

    Could this be related to your switch from 6.2 to 6.5? (I think that can make things glitchy--sometimes you have to wipe & rescan or just delete the database outright & rescan. Ugly, I know.)

  5. #5
    Senior Member Craig's Avatar
    Join Date
    Apr 2005
    Location
    Leeds, UK
    Posts
    867
    I have parallel installations of 6.2 and 6.5 so I can switch between them whenever I like,

    I've never had success with DISCNUMBER = 1 though, that's why I took the X of Y approach and it's worked well untill recently.

    Craig

  6. #6
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,548
    Quote Originally Posted by Craig
    I have parallel installations of 6.2 and 6.5 so I can switch between them whenever I like,

    I've never had success with DISCNUMBER = 1 though, that's why I took the X of Y approach and it's worked well untill recently.
    It works as expected for me in 6.5.

    Is it only the "X of Y" albums that are being sorted incorrectly, or is it all multi-disc sets? I wouldn't be amazed if the "X of Y" entries broke something. It's going to be very dependant on how SlimServer decides to parse that, and I wouldn't be surprised if the parsing has changed. I've seen other people use "X/Y" and similar style entries. Putting anything other than a number into a tag where a number is expected is a gamble.

    I use

    DISC=1
    DISCC=2

    DISC=2
    DISCC=2

    I believe it been said that the DISCC (or DISCCOUNT) is ignored by SlimServer.

  7. #7
    Senior Member Craig's Avatar
    Join Date
    Apr 2005
    Location
    Leeds, UK
    Posts
    867
    All my multiple albums are tagged as DISCNUMBER 1 of 2 etc and the tag just isn't showing up anymore.

    I'll change a couple to use DISC as you said and see how it goes.

    Craig

  8. #8
    Senior Member Craig's Avatar
    Join Date
    Apr 2005
    Location
    Leeds, UK
    Posts
    867
    I changed Aerosmith's A Little south of Sanity to use DISC = 1 or 2 and also tried chaging TRACKNUMBER to TRACK.

    The Disc and track numbers are showing up ok in the track info but this is how it is being sorted

    Walk on Down
    Hole in My Soul
    Crazy
    Monkey on My Back
    Livin' on the Edge
    Mama Kin
    Cryin'
    Walk This Way
    Dude (Looks Like a Lady
    Rag Doll
    Angel
    What It Takes
    Janie's Got a Gun
    Sweet Emotion
    Amazing
    Eat the Rich
    Love in an Elevator
    Falling in Love Is Hard on the Knees
    Same Old Song and Dance
    Back in the
    Last Child
    The Other Side


    This is the correct order

    Eat The Rich
    Love In An Elevator
    Falling In Love (Is Hard On The Knees)
    Same Old Song And Dance
    Hole In My Soul
    Monkey On My Back
    Livin' On The Edge
    Cryin'
    Rag Doll
    Angel
    Janie's Got A Gun
    Amazing

    Back In The Saddle
    Last Child
    The Other Side
    Walk On Down
    Dream On
    Crazy
    Mama Kin
    Walk This Way
    Dude (Looks Like A Lady)
    What It Takes
    Sweet Emotion

    Craig

  9. #9
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,548
    Quote Originally Posted by Craig
    I changed Aerosmith's A Little south of Sanity to use DISC = 1 or 2 and also tried chaging TRACKNUMBER to TRACK.

    The Disc and track numbers are showing up ok in the track info but this is how it is being sorted
    I guess maybe we should have asked if disc and track numbers appeared to be correct in the track info. If so, fiddling with tags is probably be a waste of time. It it's already correct, there's nothing to fix in the tags.

    Try a reinstall of 6.5?

  10. #10
    Senior Member Craig's Avatar
    Join Date
    Apr 2005
    Location
    Leeds, UK
    Posts
    867
    Quote Originally Posted by JJZolx
    I guess maybe we should have asked if disc and track numbers appeared to be correct in the track info. If so, fiddling with tags is probably be a waste of time. It it's already correct, there's nothing to fix in the tags.

    Try a reinstall of 6.5?
    Good Point I'll try that but DISCNUMBER 1 of 2 did show up in track info until a few days ago.

    So what is the standard? if there is one?

    TRACKNUMBER 1 -> whatever
    DISC 1
    DISC 2
    DISC 3

    Craig

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •