Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1

    Playing album by track order

    I have been trying to figure out how to configure my SB3 to play albums by track order. Right now, it will play the tracks sorted by title (alphabetically). I want it to play track 1 first, followed by track 2, 3, and so on. How do I set that up? i can't find it in the settings....

    Thanks!

  2. #2
    Senior Member radish's Avatar
    Join Date
    Apr 2005
    Location
    Red Bank, NJ
    Posts
    5,052
    It's not an option, it's how it always works. If it's not doing it for you, you must not have track number tags in your files. What file format/tagger are you using

  3. #3

    Track number is Default?

    Quote Originally Posted by radish
    It's not an option, it's how it always works. If it's not doing it for you, you must not have track number tags in your files. What file format/tagger are you using

    Sorry, I don't understand. Are you saying that the default setting is to play the tracks using the Title sorted alphabetically as a sequence? I am using FLAC, and EAC to convert/tag my CDs...

  4. #4
    Senior Member snarlydwarf's Avatar
    Join Date
    Jul 2005
    Location
    Oregon
    Posts
    3,674
    Well, you need to tell it the order somehow...

    By default, that is 'TRACKNUMBER' on FLAC files.

    If that tag is missing it will fall back to sorting by TITLE.

    (Unless you're using Browse Music Folder.. in that case sorting is based on filename, not what is in the tags at all.)

    It sounds like your FLACs don't have a TRACKNUMBER in them.

    mp3tag (look for the v2.35 one, no the one that is like version 9 or something... two programs with the same name) has an 'auto-number tracks' thing if you need to go back and insert them. (And despite the name, it does do FLAC.)

  5. #5

    Thanks!

    Thanks! I will try that out.

    QUOTE=snarlydwarf]Well, you need to tell it the order somehow...

    By default, that is 'TRACKNUMBER' on FLAC files.

    If that tag is missing it will fall back to sorting by TITLE.

    (Unless you're using Browse Music Folder.. in that case sorting is based on filename, not what is in the tags at all.)

    It sounds like your FLACs don't have a TRACKNUMBER in them.

    mp3tag (look for the v2.35 one, no the one that is like version 9 or something... two programs with the same name) has an 'auto-number tracks' thing if you need to go back and insert them. (And despite the name, it does do FLAC.)[/QUOTE]

  6. #6
    Member
    Join Date
    Dec 2005
    Posts
    34

    Some albums don't play in track order

    Hi,

    some of my albums will not be played in the right order (i.e. as iTunes has imported and tagged them). Some albums will be played in alphabetical order.
    One album will be played song 8-16 first, then song 1-7. I have no clue what is causing this issue. In this case, the song titles do even start with 8-9-10 etc.

    I'm using nightlies on an iBook with 10.4.5.

    -Hans

  7. #7
    Senior Member ceejay's Avatar
    Join Date
    Apr 2005
    Location
    Worcestershire, UK
    Posts
    2,314
    Quote Originally Posted by drhanso
    Hi,

    some of my albums will not be played in the right order (i.e. as iTunes has imported and tagged them). Some albums will be played in alphabetical order.
    One album will be played song 8-16 first, then song 1-7. I have no clue what is causing this issue. In this case, the song titles do even start with 8-9-10 etc.

    I'm using nightlies on an iBook with 10.4.5.

    -Hans
    First, check your track number tags with a separate program like mp3tag.

    Note that if your track titles start with 7-, 8-, 9-, etc then thiese are likely to give you the wrong order as well: should be 01- , 02-, 03- etc

    Finally, how are you getting to the album? Are you using Browse Music Folder, or Browse by Album/Artist etc ?

    Ceejay.

  8. #8
    Member
    Join Date
    Dec 2005
    Posts
    34
    Quote Originally Posted by ceejay
    First, check your track number tags with a separate program like mp3tag.

    Note that if your track titles start with 7-, 8-, 9-, etc then thiese are likely to give you the wrong order as well: should be 01- , 02-, 03- etc

    Finally, how are you getting to the album? Are you using Browse Music Folder, or Browse by Album/Artist etc ?

    Ceejay.
    Almost all of my albums are played correctly. Only some are 'different'. So if an album consists of song '1. my first song' as track one and '2.my second song' as track 2, it should play track 1 and then track 2. Why does it not work for a few albums with SlimServer?
    AND they get displayed in the correct order on the left half of the SlimServer browser window, but as soon as I add them to the playlist on the right side, they are 'reshuffled' somehow. But only for a few albums.

    The tags should be ok as iTunes plays them ok.

    -Hans
    Last edited by drhanso; 2006-03-31 at 14:10.

  9. #9
    Senior Member ceejay's Avatar
    Join Date
    Apr 2005
    Location
    Worcestershire, UK
    Posts
    2,314
    Quote Originally Posted by drhanso
    Almost all of my albums are played correctly. Only some are 'different'. So if an album consists of song '1. my first song' as track one and '2.my second song' as track 2, it should play track 1 and then track 2. Why does it not work for a few albums with SlimServer?
    AND they get displayed in the correct order on the left half of the SlimServer browser window, but as soon as I add them to the playlist on the right side, they are 'reshuffled' somehow. But only for a few albums.

    The tags should be ok as iTunes plays them ok.

    -Hans
    Well, if only "some" of your albums misbehave in this way, there must be something different about them!

    And don't assume that just because iTunes plays them ok, that there isn't something odd about the tags. You really should have a good look at the tags with mp3tag.

    For example, if these are MP3 files, and you have both ID3v1 and ID3v2 tags present, Slimserver gets confused and may well behave differently from iTunes.

    What file type is it?

    Are you browsing by Music Folder, or by Artist/Album?

    Is "shuffle by album" turned off?

    Keep talking, we'll get you sorted out soon enough!

    Ceejay

  10. #10
    Member
    Join Date
    Dec 2005
    Posts
    34
    <<Well, if only "some" of your albums misbehave in this way, there must be something different about them!>>

    I thought so. Today I found that one album gets listed twice, i.e. it contains 16 songs and if I add it to the playlist, SlimServer will add 32 songs, each song twice. I've found this in just one album so far (Les Paul-American made-World Played, bought at allofMP3.com in 180kB VBR).

    <<And don't assume that just because iTunes plays them ok, that there isn't something odd about the tags. You really should have a good look at the tags with mp3tag.>>

    As a mac user (no mp3tag) what else can I do check the tags?

    <<For example, if these are MP3 files, and you have both ID3v1 and ID3v2 tags present, Slimserver gets confused and may well behave differently from iTunes.>>

    The files in question where SlimServer plays song#8 1st, are AAC, encoded with iTunes, so there should be no issue on just a single album.

    <<Are you browsing by Music Folder, or by Artist/Album?>>

    I don't understand that question. I have 'use iTunes' checked and Slim does use my iT playlists, albums, etc. Where can I set the pref you're mentioning?

    <<Is "shuffle by album" turned off?>>

    Yes.

    <<Keep talking, we'll get you sorted out soon enough!>>

    That' what friends are for! Thanks for you help so far.

    -Hans, sunny Bavarian outback.

    /EDIT, half an hour later: The issue is gone after having installed April1 nightly (and the library was started _immediately_. At least that's my guess as perl was eating up all my iBooks CPU cycles for more than 5 minutes). No, no April fool. Both the aforementioned sorting issue plus the double files are gone!
    Plus: If there were playlists or songs in iTunes where the title started with a bullet then Squeezebox3 would display a question mark instead of the bullet. They are displayed correctly now. EDIT/
    Last edited by drhanso; 2006-04-01 at 11:15.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •