Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 9 of 9
  1. #1
    Junior Member
    Join Date
    Apr 2005
    Location
    Sunnyvale, CA
    Posts
    22

    Squeezebox 3 slow to respond to remote control

    Hi,

    I have a squeezebox 3 and i'm running
    SlimServer Version: 6.2.1 - 5194 - Mac OS X 10.4.5 (8H14) - EN - utf8 on a Mac Mini 1.42Gz with 1G of Ram.

    What i have noticed and sometimes it gets more than a little annoying is that i walk over to the Sqb3 and try and change what is playing with the remote. The screen does not move, so i press some more keys, and then all at once the commands all whip past on the display. It's almost like the thing has been buffering up all the commands and then either once it has enough free CPU it runs through them all at once.

    What happens to the commands are they run just within the Sqb3 or are they all passed back to the server ?

  2. #2
    Senior Member
    Join Date
    Jun 2006
    Location
    Colchester, UK
    Posts
    338
    Hi there.

    Just found this after searching for "slow" & "remote"!

    I have the same problem with my Squeezebox 3 and I'm currently at the very latest version of 6.5b. I run a very minimal Linux - Fedora FC 5 with no X-windows on an Epia Via 1Ghz based unit with 512MB of RAM. The problems seems to happen wireless and wired.

    It can be very unresponsive even when nothing obvious seems to be taking system resources. Once I've started to understand some of the debug options, I'll see if I can suss out what's happening.

    Anyone else have any thoughts?

    Cheers,

    Richard

  3. #3
    Senior Member Patrick Dixon's Avatar
    Join Date
    Apr 2005
    Location
    UK
    Posts
    1,805
    See this bug:-

    http://bugs.slimdevices.com/show_bug.cgi?id=2081

    Although marked as 'resolved' I'm not convinced it is.

  4. #4
    Senior Member
    Join Date
    Apr 2005
    Posts
    8,410
    Richard - 6.5 contains code to suppress stored keypresses if they are more than 3 seconds old. Run with --perfwarn=0.5 to see what is taking the resources and post here or on the beta thread. [this doesn't look to be an Alien issue]

    Patrick - I think the official answer is to wait for 6.5. Is the late keycode suppression important to you and if so is a non windows solution worthwhile? If so you could patch/replace the IR.pm file [or could for you..]

  5. #5
    Senior Member Patrick Dixon's Avatar
    Join Date
    Apr 2005
    Location
    UK
    Posts
    1,805
    Quote Originally Posted by Triode
    Patrick - I think the official answer is to wait for 6.5. Is the late keycode suppression important to you and if so is a non windows solution worthwhile? If so you could patch/replace the IR.pm file [or could for you..]
    Indeed Adrian. I'm now using a 2G Althlon 64 so slow response is a thing of the past for me, but I do think it was a mistake not to include your code in 6.3.0 particularly when SD and their agents are promoting fairly low powered NASes running SS.

    Not sure why it's slow on the Mac Mini though.

    For me the actions which took a long time were:-

    Random Play
    Building large Playlists
    Browse Artist or Album - if you have a large library.

    Everything gets worse if you are rescanning the library.

    You learn to wait.
    Last edited by Patrick Dixon; 2006-07-02 at 04:52.

  6. #6
    Hi my second post here so i┤m a newbie to this.

    I have this problem to running v.3 hardware and 6.3 server and win xp.

    But.
    Under Player Settings remote

    I have 2 alt
    1 Slim_Devices_Remote
    2 jvc_dvd

    what┤s jvc_dvd?

    I unmarked "jvc_dvd" and now my remote works flawlessly (used it for an hour or so)

  7. #7
    Senior Member snarlydwarf's Avatar
    Join Date
    Jul 2005
    Location
    Oregon
    Posts
    3,674
    jvc_dvd is the IR codes for a JVC DVD player. This lets you take a cheapo Universal Remote (which probably isn't "trainable" and probably doesn't list the magic code for Slimdevices) and just tell it "I have a JVC DVD player!" .. the remote will send JVC codes, and the server will parse them.

    It works well... unless you have a JVC DVD player.. or a JVC TV.

  8. #8
    Quote Originally Posted by CosyCat View Post
    Hi my second post here so i┤m a newbie to this.

    I have this problem to running v.3 hardware and 6.3 server and win xp.

    But.
    Under Player Settings remote

    I have 2 alt
    1 Slim_Devices_Remote
    2 jvc_dvd

    what┤s jvc_dvd?

    I unmarked "jvc_dvd" and now my remote works flawlessly (used it for an hour or so)

    thank you thank you
    well don e cosy cat
    I fixed slow remote this way too

    cheers dave

  9. #9
    Senior Member
    Join Date
    Jun 2006
    Posts
    749
    To prevent users (like me) from entering extra remote control presses when the SB does not appear to be responding right away, a great feature would be visual feedback on the SB display when a remote command is received, such as flashing a tiny remote control icon or even just a few pixels in a consistent position on the display. I've seen this type of thing on several devices, and I expect it would be fairly trivial for Slim's software/firmware folks to implement it.

    The Squeezebox itself would issue the display icon as soon as it receives an IR command, without having to wait for any response from the Slimserver. It confirms for the user that: a) he or she successfully pressed a button on the remote; b) the batteries in the remote are not dead; and c) the SB received the command OK.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •