Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Mar 2006

    Cannot connect a new squeezebox

    I have just purchased a wireless squeezebox 3 and I am having real problems in connecting it via ethernet and wireless.

    I have a 10mbps D-Link ethernet card for my wired connection, and my wireless setup is a Zoom X6 5590 wireless modem router, with a zoom USB adapter on my PC, 802.11g network.

    I cannot get either the wired or wireless squeeze options to connect, and now after having initially setup the ethernet options, I get an error message saying 'error: ethernet appears disconnected' when trying to setup a wired network. The network cables are attached and I know they work because I have tried them with other devices. I seem to be unable to re-enter the ethernet setup options, where I can specify IP addresses, etc. Reseting to the factory default settings by holding down 'add' whilst powering on the squeezebox does reset the wireless options, but does not seem to reset the ethernet setup procedure.

    I have set up the correct firewall exceptions, and I have also tried totally disabling my firewall, uninstalling norton anti-virus and also removing all excryption from my wireless network, but still no luck. The details in the manual seem a little vague.

    I spent 5 hours yesterday trying to setup the squeezebox, which really seems a long time for such a device. Could anyone please advise me of the correct procedure in order to get my squeezebox working.



  2. #2
    I got my SB3 a few days and also had problems connecting to slimserver. Don't know if this will help your particular case, but it might help someone in the future, so I'll post it anyway.

    Symptoms - SB3 seemed to set itself up fine both via ethernet and wirelessly. It obtained a proper IP address. I could ping it from my Slimserver PC. But it wouldn't link up - it just hung on 'Connecting to Slimserver'. From the router lights I could see that it was talking to the Slimserver PC (and slim.exe was using increased CPU time) but it just wouldn't connect. Strangely, it connected to Squeezenetwork quite happily.

    I tried every combination of everything I could think of, turned off all encryption, deactivated my PC's firewall, my router's firewall, etc. Still nothing. Searched the forums for any clues. Was tearing my hair out.

    About 5 torturous hours later, I stumbled across a post by (IIRC) Michael Herger where he mentioned the 'blocking' control on Slimserver. I'd installed SS on my new server a couple of months ago, well before the arrival of my SB3, and being the sort who verges on paranoia over such matters, had enabled the 'block access except for these IPs' setting. Of course, I'd completely forgotten to go back in and add the IP address my new SB3 was now occupying. Which is presumably why SlimServer was ignoring my SB3's repeated plaintive entreaties to connect. Oh, how I laughed hysterically!

    In hindsight, it wasn't such a bad thing, because I underwent a crash course in wireless networking (first time I'd tried it) and configuring my router - irrelevant as it all turned out to be, it was good to learn a bit about such things. However, given this is a rather elementary yet maddening mistake, I wonder if it might be worth including in the SS FAQ, or something? I suppose I should add it to the Wiki myself. Has anyone contemplated doing some kind of 'Troubleshooting wizard' for all this sort of stuff?

    (PS - thanks Michael, you saved my sanity that night
    Last edited by oktup; 2006-03-17 at 06:18.

  3. #3
    Senior Member Siduhe's Avatar
    Join Date
    Jun 2005
    deepest, darkest, south-east London
    Quote Originally Posted by simonjkendrew
    I seem to be unable to re-enter the ethernet setup options, where I can specify IP addresses, etc. Reseting to the factory default settings by holding down 'add' whilst powering on the squeezebox does reset the wireless options, but does not seem to reset the ethernet setup procedure.
    To get back to the ethernet (wired) set up options, use the left arrow key until the menus won't go back any further, and then scroll down. You should then see the option to set up a wired connection, go right, and all the options should be there by scrolling down. If not, what are the options available to you in your top level networking menu ?

    With your wired connection, I'm a bit confused at which stage you are stuck at. Can the Squeezebox see the SSID of your wireless network and just won't connect to it, or can it not even see the network at all ?

    If the former, it's more likely to be a firewall, router or permissions issue - if the latter, it's more likely to be that your wireless network itself isn't set up right.

    Let us know and we'll do what we can.

    P.S. Is your router listed as one which is known to work with the Squeezebox in the router status pages ?


    P.P.S. Have you tried rebooting the router - that may help with the "ethernet appears to be disconnected" problem.
    Last edited by Siduhe; 2006-03-17 at 06:02.

  4. #4
    Junior Member
    Join Date
    Mar 2006
    I am still having problems trying to connect my squeezebox to my wireless network. Let me explain what I have done so far.

    I have my squeezebox (firmware v35, slimserver 6.2.2) wired into my ADSL gateway, and it can then communicate to my wireless PC through the gateway. This works great.

    However, trying to connect the squeezebox wirelessly is proving troublesome, as the connect option times out after 30 seconds, failing to connect. I have removed all wireless encryption, and have located the squeezebox, the ADSL gateway, and my computer all next to each other, so there can be no signal problems. I have totally uninstalled norton anti-virus, disabled the Windows XP firewall, and opened the 3 required ports on my ADSL gateway. I have turned DHCP off and manually configured my USB wireless adapter and squeezebox. I know the wireless adapter and gateway connect when setup manually, as my PC can still access my internet conenction from the ADSL gateway. When I do a factory default reset on the squeezebox, and then look in the settings, under wireless network, it lists signal strength as 0%, but then once I have entered all the wireless setup options and it times out, I go back into the signal strength and it is between 95%-100%, so am I correct in assuming that the squeezebox is actually detecting my wireless network?

    Here are the settings I am using

    USB Wireless adapter on my PC
    IP address
    Subnet mask
    Default gateway
    DNS server

    IP address
    Subnet mask
    DNS server
    Bridge (wireless to ethernet) No
    MAC address listed is the same as that printed on the bottom of the device

    ADSL gateway
    IP addresses range from to
    The 3 requested ports are opened for the IP address

    Any suggestions please?

  5. #5
    Senior Software Engineer - Logitech/Slim Devices
    Join Date
    Apr 2005
    Ipswich, UK

    You should try the lastest slimserver 6.2.2 nightly, this includes firmware v36. This firmware fixes compatibilty issues with some routers/gateways.

    Please be aware that some issues with WPA are still being worked on. Depending on your router/gateway, if you have problems connected with WPA not using DHCP might work ok.

    If you still have problems could you post the make, model and firmware version of your ASDL gateway.


  6. #6
    Senior Member
    Join Date
    Oct 2005

    One item to note - unfortunately this won't solve the problem, but it'll increase security. Do not port-forward SlimServer's ports in your gateway. Port forwarding is to allow Internet access. It directs external (Internet) port requests to a certain machine's ports on your internal network. It won't help with Squeezebox access at all as both your Squeezebox and your SlimServer are on your internal network. All you've done is opened up three ports to the Internet, which was probably noticed 30 seconds after you opened them.

    Unfortunately your problems seem connected to wireless incompatibility. We can conclude this from the following:

    1. You can connect to SlimServer wired. This means you've handled your IP addresses assignment and firewall configuration correctly.

    2. You can't connect with open encryption. This means you haven't made any errors with passphrases.

    All I can advise at this point is check for new router/gateway firmware and try the latest Squeezebox firmware. Also make sure you have SSID right - enable broadcast and change it to something different to make sure that's the network you're seeing.

    I had the same problem as you and concluded incompatibility between my Squeezebox and my SMC2804WBRP-G router. The options were: return the $450 CDN Squeezebox or get a new $80 router. Obviously I replaced the router, going for a Linksys WRT54G, which worked fine the first time and has continued to work in all modes but WPA2.

    Combined ADSL modem/gateway/routers seem very popular in Europe. I don't know why - it seems to me that multipurpose devices end up being Jack of all trades, master of none. Plus if there comes a need to replace it, your costs are higher.

    So get in touch with Slim Devices support and give them the manufacturer/model number of your ADSL gateway. They are working hard on compatibility, there have been more firmware releases in the last three months than in the entire lifespan of the SB2.

  7. #7
    Junior Member
    Join Date
    Mar 2006



    I've downloaded the latest nightly build, with firmware version 37 and wireless now works, with WPA encryption!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts