Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    Member gerry_duprey's Avatar
    Join Date
    Mar 2006
    Location
    Ann Arbor, MI USA
    Posts
    50

    CLI: "rescan done" notice not sent

    Howdy,

    After issuing a "listen 1" on a CLI connection, I will get a simple "rescan" notice/report when a rescan has been started (in this case, by using the slimserver web interface).

    However, I never receive a "rescan done" notice. Do I need to do something more than "listen 1" to enable receiving "rescan done" messages?

    This is with 6.5b1 6554 (3/11 build)

    Thanks,

    Gerry

  2. #2
    Senior Member
    Join Date
    Jun 2005
    Location
    Switzerland
    Posts
    610
    No. Will look into it.

    Fred

  3. #3
    Senior Member
    Join Date
    Jun 2005
    Location
    Switzerland
    Posts
    610
    Can't reproduce that. What's your config, using iTunes?

    Fred

  4. #4
    Member gerry_duprey's Avatar
    Join Date
    Mar 2006
    Location
    Ann Arbor, MI USA
    Posts
    50
    No itunes -- just one root directory with music (music is organzied in subfolders by artist, then album) and one directory where my M3U playlists is kept.

    My entire session works like this:

    1) telnet 10.0.0.1 9090
    2) type "listen 1" -- "listen 1" is echoed back
    3) type "rescan ?" -- "rescan 0" is echoed back
    4) Press the "Rescan" button on the Web interface
    5) Receive a "rescan" report/notice on the telnet connection
    6) Watch slimserver.pl via "top" until it stops consuming CPU
    7) CPU consumption drops to 0, no report or anything on connection
    8) Issue a "rescan ?" -- "rescan 0" is echoed back confirming it's no longer rescanning

    In terms of the settings, I'm issuing a rescan, but there are no actual changes to be found (just issued it to test what the server would send, not because I needed it). It was set to the "Look for new and changed" setting when I pressed the button.

    Reported slimserver version is 6.5b1 6554

    Let me know if there is any info I can get you.

    Gerry

  5. #5
    Senior Member
    Join Date
    Jun 2005
    Location
    Switzerland
    Posts
    610
    Works for me on 6619 using the steps above... Can you try it again next nightly? Thanks.

    Fred

  6. #6
    Member gerry_duprey's Avatar
    Join Date
    Mar 2006
    Location
    Ann Arbor, MI USA
    Posts
    50
    Howdy,

    Just downloaded, installed and started last nights build (3/20 build, Web interface shows 6.5b1 6626. Running perl 5.8.8

    Unfortunatly, there doesn't appear to be any change. I checked the log files and there were no messages/errors during the rescan.

    A "rescan ?" done before, during and after the scan did report the right thing, but I never received a "rescan done" or any form of report when the rescan completed.

    I understand it's pretty tough to diagnose a problem when you can't see it yourself. If it would help, I can provide ssh login to the linux server slimserver.pl is running on and from there you can look at the config/logs and telnet into the CLI to issue a rescan command and watch the results. In understand if you'd rather not, just putting the option out there.

    Gerry

  7. #7
    Senior Member
    Join Date
    Jun 2005
    Location
    Switzerland
    Posts
    610
    Before we go the ssh route, can you enable d_import and d_command and try it again?

    Thanks

    Fred

  8. #8
    Member gerry_duprey's Avatar
    Join Date
    Mar 2006
    Location
    Ann Arbor, MI USA
    Posts
    50
    Howdy,

    Okay -- ran it with both d_import and d_command. I can send you the log if you'd like. What I think are relevant entries are:

    Start of scan:
    Code:
    2006-03-21 21:26:39.9424 Import: Wiped all in-memory caches.
    2006-03-21 21:26:43.8080 Import: Starting PLAYLIST scan
    2006-03-21 21:26:43.8470 Import: Starting FOLDER scan
    2006-03-21 21:26:44.7840 Request: Command [rescan] (Done)
    2006-03-21 21:26:44.8319 Request: Notifying CODE(0x9cf9470) of rescan =~ (no filter)
    2006-03-21 21:26:44.8324 Request: Don't notify CODE(0x8dbdbe0) of rescan !~ [['playlist']]
    2006-03-21 21:26:44.8325 Request: Notifying CODE(0x98a1094) of rescan =~ (no filter)
    2006-03-21 21:26:44.9633 Import: Scanning with 2 import plugins
    2006-03-21 21:26:44.9634        PLAYLIST scan started at: Tue Mar 21 21:26:43 2006
    2006-03-21 21:26:44.9635        FOLDER scan started at: Tue Mar 21 21:26:43 2006
    One of the warning/errors that occur during the scan (unrelated, I beleive, to the CLI issue, but just in case):
    Code:
    2006-03-21 21:27:17.1100 Slim::Formats::Parse::readM3U:
    WARNING:
            file:///usr/opt/mp3/music/XTC/Black%20Sea/Track%205.mp3 found in playlist:
            file:///usr/opt/mp3/slim/stock/Entertaining.m3u doesn't exist on disk - skipping!
    When I sent a "rescan ?" from my CLI client during the scan:

    Code:
    2006-03-21 21:27:34.5948 Request: Query [rescan] from CLI  (Done)
    2006-03-21 21:27:34.5949    Result: [_rescan] = [1]
    End of the rescan/log:
    Code:
    2006-03-21 21:30:36.7207 Import: Completed PLAYLIST Scan in 232 seconds.
    2006-03-21 21:30:48.3254 Import: Scanning with 1 import plugins
    2006-03-21 21:30:48.3257        FOLDER scan started at: Tue Mar 21 21:26:43 2006
    2006-03-21 21:30:48.3258 
    2006-03-21 21:30:48.3768 Import: Completed FOLDER Scan in 244 seconds.
    As before, I did not get any "rescan done" (or "rescan 0") or any other report when the rescan completed.

    Gerry

  9. #9
    Senior Member
    Join Date
    Jun 2005
    Location
    Switzerland
    Posts
    610
    Just a hunch: is look for artwork off and what happens if you turn it on?

    Fred

  10. #10
    Member gerry_duprey's Avatar
    Join Date
    Mar 2006
    Location
    Ann Arbor, MI USA
    Posts
    50
    Quote Originally Posted by Fred
    Just a hunch: is look for artwork off and what happens if you turn it on?
    Bingo!

    No, I don't use the artwork stuff. So as you asked, I put in an empty directory and told slimserver to use artwork, then did a rescan.

    With the artwork in place, I now get a "rescan done" upon completion of the rescan! Yeah!

    Is artwork (or at least a dummy artwork directory) a slimserver requirement or just something the CLI was expecting?

    Also, and this is in the gravy department, is there anyway a "rescan done" report can indicate if the last scan actually found any changes or not? I ask because my client caches a lot of state and right now, whenever I get a rescan done, I plan to dump it all and reload it (a time consuming process). If I knew the rescan detected no changes, I could reasonably assume my local cached data is still valid and ignore this. Of course, going completely nutz, it would be nice to know what changed (i.e. genres, playlists, albums, tracks, artists, etc). But now I'm off the deep end. Just getting "rescan done" is a great step forward!

    Thanks!

    Gerry

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •