Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Senior Member
    Join Date
    Apr 2005
    Location
    Scotland
    Posts
    389

    What's the minimum slimserver version required for SB3?

    Hi all,

    Does anybody know what is the earliest version of slimserver which will work on the SB3?

    I used to have an SB1, and version 5.x (5.4.1?) worked very reliably. The service (on Linux) would run happily for weeks on end.

    I've never had much luck with 6.0/6.1/6.2.1 (or later - I'm on nightly builds at the moment). But I could live with it, just having to issue "service slimserver restart" every couple of days.

    Now that I have the SB3, with its inherent wireless issues, it's a nightmare. I've just spent 20 minutes getting the thing to connect to my wireless LAN again, after the slimserver software failed again.

    (It never fails as such, e.g. the service is still running, but the hardware cannot connect to the service and the http://ipaddress:9000 requests just freeze). I've just issued two "service slimserver restart" messages and now it's responding again, which then enables me to connect the ahrdware.

    So my question: can I use 5.4.1 with my SB3 and still retain fucntionality? I only play MP3 files and listen to shoutcast, I don't (and won't) use the squeezenetwork stuff as my server runs 24x7 so I have no need.

    Any advice? Will 5.4.1 do what I need?

    many thanks!


    Jim

  2. #2
    Perl Commando Dan Sully's Avatar
    Join Date
    Apr 2005
    Location
    Daly City, CA
    Posts
    2,865

    What's the minimum slimserver version required for SB3?

    * jimwillsher shaped the electrons to say...

    >Does anybody know what is the earliest version of slimserver which will
    >work on the SB3?


    Jim - any of the 6.x series will work. 5.4.x will not.

    >I used to have an SB1, and version 5.x (5.4.1?) worked very reliably.
    >The service (on Linux) would run happily for weeks on end.
    >
    >I've never had much luck with 6.0/6.1/6.2.1 (or later - I'm on nightly
    >builds at the moment). But I could live with it, just having to issue
    >"service slimserver restart" every couple of days.


    Do you happen to have a crash log? I'd love to know what's causing the crash.

    -D
    --
    Off the record, on the QT, and very hush-hush.

  3. #3
    Senior Member
    Join Date
    Apr 2005
    Location
    Scotland
    Posts
    389
    Thanks for the info.

    No, no crash log. The thing is, slim doesn't crash. It just becomes unresponsive. When I issue the "service slimserver restart" I am told that it ends "ok", rather than receiving any "service wasn't running" messages. That's what's so frustrating, it's as if it gets into a loop.

    Real shame about the 5.4 / 6.0 thing though, as 6.x isn't nearly as stable as 5.4.x was.


    Jim

  4. #4
    Senior Member stinkingpig's Avatar
    Join Date
    May 2005
    Location
    Berkeley, CA
    Posts
    833

    Re: What's the minimum slimserver version required forSB3?

    >
    > Thanks for the info.
    >
    > No, no crash log. The thing is, slim doesn't crash. It just becomes
    > unresponsive. When I issue the "service slimserver restart" I am told
    > that it ends "ok", rather than receiving any "service wasn't running"
    > messages. That's what's so frustrating, it's as if it gets into a
    > loop.
    >


    maybe that's exactly what it's doing. I'll bet you've got something in
    your library that causes the db rescan to go wonky. There's a nightly db
    rescan in 6.x. Try pointing it at a subset of the library.
    --
    Jack Coates At Monkeynoodle Dot Org: It's A Scientific Venture!
    "I spent all me tin with the ladies drinking gin, so across the Western
    ocean I must wander" - traditional


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •