Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1
    Senior Member
    Join Date
    Nov 2005
    Posts
    274

    locales used for date format?

    There's a small issue with the language used for the "date/time" screensaver on my SqueezeBox: it's in English, while I would prefer German.

    The Server is running on a Kubuntu (Breezy) Linux which is a Debian derivate.
    The locales settings are:
    LANG=de_DE@euro
    LANGUAGE=de_DE:de

    Every application running on this system (SSH/Samba) seems to take this setting into account, also slimserver seems to "see" it. On the server settings main page it's says:

    SlimServer Version: 6.2.2 - trunk - Debian - DE - iso-8859-1

    I also set the language settings in the Slimserver settings to German. Now about everything including the Squeezebox's menus are in German ... still the language for the dat/time screensaver is English.

    The most disturbing thing however is that if I restart slimserver manually, the date/time screensaver changes to German.

    I began to wonder if the locales were not correctly set at the time slimserver was first started and shifted it from "S20" to "S99" in the runlevel directory. Unfortunately, this didn't help.

    I'm perplexed what makes the restart different from the first start considering locales or whatever and how I could fix this...

    Any suggestions?

  2. #2
    Member
    Join Date
    Sep 2005
    Location
    Past the Black Stump
    Posts
    46

    locales used for date format?

    On 16/12/05 09:43:49, 0xdeadbeef wrote:
    >
    > There's a small issue with the language used for the "date/time"
    > screensaver on my SqueezeBox: it's in English, while I would prefer
    > German.
    >
    > The Server is running on a Kubuntu (Breezy) Linux which is a Debian
    > derivate.
    > The locales settings are:
    > LANG=de_DE@euro
    > LANGUAGE=de_DE:de
    >


    > I began to wonder if the locales were not correctly set at the time
    > slimserver was first started and shifted it from "S20" to "S99" in
    > the
    > runlevel directory. Unfortunately, this didn't help.
    >



    You need to add those two line to what ever is starting your slimserver
    at boot time.

    LANG and LANGUAGE are not being set by the boot scripts.

    --
    'ooroo

    stinga...(-)
    ---------------------------------------------------
    Email: stinga (AT) wolf-rock (DOT) com o
    You need only two tools. o /////
    A hammer and duct tape. If it /@ `\ /) ~
    doesn't move and it should, > (O) X< ~ Fish!!
    use the hammer. If it moves and `\___/' \) ~
    shouldn't, use the tape. \\\
    ---------------------------------------------------

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •