Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 9 of 9
  1. #1
    Senior Member DrNic's Avatar
    Join Date
    Apr 2005
    Location
    Leaden Roding, UK
    Posts
    330

    Track order & naming problem - 6.2.2

    Using the nightly from 4/12/05:
    MP3 tracks (from compilation album) imported via iTunes, with compilation tag set.
    Tracks named by iTunes as 1-01, 1-02 etc (disc 1) and 2-01, 2-02 etc (disc 2).
    Found that the tracks were listed in SS by artist order alphabetically.
    Edited tags for track numbers to simple 1, 2, 3, etc. Renamed track files to reflect this. Told SS to NOT use iTunes. Deleted db file. Rescanned everything.
    Tracks still appear with name 1-01 Blah Blah, ordered by artist alphabetically!!
    Where is SS getting the old name from, as file names _and_ tags have been changed? Interestingly turning on "use iTunes" gives the tracks the right order (but still remain named 1-01, 1-02 etc)

    Using Win XP2, P4 3.2 gig, 1 gig ram.

    Any thoughts?

    Nic

    PS Moved to this new thread from here (as different problem really!): http://forums.slimdevices.com/showthread.php?t=18796
    Last edited by DrNic; 2005-12-05 at 05:48.

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Posts
    7,103

    Track order & naming problem - 6.2.2

    Have you looked at the files with a thorough tag
    checker? Sounds like you have some file tags that
    you can't see/edit but that SS can see.

    Mp3tag could probably see them, but you'd have to
    know what you're looking for. I find that foobar
    seems to find all the tags.

    Once you know what you're looking for (i.e. is it
    in a "COMMENT" field? a "TRACK" field?), you can
    then get Mp3tag to find and delete it.

    Also, you may want to settle on one tagging
    system. ID3v2 only seems to work for me. When I
    have both ID3v1 and ID3v2, Mp3tag often does not
    agree with SlimServer or foobar. It's easy to get
    Mp3tag to delete everything but one tag set.

    DrNic wrote:
    > Using the nightly from 4/12/05:
    > MP3 tracks (from compilation album) imported via

    iTunes, with
    > compilation tag set.
    > Tracks named by iTunes as 1-01, 1-02 etc (disc 1)

    and 2-01, 2-02 etc
    > (disc 2).
    > Found that the tracks were listed in SS by artist

    order alphabetically.
    > Edited tags for track numbers to simple 1, 2, 3,

    etc. Renamed track
    > files to reflect this. Told SS to NOT use iTunes.

    Deleted db file.
    > Rescanned everything.
    > Tracks still appear with name 1-01 Blah Blah,

    ordered by artist
    > alphabetically!!
    > Where is SS getting the old name from, as file names

    _and_ tags have
    > been changed? Interestingly turning on "use iTunes"

    gives the tracks
    > the right order (but still remain named 1-01, 1-02

    etc)
    >
    > Using Win XP2, P4 3.2 gig, 1 gig ram.
    >
    > Any thoughts?
    >
    > Nic
    >
    > PS Moved to this new thread from here (as different

    problem really!):
    > http://forums.slimdevices.com/showthread.php?t=18796
    >
    >


    --
    ___________________________________


    Mark Lanctot
    ___________________________________







  3. #3
    Senior Member DrNic's Avatar
    Join Date
    Apr 2005
    Location
    Leaden Roding, UK
    Posts
    330
    Quote Originally Posted by Mark Lanctot
    Have you looked at the files with a thorough tag
    checker? Sounds like you have some file tags that
    you can't see/edit but that SS can see.

    Mp3tag could probably see them, but you'd have to
    know what you're looking for. I find that foobar
    seems to find all the tags.

    Once you know what you're looking for (i.e. is it
    in a "COMMENT" field? a "TRACK" field?), you can
    then get Mp3tag to find and delete it.

    Also, you may want to settle on one tagging
    system. ID3v2 only seems to work for me. When I
    have both ID3v1 and ID3v2, Mp3tag often does not
    agree with SlimServer or foobar. It's easy to get
    Mp3tag to delete everything but one tag set.
    Thanks Mark
    Sorry for the delay in getting back to this thread, darned work!
    I have looked at the tags with MP3Tag, and they are all present and correct! There are no erroneous fields (comment etc) present.
    The only thing is these files have both ID3v1 and ID3v2. But all my mp3 encoded by itunes do. It is only the ones in compilation albums that exhibit this problem.
    The real question is how does SS get the old track numbers, now that they are re-tagged and file renamed?!

    I'm confused!

    Nic

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Posts
    7,103

    Re: Track order & naming problem - 6.2.2

    Strange.

    Have you rescanned using the "clear library" option?

    --- DrNic <DrNic.1znckz (AT) no-mx (DOT) forums.slimdevices.com>
    wrote:

    >
    > Mark Lanctot Wrote:
    > > Have you looked at the files with a thorough tag
    > > checker? Sounds like you have some file tags that

    >
    > > you can't see/edit but that SS can see.
    > >
    > > Mp3tag could probably see them, but you'd have to
    > > know what you're looking for. I find that foobar
    > > seems to find all the tags.
    > >
    > > Once you know what you're looking for (i.e. is it
    > > in a "COMMENT" field? a "TRACK" field?), you can
    > > then get Mp3tag to find and delete it.
    > >
    > > Also, you may want to settle on one tagging
    > > system. ID3v2 only seems to work for me. When I
    > > have both ID3v1 and ID3v2, Mp3tag often does not
    > > agree with SlimServer or foobar. It's easy to get

    >
    > > Mp3tag to delete everything but one tag set.
    > >

    >
    > Thanks Mark
    > Sorry for the delay in getting back to this thread,
    > darned work!
    > I have looked at the tags with MP3Tag, and they are
    > all present and
    > correct! There are no erroneous fields (comment etc)
    > present.
    > The only thing is these files have both ID3v1 and
    > ID3v2. But all my mp3
    > encoded by itunes do. It is only the ones in
    > compilation albums that
    > exhibit this problem.
    > The real question is how does SS get the old track
    > numbers, now that
    > they are re-tagged and file renamed?!
    >
    > I'm confused!
    >
    > Nic
    >
    >
    > --
    > DrNic
    >

    ------------------------------------------------------------------------
    > DrNic's Profile:
    > http://forums.slimdevices.com/member.php?userid=92
    > View this thread:
    > http://forums.slimdevices.com/showthread.php?t=18809
    >
    >

  5. #5
    Junior Member
    Join Date
    Apr 2005
    Location
    Auckland
    Posts
    2

    Re: Track order & naming problem - 6.2.2

    I'm also seeing this problem with a Greatest Hit's album.

    Tracks appear to be sorted & load and play in alphabetical, not track order.

    I've setup a test 6.2.2 server with only two albums and used mp3tag to check the tags are OK for both albums. One plays fine and shows up with the track number prepended to the track name, the other plays alphabetically and shows up without the track number prepended....

    I've only noticed this since 6.2.x... but then my tags were a complete mess previously, and I'm only just getting them sorted out!

    Anybody got any ideas...

    Thanks
    Ken.

  6. #6
    Senior Member DrNic's Avatar
    Join Date
    Apr 2005
    Location
    Leaden Roding, UK
    Posts
    330
    Mark,
    I have done the clear library & rescan everything option many times to no avail. I have also deleted the db file...

    kgdownie,
    In a perverse sort of way I am glad you have experienced this also, as I was starting to think my computer had "special" powers...

    Nic

  7. #7
    Junior Member
    Join Date
    Apr 2005
    Location
    Auckland
    Posts
    2

    Re: Track order & naming problem - 6.2.2

    DrNic,

    If I select the option "Specifiy a list of Common Album Titles" under "Home / Server Settings / Behaviour / Common Album Titles" then once I've rescanned the problem goes away...

    I Don't know what other issues that might cause though!

    You might want to give it a try....


    Cheers
    Ken

  8. #8
    Senior Member DrNic's Avatar
    Join Date
    Apr 2005
    Location
    Leaden Roding, UK
    Posts
    330
    Quote Originally Posted by kgdownie
    DrNic,

    If I select the option "Specifiy a list of Common Album Titles" under "Home / Server Settings / Behaviour / Common Album Titles" then once I've rescanned the problem goes away...

    I Don't know what other issues that might cause though!

    You might want to give it a try....


    Cheers
    Ken
    Ken
    Thanks for the suggestion. I found this out after all my Greatest Hits albums became one! Then after ticking this box and rescanning the individual albums appeared again. However the bizarre ability of slimserver to find a track name that to all intents no longer exists in any tag or file name still stares me in the face mocking me!!

    Nic

  9. #9
    Senior Member DrNic's Avatar
    Join Date
    Apr 2005
    Location
    Leaden Roding, UK
    Posts
    330
    Well I have found out that if the CDs were ripped in iTunes (something I no longer do) the compilation albums with more than one disc get a "discnumber" tag set. They also get an "itunescompilation" tag set.
    If I remove the discnumber tag then the tracks are numbered correctly. (01,02 not 1-01,1-02 or 2-01, 2-02)
    However, with cleaned tags (only ID3v2)- no discnumber, track numbers as 01,02,03 etc, filenames as 01blahblah etc, and no comments tag set - and tell SS not to use itunes then the compilation albums still get their tracks arranged not by track number but in artist alphabetically!!!
    Re-enabling "use iTunes" sets the track order right - heh?

    I don't want to use iTunes - I'm moving far away from that place...

    Nic

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •