Hi everyone. I had hoped my first post would be in praise of a wonderful working product, but unfortunately, I need some help...

I received my SB2 yesterday, and finally got a chance to start setting it up tonight. Now let me see if I can remember all the events. I started out with my Linksys WRT54G wireless router with an SSID that does have a space in it, using 128 bit WEP encryption. I added the SB2's MAC address to the MAC address filter.

I then began setup on the SB2, giving it the SSID, and WEP password. It failed to connect to the router. I disabled the MAC filter, still no connection. I disabled WEP, no connection. I turned both of those back on. I read through several forum posts relating to various wireless problems, but none seemed to fit my situation. On a whim, I turned SSID broadcast on, and suddenly the SB2 connected. Turn SSID off, SB2 disconnects.

I then found the post saying spaces in SSIDs caused problems, so I removed the spaces in my SSID. Still only worked with broadcast on, and not when broadcast off. I upgraded my routers firmware, and the SB2 firmware. I then downloaded the nightly build for Slimserver, and updated the SB2 firmware again, still no change in the behavior. I also changed my SSID to something completely stupid (like "qwerty" or something similar), and that didn't help.

I'm sure I'm forgetting a few tests I performed... Oh, when the SB2 does connect, the wireless strength is over 90% (usually in the 95-97% range), so I don't think it is a flaky wireless signal -- watching the signal strength as I change the broadcast setting on the router, I can watch it go from 90+% to zero. I confirmed the firmware is now version 23, and the MAC address matches what I have in the filter.

I'm very much out of ideas at this point, and will appreciate any hints people can give. Thanks everyone, and I hope to be back soon with praise for this outstanding product!