Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1
    Senior Member
    Join Date
    Jun 2005
    Posts
    422

    "Browse Songs" and "Search for Songs" show also matching album and artist names

    When using "Browse Songs" and "Search for Songs" on the Squeezebox with the remote not only songs but also matching albums and artists are shown. This happens with the August 8 nightly. With previous versions (somewhere before August 5) this did not happen. As far as I understand there was an amendment on August 5 regarding bug 399 which seems to be related to searching. Could that have introduced the wrong behavior?

    Further, when selecting "Search For Songs" on the remote and e.g. selecting all songs containing an "A" by pressing twice the right arrow button the last item in the resultang song list is shown as "ALL_SONGS" instead of "All Songs". Even in the German version "ALL_SONGS" is shown instead of the German text "Alle Titel". As far as I can remember this was also different before August 5.

    Finally, when selecting "Browse Songs" on the remote in the resulting song list there is no "All..." item at all. Shouldn't be the last item in the list an "All Songs" entry?

    I have filed a bug report for these.

    BTW "Browse Songs" has been tremendously accelerated (by this amendment?). It took always several minutes until the song list was shown (so I did not use it in practice) but now the song list is shown instantaneously without any delay!

  2. #2
    Senior Member
    Join Date
    Jun 2005
    Posts
    422
    I found now that "Browse Songs" and "Search For Songs" do not show matching albums and artist names but matching directory names.

    I have all my music files stored on disk in D:\My Music\Artist Name\Album Name\Track No.-Artist - Song Title.ogg. I now found that in addition to the song titles the matching directory names are shown in the result song list on my Squeezebox when using "Browse Songs" or "Search For Songs". Since the directory names are in fact the artist names and the album names it looked at the first glance as if the artist and album tags are searched.

    I can easyly reproduce this behaviour on a test system comprising only a small number of song files by creating a subdirectory (e.g. xxx) in my music directory. It is even not necessary to put a song file in this directory. When I select "Browse Songs" and select "x" on the remote the directory name "xxx" is shown als song title. Also when selecting "Search For Songs" and inputing "xxx" the directory name is shown as song title.

    I tried the August 11 nightly and have the same effect. Can anybody confirm this bug or is it only specific for me?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •