Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Frank L
    Guest

    Gaps when browsing music folder

    Starting recently, when I browse the music folder or select "home" I get a
    short (1 second +/-) pause. Unfortunately it happened after I changed a lot
    of variables at the same time (replaced hard drive, reinstalled XP Pro,
    upgraded to SlimServer 6.x, installed all other software). I didn't have
    this problem with version 5.x, but obviously I have no idea if that has
    anything to do with it. I tried searching for spyware/viruses, disabling
    unnecessary programs using msconfig, upgrading memory from 128MB to 384MB,
    upgrading to the latest nightlies, etc. and I can't seem to solve the
    problem. I searched the archives and could not find any messages related to
    this problem. That leads me to believe it is a computer problem, but I
    thought I would check before doing anything drastic.

    Here is a summary of my system.

    Dell Pentium PIII 800mhz
    384MB RAM
    XP Pro
    Hard Drives:
    - 120GB Western Digital WD1200JB (boot)
    - 200GB Western Digital WD2000BB (music)
    Slimserver 6.0.1
    Firmware version 40

    Any suggestions would be appreciated.

    -- Frank




  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,503

    Gaps when browsing music folder

    [..]
    > of variables at the same time (replaced hard drive, reinstalled XP Pro,
    > upgraded to SlimServer 6.x, installed all other software). I didn't have
    > this problem with version 5.x, but obviously I have no idea if that has


    6.x seems to be a little slower than 5.x when browsing folders.

    What plugins do you use?

    > anything to do with it. I tried searching for spyware/viruses, disabling
    > unnecessary programs using msconfig, upgrading memory from 128MB to
    > 384MB,


    This should _not_ have a negative impact :-)

    > Slimserver 6.0.1


    You might want to update to 6.0.2

    --

    Michael

    -----------------------------------------------------------
    Help translate SlimServer by using the
    StringEditor Plugin (http://www.herger.net/slim/)


  3. #3
    Frank L
    Guest

    Gaps when browsing music folder

    Thanks for the response.

    "Michael Herger" <slim (AT) herger (DOT) net> wrote in
    message newsp.spzcobstkpbrd7 (AT) truckli (DOT) jo-sac.ch...

    >What plugins do you use?


    I unchecked all the pluggins and I get the same pause.

    >You might want to update to 6.0.2


    I tried that too and no improvement.

    I should add that I am using a wired Squeezebox and I am connecting to the
    Slimserver computer with a Laptop/WiFi. the pauses happen when I control
    the Squeezebox from either computer.

    -- Frank




  4. #4
    Steve Baumgarten
    Guest

    Gaps when browsing music folder

    When I browse the music folder via the web interface I see the display
    on my SB2 freeze up (i.e., the large font that was scrolling the "Now
    Playing" info stops dead in its tracks -- pardon the pun) until results
    are returned to the browser. Music continues to play; I don't know,
    however, if this is due to the big SB2 internal buffer or because the
    server is still sending audio even though it isn't sending display
    updates. (I'm guessing the former, though, and not the latter.)

    This is with 6.0.2 (released version) on Windows XP; the top level of my
    music folder contains about 800 folders, each an album, with no loose
    tracks.

    Other than browsing the music folder, I don't see any appreciable delays
    on browses or searches.

    (I haven't filed a bug on this because I know "browse folder" is slated
    for some optimization already, and I think the big SB2 buffer is
    probably letting me skate by with no audio dropouts in the meantime.)

    SBB






    Visit our website at http://www.ubs.com

    This message contains confidential information and is intended only
    for the individual named. If you are not the named addressee you
    should not disseminate, distribute or copy this e-mail. Please
    notify the sender immediately by e-mail if you have received this
    e-mail by mistake and delete this e-mail from your system.

    E-mail transmission cannot be guaranteed to be secure or error-free
    as information could be intercepted, corrupted, lost, destroyed,
    arrive late or incomplete, or contain viruses. The sender therefore
    does not accept liability for any errors or omissions in the contents
    of this message which arise as a result of e-mail transmission. If
    verification is required please request a hard-copy version. This
    message is provided for informational purposes and should not be
    construed as a solicitation or offer to buy or sell any securities or
    related financial instruments.


  5. #5
    Perl Commando Dan Sully's Avatar
    Join Date
    Apr 2005
    Location
    Daly City, CA
    Posts
    2,865

    Gaps when browsing music folder

    * Steve Baumgarten shaped the electrons to say...

    >This is with 6.0.2 (released version) on Windows XP; the top level of my
    >music folder contains about 800 folders, each an album, with no loose
    >tracks.
    >
    >(I haven't filed a bug on this because I know "browse folder" is slated
    >for some optimization already, and I think the big SB2 buffer is
    >probably letting me skate by with no audio dropouts in the meantime.)


    There's really only so much that can be done here.. the Windows FS isn't the
    best for reading a large directory like that..

    If you want to make this faster, I suggest having a smaller top level directory structure, such as:

    A/
    B/
    C/
    ....
    Z/

    -D
    --
    <dr.pox> do they call it 'gq' because it makes your text fashionable?

  6. #6
    Senior Member
    Join Date
    Apr 2005
    Posts
    8,410

    Gaps when browsing music folder

    > When I browse the music folder via the web interface I see the display
    > on my SB2 freeze up (i.e., the large font that was scrolling the "Now
    > Playing" info stops dead in its tracks -- pardon the pun) until results
    > are returned to the browser. Music continues to play; I don't know,
    > however, if this is due to the big SB2 internal buffer or because the
    > server is still sending audio even though it isn't sending display
    > updates. (I'm guessing the former, though, and not the latter.)
    >


    You may find that 6.1 freezes up less as far as scrolling text is concerned.

  7. #7
    Senior Member JJZolx's Avatar
    Join Date
    Apr 2005
    Location
    Colorado
    Posts
    11,555
    Quote Originally Posted by Dan Sully
    * Steve Baumgarten shaped the electrons to say...

    >This is with 6.0.2 (released version) on Windows XP; the top level of my
    >music folder contains about 800 folders, each an album, with no loose
    >tracks.
    >
    >(I haven't filed a bug on this because I know "browse folder" is slated
    >for some optimization already, and I think the big SB2 buffer is
    >probably letting me skate by with no audio dropouts in the meantime.)


    There's really only so much that can be done here.. the Windows FS isn't the best for reading a large directory like that..
    AFAIK, Windows at least caches the directory lookup so that returning to the directory (descend, return, descend, return) shouldn't cause too much pain. Are you sure the problem doesn't lie more with SlimServer's database interaction when doing a Browse Music Folder?

    This gets back to my suggestion that there needs to be a simple means of doing _actual_ directory browsing, without SlimServer trying to use the activity for cataloging tracks. I've yet to see SlimServer accurately portray the real directory structure of my music directory tree when using this method of browsing. There's always something missing, or completely misplaced. At times it makes me wish there was no SlimServer user interface at all and that I could just use Windows Explorer to browse and play _music_ and forget all the plugins, screen savers, RSS news feeds, and all the other crap.
    ________
    XL185
    Last edited by JJZolx; 2011-01-22 at 01:49.

  8. #8
    Quote Originally Posted by Dan Sully

    There's really only so much that can be done here.. the Windows FS isn't the best for reading a large directory like that..
    In fact Windows XP does just fine; a short perl script that does nothing more than an opendir(), readdir(), closedir() on my music folder takes at most 1 second to run. (The file system is on an internal drive running on the same PC as the SlimServer.)

    I can even traverse my entire music library, about 16,000 files, using perl's File::Find package, in about 15 seconds. But since browsing the music folder only requires the perl code to read a single directory and create some HTML that represents what it finds, there's obviously a lot more going on and much room for improvement.

    There's simply no way the performance I'm seeing in 6.0.2 can be blamed on Windows XP.

    I had thought this was a known problem and something that was being worked on -- that there was a lot of unnecessary work going on with the DB in addition to just doing a readdir() -- but if that's not the case I'll file a bug report (or add my comments to an existing report if someone else has already done so).

    SBB

  9. #9
    Perl Commando Dan Sully's Avatar
    Join Date
    Apr 2005
    Location
    Daly City, CA
    Posts
    2,865

    Gaps when browsing music folder

    * Steve Baumgarten shaped the electrons to say...

    >I had thought this was a known problem and something that was being
    >worked on -- that there was a lot of unnecessary work going on with the
    >DB in addition to just doing a readdir() -- but if that's not the case
    >I'll file a bug report (or add my comments to an existing report if
    >someone else has already done so).


    Please file a bug - everyone that puts more effort behind this will light
    certain fires under various people here.

    Question - What do you have "Sort By File" set to? It's in Settings-> Behavior

    -D
    --
    <noah> I used to be indecisive, but now I'm not sure.

  10. #10

    Re: Gaps when browsing music folder

    Dan Sully wrote:

    > Question - What do you have "Sort By File" set to? It's in Settings-> Behavior


    It's set to "Sort by File Name". I figured this would be the faster of
    the two options (where the other one is "Sort by Song Information"),
    though in my case it wouldn't make a difference as all my tracks are named:

    trackno - artist - trackname.{flac|mp3}

    In any event it certainly shouldn't make a difference for browsing the
    top level of my music folder, since it consists of nothing more than
    about 800 other folders and no loose tracks.

    SBB


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •