Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 9 of 9
  1. #1
    Roy Owen
    Guest

    SS 6.0 and RSS plugin

    In the course of debugging a different problem I ran acros the
    following in the log file

    2005-04-01 16:45:42.5880 current rss feed not set\n2005-04-01
    16:45:42.5990 Backtrace:

    frame 0: Slim::Utils::Misc::assert
    (C:/PROGRA~1/SLIMSE~1/server/Plugins/RssNews.pm line 628)
    frame 1: Plugins::RssNews::lines
    (/PerlApp/Slim/Player/SqueezeboxG.pm line 622)
    frame 2: Slim::Player::SqueezeboxG::scrollUpdate
    (/PerlApp/Slim/Utils/Timers.pm line 62)
    frame 3: Slim::Utils::Timers::checkTimers (slimserver.pl line 611)
    frame 4: main::idle (slimserver.pl line 549)
    frame 5: main::main (slimserver.pl line 61)
    frame 6: PerlSvc::Interactive (perlsvc line 1208)
    frame 7: PerlSvc::_interactive (slimserver.pl line 0)
    frame 8: (eval) (slimserver.pl line 0)

    Here's the problem. C:/PROGRA~1/SLIMSE~1/server/Plugins/RssNews.pm, line 628:

    618 }
    619
    620 sub lines {
    621 #This returns the 2 lines to display on the unit
    622 my $client = shift;
    623 my $lineref;
    624 my $now = time();
    625
    626 # the current RSS feed
    627 my $display_current = $client->param('PLUGIN.RssNews.display_current');
    628 assert($display_current, 'current rss feed not set\n');
    629
    630 # the current item within each feed.
    631 my $display_current_items =
    $client->param('PLUGIN.RssNews.display_current_items');
    632
    633 #remember which item in feed we are currently showing
    634 # this will be stored on a per-client basis
    635 if (!defined ($display_current_items)) {
    636 $display_current_items = {$display_current => {'next_item' => 0}};
    637 } elsif (!defined($display_current_items->{$display_current})) {
    638 $display_current_items->{$display_current} = {'next_item' => 0};


    any idea what the problem is?

    Thanks
    --
    Do meddle in the affairs of Dragons,
    for you are crunchy and good with Tabasco.

  2. #2
    Slim Devices Developer Dave Cohen's Avatar
    Join Date
    Apr 2005
    Posts
    21

    SS 6.0 and RSS plugin

    Roy,

    I don't know off-hand what's causing that problem. The assert means
    the code always expects display_current to be set. And in my testing
    that was always the case (otherwise I would have seen that output and
    at the very least put the '\n' in double quotes.

    So a few questions...

    Where you using the news feed screensaver, or the manual browsing?

    Did the server crash? (I take it from your post you didn't actually
    notice any problems except the message in the log)

    Could it be that your server lost its connection to the internet for a
    brief period?

    Thanks,

    -Dave


    On Fri, Apr 01, 2005 at 04:59:47PM -0500, Roy Owen wrote:
    > In the course of debugging a different problem I ran acros the
    > following in the log file
    >
    > 2005-04-01 16:45:42.5880 current rss feed not set\n2005-04-01
    > 16:45:42.5990 Backtrace:
    >
    > frame 0: Slim::Utils::Misc::assert
    > (C:/PROGRA~1/SLIMSE~1/server/Plugins/RssNews.pm line 628)


    [snip]

  3. #3
    NOT a Slim Devices Employee kdf's Avatar
    Join Date
    Apr 2005
    Posts
    9,493

    SS 6.0 and RSS plugin

    Quoting Dave Cohen <dave (AT) slimdevices (DOT) com>:

    > Roy,
    >
    > I don't know off-hand what's causing that problem. The assert means
    > the code always expects display_current to be set. And in my testing
    > that was always the case (otherwise I would have seen that output and
    > at the very least put the '\n' in double quotes.
    >
    > So a few questions...
    >
    > Where you using the news feed screensaver, or the manual browsing?


    I see similar output to the original post when a slimp3 is set to use the rss
    screensaver. it happen on startup, when the slimp3 jumps straight into
    screensver mode. it seems to only happen when a slimp3 is set to use the
    screensaver for me.

    -kdf

  4. #4
    Roy Owen
    Guest

    SS 6.0 and RSS plugin

    Dave,
    I'm using the RSS screen saver on SBG's I don't think it's a
    connection loss as there are many entries in the log. The server
    crashed but not due (I think) to the RSS ScreenSaver as the screen
    saver was not running when the server crashed.

    On Apr 1, 2005 9:18 PM, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
    > Quoting Dave Cohen <dave (AT) slimdevices (DOT) com>:
    >
    > > Roy,
    > >
    > > I don't know off-hand what's causing that problem. The assert means
    > > the code always expects display_current to be set. And in my testing
    > > that was always the case (otherwise I would have seen that output and
    > > at the very least put the '\n' in double quotes.
    > >
    > > So a few questions...
    > >
    > > Where you using the news feed screensaver, or the manual browsing?

    >
    > I see similar output to the original post when a slimp3 is set to use the rss
    > screensaver. it happen on startup, when the slimp3 jumps straight into
    > screensver mode. it seems to only happen when a slimp3 is set to use the
    > screensaver for me.
    >
    > -kdf
    >

  5. #5
    Slim Devices Developer Dave Cohen's Avatar
    Join Date
    Apr 2005
    Posts
    21

    SS 6.0 and RSS plugin

    Roy and KDF,

    If you can reproduce that message reliably, could you try with the
    attached RssNews.pm? It should print some more messages which
    will help me track it down. Please send me the output if you see the
    usual error, or a message about display_current not set. Also send
    the result of grepping for "Rss" in your server prefs file, if you
    know how to do that.

    You can send directly to me at dave (AT) slimdevices (DOT) com. I'll post a fix
    to the list as soon as I have one.

    Thanks,

    -Dave

  6. #6
    NOT a Slim Devices Employee kdf's Avatar
    Join Date
    Apr 2005
    Posts
    9,493

    time out

    I'm tired of the same old disputes and mudslinging; everyone is an expert and
    knows better than everyone else how to run a business that isn't their own. I
    have less and less free time, and less motivation to spend that time wading
    through the same old arguments. The latest rehash of forum wars is just too
    much for my patience. So, for now, I'm taking the only rational option,
    walking away. There are probably plenty of people far more capable to answer
    questions than I, who may even have the time and desire to tough it out. Its
    just too much for me right now.

    ttyl.
    -kdf

  7. #7
    Roy Owen
    Guest

    time out

    kdf,
    I sorry to hear that you feel that you need to leave. Personally I have
    appreciated your help and insights and will miss you greatly. Hope you come
    back soon.

    Roy

    On Apr 5, 2005 3:32 PM, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
    >
    > I'm tired of the same old disputes and mudslinging; everyone is an expert
    > and
    > knows better than everyone else how to run a business that isn't their
    > own. I
    > have less and less free time, and less motivation to spend that time
    > wading
    > through the same old arguments. The latest rehash of forum wars is just
    > too
    > much for my patience. So, for now, I'm taking the only rational option,
    > walking away. There are probably plenty of people far more capable to
    > answer
    > questions than I, who may even have the time and desire to tough it out.
    > Its
    > just too much for me right now.
    >
    > ttyl.
    > -kdf
    >

  8. #8
    Mark Bennett
    Guest

    time out

    I agree - your contribution to Slim Devices product development,
    and the support on this forum has been fantastic. It's way
    beyond what anyone has a right to ask of you, and you will be
    missed.

    I also hope that with a break for a while you'll feel like
    getting involved again - you'll be greeted heartily by the
    many users you've helped in the past.


    On Tue, 2005-04-05 at 16:36 -0400, Roy Owen wrote:
    > kdf,
    > I sorry to hear that you feel that you need to leave. Personally I
    > have appreciated your help and insights and will miss you greatly.
    > Hope you come back soon.
    >
    > Roy
    >
    > On Apr 5, 2005 3:32 PM, kdf <slim-mail (AT) deane-freeman (DOT) com> wrote:
    > I'm tired of the same old disputes and mudslinging; everyone
    > is an expert and
    > knows better than everyone else how to run a business that
    > isn't their own. I
    > have less and less free time, and less motivation to spend
    > that time wading
    > through the same old arguments. The latest rehash of forum
    > wars is just too
    > much for my patience. So, for now, I'm taking the only
    > rational option,
    > walking away. There are probably plenty of people far more
    > capable to answer
    > questions than I, who may even have the time and desire to
    > tough it out. Its
    > just too much for me right now.
    >
    > ttyl.
    > -kdf
    >

  9. #9
    Slim Devices Developer Dave Cohen's Avatar
    Join Date
    Apr 2005
    Posts
    21

    SS 6.0 and RSS plugin

    I believe at last I have this fixed. Bug 1339 is tracking the issue:

    <http://bugs.slimdevices.com/show_bug.cgi?id=1339>

    For details as to the cause, and for a version of the Plugin which
    solves the problem, see the bug.

    Please let me know if this does not in fact solve the problem.

    Thanks Roy for the help tracking this down.

    -Dave


    On Fri, Apr 01, 2005 at 04:59:47PM -0500, Roy Owen wrote:
    > In the course of debugging a different problem I ran acros the
    > following in the log file
    >
    > 2005-04-01 16:45:42.5880 current rss feed not set\n2005-04-01
    > 16:45:42.5990 Backtrace:
    >


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •