I just got my eagerly-awaited Squeezebox2, and I initially couldn't get
it to connect to my home wireless network. After I verified that I
could connect to other networks and to my wired network, on a lark, I
tried changing my SSID.

When I tried to connect to the network with my original SSID (say "123
Main Street" -- not my real SSID but close enough for this story), it
would fail with the "can't connect to wireless network" message, after
the SSID selection step but before the DHCP/static IP selection step.

I initially changed the SSID to "TESTO" and that worked. Back to the
original and it failed; finally I tried "123MainStreet" and that worked

Does the Squeezebox2 firmware not handle spaces in SSIDs correctly?
I'd like to be able to change back to my original SSID. Also, the way
this failed was not very graceful -- I spent a lot of time thinking I
must have a signal problem or some kind of network issue.

Once I got past that, everything worked well -- thanks to Slim Devices
for a really great piece of hardware and accompanying software!