Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1
    Patrick Dixon
    Guest

    Re: Problem starting 6.0b1on FC3 (was Problemstarting5.4.0on FC3)

    File sent.

    I'm now getting a Slimserver crash when I try to connect SoftSqueeze 1.14 (running on a Win XP PC elsewhere on the network).

    Error is:

    "Your vendor has not defined Socket macro IPPROTO_TCP, used at /usr/local/slimserver/Slim/Networking/Slimproto.pm line 77"

    I'm off to bed now - don't work too hard!

    -----Original Message-----
    From: discuss-bounces (AT) lists (DOT) slimdevices.com
    [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com]On Behalf Of Dan Sully
    Sent: 13 March 2005 20:00
    To: Slim Devices Discussion
    Subject: [slim] Re: Problem starting 6.0b1on FC3 (was Problem
    starting5.4.0on FC3)


    * Patrick Dixon shaped the electrons to say...

    >Dan, thanks for the instant response!
    >
    >I let it do whatever it did in the /usr/local/slimserver directory???
    >
    >I got one Warning:
    >prerequisite AppConfig 1.55 not found


    that's ok.

    >(Do you really want me to email you with the tar.gz file?)


    Yes - please.

    >Slimserver now starts from the command line, but with the following warning:
    >
    >Use of uninitialised value in string eq at /usr/local/ActivePerl-5.8/lib/site-perl/5.8.6/i686-linux-thread-multi/XML/Parser.pm line 16.


    Also harmless.

    >So what have I done and why did I have to do it?


    You've installed the required modules for SlimServer - because we can't ship
    the binary modules for every different variation of Linux distribution, they
    weren't included by default for your Linux.

    After I have the tarball, I'll be able to tell you more.

    Thanks.

    -D
    --
    <faisal> my life is collapsing to what will soon be NEGATIVE INTEGER degrees of separation.

  2. #2
    Senior Software Engineer - Logitech/Slim Devices
    Join Date
    Apr 2005
    Location
    Ipswich, UK
    Posts
    1,394

    Re: Problem starting 6.0b1on FC3 (wasProblem starting5.4.0on FC3)

    Patrick Dixon wrote:

    >File sent.
    >
    >I'm now getting a Slimserver crash when I try to connect SoftSqueeze 1.14 (running on a Win XP PC elsewhere on the network).
    >
    >Error is:
    >
    >"Your vendor has not defined Socket macro IPPROTO_TCP, used at /usr/local/slimserver/Slim/Networking/Slimproto.pm line 77"
    >
    >I'm off to bed now - don't work too hard!
    >
    >

    Patrick,

    You must use Softsqueeze 2.0 with slimserver 6.0, this is supplied with the latest slimserver versions. At the moment this is not available from Sourceforge, at the moment it is important to run the version supplied with the slimserver while in beta.

    I don't know if the crash was related to you using Softsqueeze 1.14, but even it not you would not have got much further. I have just checked in some Softsqueeze fixes, and would recommend upgrading to tomorrow's nightly for Softsqueeze.

    Regards,
    Richard

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •