Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Oct 2022
    Posts
    3

    PiCore Player / 3.5 inch Display / Calibration fails

    Hello!
    I have a PiCore player on an RPi4 as a multiroom system with several PiZero.
    Works great.
    Now I got a 3.5 inch screen from a friend to plug into the GPIO.
    For the installation I first tried to remove the config of HiFiBerry so that the GPIO is not somehow occupied.
    For this I deleted the entry in the GUI and also in Config.TXT.
    Then I proceeded exactly as described in the Picore Dokumentation to add the 3.5 inch Display.
    (sorry - I tried but I am not allowed to add links at this point because I am new here :-()

    The display works allready at this point.

    When I try to calibrate, I get:
    sudo TSLIB_FBDEVICE=/dev/fb1 TSLIB_TSDEVICE=/dev/input/event0 /usr/local/bin/ts_calibrate
    open fbdevice: No such file or directory

    I also tried "event1"
    here the error is different:
    ts_setup: No such file or directory

    While editing the Jivelite.sh with Nano I saw, the $EVENTNO in line
    export TSLIB_TSDEVICE=/dev/input/$EVENTNO

    becomes red. Does that mark an error?
    COuld someone plaese help?

    Thanks!
    Rakete.

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    6,260
    The error refers to FBDEVICE ... so maybe it is fb0 and not fb1

    Try
    ls /dev/fb*
    to see what you have
    Last edited by Paul Webster; 2022-10-03 at 09:15.
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  3. #3
    Junior Member
    Join Date
    Oct 2022
    Posts
    3
    Ok - got it. How simple. :-)
    Thank you.
    It was fb0

    Now, the calibration starts. But the display doesn't react on tap.
    Any suggestions?

    Since I former hat a HifiBerry installed on the GPIO, I assume there is still some config mixedup on the gpio.

    Thx!
    Rakete

  4. #4
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    6,260
    what do you see with
    ls /dev/input/event*
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  5. #5
    Junior Member
    Join Date
    Oct 2022
    Posts
    3
    /dev/input/event0

    I got the thing as a gift.
    Maybe it is simply defective.

    Is there an easy way to check the touch function?

    THanks!
    Christian
    Last edited by Rak3tenmann; 2022-10-03 at 23:42.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •