Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Oct 2022
    Posts
    1

    mono sound on piCorePlayer with hifiberry soundcard

    Hi everyone
    Im currently trying to set up a raspberry pi with a hifiberry sound card for a mono speaker. But I'm struggling with the required asound.conf settings.
    As far as I can tell, i need to change the settings in Beta/Extras/asound

    But if i change it there to mono, i haven't gotten any sound yet. I'm not sure what is required in the output settings field. If i empty it in first, i feel like it doesn't recognize my soundcard.

    Thank you for any tips



    This is the current file if i check via putty /etc/asound.conf
    Code:
    # default - Generated by piCorePlayer
    pcm.!default {
       # mono
       type route;
       slave.pcm "hw:0,0";
       ttable {
          0.1 1;
          0.0 1;
          1.0 1;
          1.1 1;
       }
    }
    
    pcm.pcpinput {
       type hw
       card Headphones
       device 0
    }
    
    #---ALSA EQ Below--------
    pcm.sound_device {
       type plug
       slave.pcm {
          type hw
          card Headphones
          device 0
       }
    }
    
    ctl.equal {
       type equal;
       controls "/home/tc/.alsaequal.bin"
       library "/usr/local/lib/ladspa/caps.so"
    }
    
    pcm.plugequal {
       type equal;
       slave.pcm "sound_device";
       controls "/home/tc/.alsaequal.bin"
       library "/usr/local/lib/ladspa/caps.so"
    }
    
    pcm.equal {
       type plug;
       slave.pcm plugequal;
    }

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    6,278
    Would an alternative approach be OK ...
    LMS/Settings/Player/xxxx/Audio/Output Channel Mode=Both Channels (Mono)

    You might need LMS 8.3 for that option (I can't remember if in 8.2.1).
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  3. #3
    Member
    Join Date
    Sep 2008
    Location
    Barcelona
    Posts
    84
    Hi,
    if I had to do it now, I'd try configuring it in LMS as suggested above.
    That said, I had same problem as you and turned out I had to select a different number for Audio Card.
    In "Generate asound.conf" section, last line is "Card: 0 1 2". Most probably you have "0" but need to select 1 or 2.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •