Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1

    Rating not returned for one track

    Hi,

    I'm experiencing a weird behaviour of Slimserver with Material Skin.
    There is one track (or at least one track I'm aware of) which has a rating but this one isn't shown in the queue, on the now playing screen or when browsing.
    However when I look at the details (via (...)More), I see the rating.
    Please see a screenshot below.
    Name:  2022_09_25_13_05_42_The_Wheal_Coil_Logitech_Media_Server_Vivaldi.png
Views: 196
Size:  189.9 KB

    cpd73 wrote in the Material skin thread, that the skin gets the ratings from the server. So I checked the exchanged messages.
    When opening the album, I see the request to retrieve the track details of the album

    Code:
    POST /jsonrpc.js HTTP/1.1
    Accept: application/json, text/plain, */*
    Accept-Encoding: gzip, deflate
    Accept-Language: en-GB
    Cache-Control: no-cache
    Connection: keep-alive
    Content-Length: 189
    Content-Type: application/json;charset=UTF-8
    Cookie: Squeezebox-albumView=; Squeezebox-expandPlayerControl=true; Squeezebox-expanded-FAVORITES=0; Squeezebox-expanded-PLUGINS=0; Squeezebox-expanded-PLUGIN_MY_APPS_MODULE_NAME=0; Squeezebox-expanded-RADIO=0; Squeezebox-enableHiDPI=1.25; _SqueezeJS-cookietest=true; Squeezebox-expanded-MY_MUSIC=1; Squeezebox-playersettings=null; Squeezebox-advancedsettings=settings/server/formatting.html%3F; Squeezebox-player=e4%3A5f%3A01%3A9e%3Aad%3A65
    Host: 192.168.1.112:9000
    Origin: http://192.168.1.112:9000
    Pragma: no-cache
    Referer: http://192.168.1.112:9000/
    User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/104.0.5112.126 Safari/537.36
    
    {"id":12,"method":"slim.request","params":["e4:5f:01:9e:ad:65",["tracks",0,25000,"tags:dikstuACRE","sort:tracknum","album_id:26247","artist_id:30499","role_id:ALBUMARTIST","library_id:0"]]}
    The response from the server however doesn't show the rating for the track in question but it contains the rating for the other track:

    Code:
    HTTP/1.1 200 OK
    Server: Logitech Media Server (8.2.0 - 1627922070)
    Connection: keep-alive
    Vary: Accept-Encoding
    Content-Encoding: gzip
    Content-Length: 378
    Content-Type: application/json
    X-Time-To-Serve: 0.0103058815002441
    
    {"result":{"titles_loop":[
    {"id":311565,"title":"The Wheal","duration":161.921,"artist_id":"30499","tracknum":"1","url":"file:///mnt/music/Library/ABC/Coil/The%20Wheal-Keelhauler/Coil%20(The%20Wheal-Keelhauler)%20-%2001%20The%20Wheal.mp3","albumartist":"Coil","trackartist":"Coil","compilation":"0"},
    {"id":311566,"title":"Keelhauler","duration":219.025,"artist_id":"30499","tracknum":"2","url":"file:///mnt/music/Library/ABC/Coil/The%20Wheal-Keelhauler/Coil%20(The%20Wheal-Keelhauler)%20-%2002%20Keelhauler.mp3","albumartist":"Coil","trackartist":"Coil","compilation":"0","rating":"60"}
    ],"count":2},
    "method":"slim.request",
    "id":12,
    "params":["e4:5f:01:9e:ad:65",["tracks","0",25000,"tags:dikstuACRE","sort:tracknum","album_id:26247","artist_id:30499","role_id:ALBUMARTIST","library_id:0"]
    ]}
    I'm puzzled what's going on here. I tried to rescan the library a few times but without any effect.
    Any idea what is happening? Where should I look at and what to look for?
    Any tips are greatly appreciated.

  2. #2
    Senior Member w3wilkes's Avatar
    Join Date
    Jan 2009
    Location
    Utah, USA
    Posts
    1,672
    Looking at everything you posted I see that this is an .mp3 file. Is there a chance that this file has both id3v1 and id3v2.3 tags? I've seen multiple tag versions do strange things in LMS. I use mp3tag with this tag setting and you can select a file or a whole directory. Then click Edit - Cut <and tell it yes, do it> Then without changing your current selection click Edit - Paste <and of course the confirm>. With these tag settings you will now just have id3v2.3 tags.
    Name:  tags.jpg
Views: 19
Size:  87.6 KB
    Main system - Rock Solid with LMS 8.2.1 on WHS 2011 - 2 Duets ( both WiFi, farthest unit gets 60% signal strength and always works since new power supply) and Squeeseslave
    Cabin system - Rock solid with LMS 8.2.1 on Win10 Pro - 1 RPi 3 Model B (WiFi) /Hifiberry DAC+ Pro/PiCorePlayer and Squeezeslave
    Squeezebox Boom - "At Large" player around both home and cabin
    Headphones and car - Android phone/Bluetooth w/full library on MicroSD card - PowerAmp music player app (similar to Material Skin)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •