Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Jan 2020
    Location
    London
    Posts
    11

    lms 8.3 and perl 5.36

    Hi Michael.

    I am running lms 8.3 on a fedora virtual machine. fedora 36 comes with perl 5.34 and LMS runs just fine.

    I've just tried fedora 37 beta, but that comes with perl5.36, and LMS won't run, as it has no 5.36 in /usr/share/squeezeboxserver/CPAN/arch/

    Leaving the lms VM on fedora 36 is not an immediate problem for me (I just copied back the old vm disc image file), but

    Do you have plans to add perl 5.36 support to lms 8.3 any time soon? If 'yes, in due course', I can wait.

    I've not looked into doing that myself yet - is it easy?

    Paul
    Last edited by Paul Barnett; 2022-09-22 at 09:47.

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,749

    lms 8.3 and perl 5.36

    > Do you have plans to add perl 5.36 support to lms 8.3 any time soon? If
    > 'yes, in due course', I can wait.


    It's mostly the latter. Once a Perl version / platform has a certain
    demand I'm usually adding support for it. But as long as it's only in a
    pre-release version of some system, or on an exotic platform, I keep
    waiting.

    > I've not looked into doing that myself yet - is it easy?


    It often is, yes :-). See
    https://github.com/Logitech/slimserv...CPAN/README.md

  3. #3
    Junior Member
    Join Date
    Jan 2020
    Location
    London
    Posts
    11
    >> I've not looked into doing that myself yet - is it easy?
    >
    > It often is, yes :-). See
    > https://github.com/Logitech/slimserv...CPAN/README.md
    >

    Thanks, I'll try it

    .... later ....

    It works!

    (fedora 37 has moved to glibc 2.36, (from 2.33) so xlocale.h is no longer provided.
    I had to fix the #include xlocale.h in ./icu/source/i18n/digitlst.cpp - (I temp symlinked xlocale.h to locale.h :-) )

    Thanks for your help - I'll run with this for now, and see how it goes.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •