Home of the Squeezebox™ & Transporter® network music players.
Page 9 of 14 FirstFirst ... 7891011 ... LastLast
Results 81 to 90 of 137
  1. #81
    Senior Member
    Join Date
    Oct 2009
    Location
    Western/Northern New York
    Posts
    1,365
    I can't add to the technical discussion, but I can report something I saw during testing. Here in the US.

    Playing DA via Paul's RNP on both a boom, and radio (on battery) in the same room, not synced. I was listening to the boom, the radio volume was low (so I didn't go nuts), and I turned it up occasionally. Both played fine for about 3 hours, then....

    I noticed the boom playing a song, scrolling the song/artist info (normal), while the radio was stuck on the station ID artwork. I turned the radio up - no sound (boom was still playing). Interestingly, the radio switched to the current song artwork info near the end of the song, then, switched to the next song artwork/info right when the boom did. But no sound from the radio. I then noticed the "square". Radio was stopped (but artwork song info kept updating, the radio did not turn off). I pressed play and everything was fine (sound restored)

    So, to the best of my testing, the boom survived the "event" but the radio did not.
    Second, the radio stopped playing the stream, but the art song info did not stop. Maybe Paul's plugin?

    Jim

  2. #82
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    6,262
    That is how my plugin family work.
    If one device is playing a station then the plugin keeps a record of what is currently playing on that station.
    Then if there is an update it sends it to all players that appear to be tuned to that same station.
    I probably should check to see if the player is really playing but my recollection is there were some situations where things got stuck ... so forcing it everywhere got around it.

    The issue with the stream stopping seems to only affect devices using Squeezeplay / Jivelite (Radio/Touch/Controller) - so not Boom/Classic etc.
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  3. #83
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    21,883
    Quote Originally Posted by Redrum View Post
    So, to the best of my testing, the boom survived the "event" but the radio did not.
    Second, the radio stopped playing the stream, but the art song info did not stop. Maybe Paul's plugin?
    Whenever you describes these event - details are important.
    Are you playing the stream direct or proxied/synced in Radio and Boom ? If direct the metadata is coming from the player and being sent to LMS, if proxied the metadata originates within LMS.

  4. #84
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    9,628
    Quote Originally Posted by bpa View Post
    Whenever you describes these event - details are important.
    Are you playing the stream direct or proxied/synced in Radio and Boom ? If direct the metadata is coming from the player and being sent to LMS, if proxied the metadata originates within LMS.
    AFAIK the metadata and cover art is coming from the Radio Now Playing plugin.

    Sent from my Pixel 3a using Tapatalk

  5. #85
    Senior Member
    Join Date
    Oct 2009
    Location
    Western/Northern New York
    Posts
    1,365
    Quote Originally Posted by bpa View Post
    Whenever you describes these event - details are important.
    Are you playing the stream direct or proxied/synced in Radio and Boom ? If direct the metadata is coming from the player and being sent to LMS, if proxied the metadata originates within LMS.
    I did mention previously - direct, and in my post you are referring to, I did mention, not synced. I had previously officered to try proxied as well. Let me know if it matters at this point.

    But it does make sense for me to repeat this info when reporting the results of a test. I will in the future

    Jim

  6. #86
    Senior Member
    Join Date
    Oct 2009
    Location
    Western/Northern New York
    Posts
    1,365
    Quote Originally Posted by Paul Webster View Post
    That is how my plugin family work.
    If one device is playing a station then the plugin keeps a record of what is currently playing on that station.
    Then if there is an update it sends it to all players that appear to be tuned to that same station.
    I probably should check to see if the player is really playing but my recollection is there were some situations where things got stuck ... so forcing it everywhere got around it.

    The issue with the stream stopping seems to only affect devices using Squeezeplay / Jivelite (Radio/Touch/Controller) - so not Boom/Classic etc.
    This make sense to what I am seeing (artwork and meta data continues), vs before on my touch where it just "stopped" (everything - go to clock ss.) where only the touch was playing.

    I agree on the "seems to" that is why I was running a boom and a radio, just to try to help to confirm the suspicions. I have not had a stop on my boom in 3 solid days of playing. My radios battery just went dead . I'll try it again tomorrow with the ps this time.

    Jim

    PS - I am willing to do any real life testing and reporting to help diagnose, just ask me. I really have no experience in the technical aspect of your discussions, so I am staying out of that!

  7. #87
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    21,883
    Quote Originally Posted by Redrum View Post
    I did mention previously - direct, and in my post you are referring to, I did mention, not synced. I had previously officered to try proxied as well. Let me know if it matters at this point.

    But it does make sense for me to repeat this info when reporting the results of a test. I will in the future
    The thread has lots of interconnected subthreads - hard to track. I'm not following this sub-thread carefully.

    My thought were that if a Radio is used as a source of metadata for all other devices by Paul's plugin, and the Radio "stops" (i.e but still connected to LMS) - will other devices see no data or will plugin changeover to a new source ?

  8. #88
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    6,262
    I suggest not worrying about this aspect for now.
    I am sure that it is not causing the playing to stop.
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  9. #89
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    21,883
    I got the stream capture program to work. It saves all MP3 in a file after a metadata title change.

    Initial test this morning using "lame" to decode the file - 3 segments - 2 track and a promo.
    The promo is in 44.1Khz but the tracks are in 32kHz

    This could explain promo being speeded up.

    Code:
    $ lame --decode Star_One_-_Songs_Of_The_Ocean\,_from_the_2003_album_\`Live_On_Earth\`.mp3 output.wav
    input:  Star_One_-_Songs_Of_The_Ocean,_from_the_2003_album_`Live_On_Earth`.mp3
            (32 kHz, 2 channels, MPEG-1 Layer I)
    
    $ lame --decode Delicious_Agony_-_DA_Interviews_Promo_#2.mp3 output.wav                             
    input:  Delicious_Agony_-_DA_Interviews_Promo_#2.mp3
            (44.1 kHz, 2 channels, MPEG-1 Layer III)
    
    $ lame --decode Jason_Becker_-_River_Of_Longing\,_from_the_2018_album_\`Triumphant_Hearts\`.mp3 output.wav
    input:  Jason_Becker_-_River_Of_Longing,_from_the_2018_album_`Triumphant_Hearts`.mp3
            (32 kHz, 2 channels, MPEG-1 Layer I)
    I'll let it run for the afternoon to get more promos & IDs.


    edit:

    *** ffmpeg says the main tracks are 44.1kHz not 32kHz - so something is odd.

    edit 2:

    mpg123 says they are 44.1Khz as well.

    Confusion might be due to MP3 fragments cut from the stream and lame has "synced" on the wrong MP3 frame header.
    Last edited by bpa; 2022-06-24 at 03:54.

  10. #90
    Senior Member
    Join Date
    Oct 2009
    Location
    Western/Northern New York
    Posts
    1,365
    Quote Originally Posted by Paul Webster View Post
    I suggest not worrying about this aspect for now.
    I am sure that it is not causing the playing to stop.
    agree, I was just reporting that my radio "stop" behaved differently than my previous touch "stop", and you explained what I saw ( more than one player in action), which I appreciate.

    I do have one question - why continue to pursue this? Are you (@bpa, @slarti, @Paul) trying to expose the cause to make sure it's not something that needs to be tweaked in LMS? Mind you, I have worked on things well past the point of common sense "just because"

    Jim

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •