Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    May 2022
    Posts
    2

    piCorePlayer USB soundcard no sound

    Hello all!
    I tried 8.1 picoreplayer in rpiZero W, but it did not connect to my wifi.
    With 6.0 i got it working and running, but the cheap usb-soundcard does not work. It does work in standard rpi os.
    I've tried hw:CARD=ALSA,DEV=1 and few other choises and disabled the hdmi, but still no sound.

    Log shows:
    [ 2.332643] usb 1-1.1: new full-speed USB device number 3 using dwc_otg
    [ 2.993030] usb 1-1.1: New USB device found, idVendor=1b3f, idProduct=2008, bcdDevice= 1.00
    [ 2.993047] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [ 2.993055] usb 1-1.1: Product: USB Audio Device
    [ 2.993062] usb 1-1.1: Manufacturer: GeneralPlus
    [ 2.999460] input: GeneralPlus USB Audio Device as /devices/platform/soc/20980000.usb/usb1/1-1/1-1.1/1-1.1:1.3/0003:1B3F:2008.0001/input/input0
    [ 3.062992] hid-generic 0003:1B3F:2008.0001: input,hidraw0: USB HID v2.01 Device [GeneralPlus USB Audio Device] on usb-20980000.usb-1.1/input3


    what to try next ?

    Name:  sounbdcard.png
Views: 179
Size:  101.3 KB
    Last edited by anon2332; 2022-05-28 at 06:20.

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    5,764
    What does
    aplay -L
    show?
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  3. #3
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,531
    hi anon2332,

    For your wifi issue see "Wifi does not work".

    For your USB DAC issue see "Add a Topping E30 USB DAC". Change the name as appropriate in step 9.

    Unless there is something really weird with your combination of hardware, I would expect your setup to be very simple, not requiring lots of unrelated changes.

    regards
    Greg

  4. #4
    Junior Member
    Join Date
    May 2022
    Posts
    2
    Thank you for your help.,
    Sound started working when i toggled off "use rasberry pi internal sound" from the web ui

  5. #5
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,531
    Sounds like good luck rather than good management.

    By default, the RPi0W has no default sound card to turn off. If you happen to plug in a HDMI screen you may get a HDMI sound driver loading as default??

    A few years ago Raspberry Pi's called their sound card ALSA which was very confusing, now it is called Headphones, b1 and b2 depending on which Raspberry Pi.

    I have been using the "3D Sound" USB sound card to test piCorePlayer and USB for many years now. Its has always worked for me.

    Here's the "Output setting" More> help, showing the soundcard on my RPi.

    For my 3D Sound USB sound card I click on "hw:CARD=Device,DEV=0"

    See my 3D Sound USB sound card uses a card name Device, almost as confusing as calling it ALSA.

    Code:
    Available output devices (click to use):
    
    hw: devices are normally the best choice, but try and decide for yourself:
    
    default
    plugequal
    equal
    hw:CARD=Headphones,DEV=0
    plughw:CARD=Headphones,DEV=0
    sysdefault:CARD=Headphones
    hw:CARD=Device,DEV=0
    plughw:CARD=Device,DEV=0
    sysdefault:CARD=Device
    front:CARD=Device,DEV=0
    surround21:CARD=Device,DEV=0
    surround40:CARD=Device,DEV=0
    surround41:CARD=Device,DEV=0
    surround50:CARD=Device,DEV=0
    surround51:CARD=Device,DEV=0
    surround71:CARD=Device,DEV=0
    iec958:CARD=Device,DEV=0
    Last edited by Greg Erskine; 2022-05-29 at 01:38.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •