Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 9 of 9
  1. #1
    Member
    Join Date
    Mar 2013
    Location
    Thulcandra
    Posts
    77

    Strange thing--no SSH

    So, one SBR-- the original one-- not UE, will not allow SSH login after rolling firmware back to 7.7.3-r16676. The WinSCP connection times out. WiFi network, IP address(name) username and password are all correct; file protocol is correctly set to SCP. I have reset factory settings.

    This happens repeatedly. I've been successful with SSH on this radio over the past couple weeks.

    Any ideas? This is a mystery.

    ~dk
    Four SBR(one 'original' and three 'improved' UEs)
    Boom with Yamaha sub
    One SB2 in the workshop
    Vintage Crosley cabinet housing PiCore, amp and speakers. Great 1940s vibe!
    Rpi 3 runs LMS; music stored on NAS

  2. #2
    Senior Member KeBul's Avatar
    Join Date
    Sep 2009
    Location
    London
    Posts
    383
    SSH on stock firmware is disabled by default... Have you enabled it in the Radio menu?

    Kev

  3. #3
    Member
    Join Date
    Mar 2013
    Location
    Thulcandra
    Posts
    77
    Quote Originally Posted by KeBul View Post
    SSH on stock firmware is disabled by default... Have you enabled it in the Radio menu?

    Kev
    Yes. I have four of these and have been SSHd into all of them multiple times over the past two weeks.

    dk
    Last edited by dkfackler; 2022-05-10 at 14:45.
    Four SBR(one 'original' and three 'improved' UEs)
    Boom with Yamaha sub
    One SB2 in the workshop
    Vintage Crosley cabinet housing PiCore, amp and speakers. Great 1940s vibe!
    Rpi 3 runs LMS; music stored on NAS

  4. #4
    Senior Member Tony T's Avatar
    Join Date
    Nov 2009
    Posts
    1,223
    Try:
    ssh -oKexAlgorithms=+diffie-hellman-group1-sha1 -c aes128-cbc <ip-address> -l root
    Tony
     SBTouch ♪ SBRadio ♬

  5. #5
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    5,704
    If the #Wiki was open ... this would go in it.
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  6. #6
    Member
    Join Date
    Mar 2013
    Location
    Thulcandra
    Posts
    77
    Quote Originally Posted by Tony T View Post
    Try:
    ssh -oKexAlgorithms=+diffie-hellman-group1-sha1 -c aes128-cbc <ip-address> -l root
    Thanks, but I don't know what to do with this. I've always used the 'idiot proof' WinSCP procedure.

    Guidance would be appreciated.

    ~dk
    Last edited by dkfackler; 2022-05-12 at 05:06.
    Four SBR(one 'original' and three 'improved' UEs)
    Boom with Yamaha sub
    One SB2 in the workshop
    Vintage Crosley cabinet housing PiCore, amp and speakers. Great 1940s vibe!
    Rpi 3 runs LMS; music stored on NAS

  7. #7
    Senior Member KeBul's Avatar
    Join Date
    Sep 2009
    Location
    London
    Posts
    383
    Quote Originally Posted by dkfackler View Post
    Thanks, but I don't know what to do with this. I've always used the 'idiot proof' WinSCP procedure.

    Guidance would be appreciated.

    ~dk
    In WinSCP session login screen...

    Select SCP
    Enter correct IP address of your SB Radio
    User name: root
    password:1234

    Then click on Advanced...

    In the Advanced Site Settings page, on the left hand pane click on SSH - Key Exchange

    In the large box of the right hand pane, click on "Diffie-Hellman group 1"

    Repeatedly Click on the Up button to move "Diffie-Hellman group 1" to the top and then click on...

    OK to close the Advanced Site setup and go back to the Login screen

    Then click on the Login button

    You'll likely get a couple of messages, don't worry about them just click on OK to both and then you should be connected and into the Radio.

    You can save that session setup change as either a site (Manage - Save As...) or make it the default settings (Manage - Set Defaults)

    Kev

  8. #8
    Member
    Join Date
    Mar 2013
    Location
    Thulcandra
    Posts
    77
    Quote Originally Posted by KeBul View Post
    In WinSCP session login screen...

    Select SCP
    Enter correct IP address of your SB Radio
    User name: root
    password:1234

    Then click on Advanced...

    In the Advanced Site Settings page, on the left hand pane click on SSH - Key Exchange

    In the large box of the right hand pane, click on "Diffie-Hellman group 1"

    Repeatedly Click on the Up button to move "Diffie-Hellman group 1" to the top and then click on...

    OK to close the Advanced Site setup and go back to the Login screen

    Then click on the Login button

    You'll likely get a couple of messages, don't worry about them just click on OK to both and then you should be connected and into the Radio.

    You can save that session setup change as either a site (Manage - Save As...) or make it the default settings (Manage - Set Defaults)

    Kev
    Thanks. They all still timeout and won't connect I'm going to be content with how things are working now.

    ~dk
    Four SBR(one 'original' and three 'improved' UEs)
    Boom with Yamaha sub
    One SB2 in the workshop
    Vintage Crosley cabinet housing PiCore, amp and speakers. Great 1940s vibe!
    Rpi 3 runs LMS; music stored on NAS

  9. #9
    Member
    Join Date
    Mar 2013
    Location
    Thulcandra
    Posts
    77

    Solved--but still strange

    So I couldn't leave well enough alone. I passed a brain stone and remembered that one bit of the sequence of events in the days prior to this loss of SSH was a new AP. All the radios connect via this AP.

    Just for something else to try, one radio was reconnected to the previous AP. SSH access worked as it should. New AP is a UniFi UAP-LR, previous is TP-Link AC750. Why this happens is beyond my understanding of IT plumbing.

    Everyone is playing together nicely now, so happiness prevails.

    Antique 'tombstone' radio RPi/PiCore player should be ready for launch later this week.

    Thanks to all who suggested SSH solutions.

    ~dk
    Four SBR(one 'original' and three 'improved' UEs)
    Boom with Yamaha sub
    One SB2 in the workshop
    Vintage Crosley cabinet housing PiCore, amp and speakers. Great 1940s vibe!
    Rpi 3 runs LMS; music stored on NAS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •