Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    Junior Member
    Join Date
    Aug 2021
    Posts
    4

    Spotty Error - Problem: Can't open file for

    Hi,

    until recently, Spotty worked fine. Suddenly the "Problem: Can't open file for" error started showing, and no tracks are played.

    I have the latest LMS and just cleared all cache and reinstalled the Spotty plugin.

    Please see the logs in the attachment.
    Attached Files Attached Files

  2. #2
    Junior Member
    Join Date
    Aug 2021
    Posts
    4
    Looks like the same thing is happening when using Spotify Connect and using the LMS player or iPeng.

  3. #3
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,724

    Spotty Error - Problem: Can't open filefor

    Please enable the "use Spotify fallback access point" option in the
    Spotty settings.

  4. #4
    Junior Member
    Join Date
    Aug 2021
    Posts
    4
    Thanks, that did the trick.

  5. #5
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,724

    Spotty Error - Problem: Can't open filefor

    > Thanks, that did the trick.

    You're based in Norway, aren't you?

  6. #6
    Junior Member
    Join Date
    May 2022
    Posts
    2

    Same problem- fallback access point also helped

    Quote Originally Posted by mherger View Post
    > Thanks, that did the trick.

    You're based in Norway, aren't you?
    ------------------

    Just for info- I had exactly the same problem from last week, and your advice with the fallback accesspoint also helped - based in Norway as well so if this is a geographical thing?
    Thanks,
    brgds Alex

  7. #7
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,724

    Spotty Error - Problem: Can't open filefor

    > Just for info- I had exactly the same problem from last week, and your
    > advice with the fallback accesspoint also helped - based in Norway as
    > well so if this is a geographical thing?


    I don't know what's going on in Spotify land. But yes, it started in
    Denmark. Suddenly the servers in Denmark wouldn't work any more. Using
    the fallback servers helped. Now next up seems Norway... Maybe I should
    just rely on the fallback servers in all cases. That certainly is not
    what Spotify designed the access point lookup for. But if they can't
    maintain the system, then we'll have to use whatever is working.

  8. #8
    Member
    Join Date
    Jan 2007
    Location
    Denmark
    Posts
    86
    Quote Originally Posted by mherger View Post
    > Just for info- I had exactly the same problem from last week, and your
    > advice with the fallback accesspoint also helped - based in Norway as
    > well so if this is a geographical thing?


    I don't know what's going on in Spotify land. But yes, it started in
    Denmark. Suddenly the servers in Denmark wouldn't work any more. Using
    the fallback servers helped. Now next up seems Norway... Maybe I should
    just rely on the fallback servers in all cases. That certainly is not
    what Spotify designed the access point lookup for. But if they can't
    maintain the system, then we'll have to use whatever is working.
    Hi ..
    I did have same topic (living in Denmark)
    Thank you for this info Mberger..
    Really appreciated.

    br
    CAAD

  9. #9
    Junior Member
    Join Date
    May 2022
    Posts
    4

    Playback works with fallback server, but Spotify Connect fails.

    Quote Originally Posted by Caad View Post
    Hi ..
    I did have same topic (living in Denmark)
    Thank you for this info Mberger..
    Really appreciated.

    br
    CAAD
    Any one in Norway / Denmark having trouble with Spotify Connect after switching to fallback servers? I can play music using LMS Web client, but soon as switching to using Spotify connect it skips thru the whole playlist (and no sound).

  10. #10
    Junior Member
    Join Date
    May 2022
    Posts
    4
    Quote Originally Posted by monocle View Post
    Any one in Norway / Denmark having trouble with Spotify Connect after switching to fallback servers? I can play music using LMS Web client, but soon as switching to using Spotify connect it skips thru the whole playlist (and no sound).
    Spotify did something to mess up Spotify Connect. Just installed Volumio which has exact same problem. There is a work-around for this:

    Add the following to the /etc/hosts on LMS:
    104.199.65.124 ap-gew4.spotify.com

    Also very important DO NOT use the Spotify Fallback Access Point (in plugin settings).


    BTW so relieved that I did not have to switch to Volumio. Bloated crap.

    Thx mherger, Your work is highly appreciated!
    Last edited by monocle; 2022-05-24 at 03:20. Reason: formatting

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •