Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Senior Member
    Join Date
    Jul 2010
    Location
    Oz
    Posts
    473

    v8.3.0+ (Mac only?): missing FreeType font causes MIS display problems

    Hi.

    I've updated to v8.3.0 and the Mac version is missing the FreeType font (FreeType.pm) - which was part of the perl 5.18 resources, I think. Some of my title formats use FreeType characters. They are no longer displayed on older devices (SqueezeBox Classic, Boom etc) with Music Information Screen.

    Will the FreeType font be readded to LMS?
    If not, can I add it as part of a plugin?

    I'd just like to have those characters displayed again on older Logitech devices with MIS.

    Thank you.

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,749
    Can you try to build it yourself?

    Code:
    sudo /Library/PreferencePanes/Squeezebox.prefPane/Contents/perl/bin/perl -MCPAN -e 'install Font::FreeType'
    I've been struggling to make it portable.
    Michael

    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
    (LMS: Settings/Information)

  3. #3
    Senior Member
    Join Date
    Jul 2010
    Location
    Oz
    Posts
    473
    Quote Originally Posted by mherger View Post
    Can you try to build it yourself?

    Code:
    sudo /Library/PreferencePanes/Squeezebox.prefPane/Contents/perl/bin/perl -MCPAN -e 'install Font::FreeType'
    I've been struggling to make it portable.
    It really is a struggle. Building it myself with the command above failed, partly because at some point it looks for perl in your user folder 'mh'. I've managed to cook up something but I'm not sure how portable it is. Maybe you can check. If you add the 2 'Font' folders (incl. the dylib) from the link below it should work - and hopefully be portable:
    https://we.tl/t-e8oxLaBe4V

    If it meets the requirements, I'd be glad to see it included in the next LMS release. Thanks.

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,749

    v8.3.0+ (Mac only?): missing FreeType fontcauses MIS display problems

    > It really is a struggle. Building it myself with the command above
    > failed, partly because at some point it looks for perl in your user
    > folder 'mh'. I've managed to cook up something but I'm not sure how
    > portable it is. Maybe you can check. If you add the 2 'Font' folders
    > (incl. the dylib) from the link below it should work - and hopefully be
    > portable:


    Unfortunately it's missing some dependencies. I believe we'd have to
    build it with statically linked dependencies (eg. it's complaining about
    lack of /usr/local/opt/libpng/lib/libpng16.16.dylib).

  5. #5
    Senior Member
    Join Date
    Jul 2010
    Location
    Oz
    Posts
    473
    Quote Originally Posted by mherger View Post
    statically linked dependencies
    And since they are not part of macOS, I suppose you meant,include them, too.
    It's just very easy to miss required dependencies when you have so much stuff installed on your machine.
    I hope I've managed to get them all now: https://we.tl/t-sYFV4Ma9Sa

  6. #6
    Senior Member
    Join Date
    Jul 2010
    Location
    Oz
    Posts
    473
    Quote Originally Posted by mherger View Post
    Can you try to build it yourself?
    Code:
    sudo /Library/PreferencePanes/Squeezebox.prefPane/Contents/perl/bin/perl -MCPAN -e 'install Font::FreeType'
    I've been struggling to make it portable.
    Apparently the latest 8.3.0 is still missing the FreeType font required for MIS to work properly. The last version I supplied (09/05) with all necessary dependencies should be portable/stand-alone and works for me.

    If the font/files won't be part of LMS, is it possible to add it (incl. the dependencies) using a small plugin or sth like that? As I understand it, fonts in a plugin packages were meant to be be used by that plugin. Or not?
    I'd only like to avoid copying the font files over every time I've installed a new LMS version. Thanks.

  7. #7
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,749

    v8.3.0+ (Mac only?): missing FreeType fontcauses MIS display problems

    > Apparently the latest 8.3.0 is still missing the FreeType font required
    > for MIS to work properly. The last version I supplied (09/05) with all
    > necessary dependencies should be portable/stand-alone and works for me.


    What Perl version is reported in Settings/Information? I might get this
    to work anyway.

  8. #8
    Senior Member
    Join Date
    Jul 2010
    Location
    Oz
    Posts
    473
    Quote Originally Posted by mherger View Post
    What Perl version is reported in Settings/Information? I might get this
    to work anyway.
    It's 5.34.0
    Thanks.

  9. #9
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,749

    v8.3.0+ (Mac only?): missing FreeType fontcauses MIS display problems

    > It's 5.34.0

    Please give the next build another try. Thanks!

  10. #10
    Senior Member
    Join Date
    Jul 2010
    Location
    Oz
    Posts
    473
    All good now, no more complaints about missing fonts, and MIS works fine. Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •