Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 13 12311 ... LastLast
Results 1 to 10 of 125
  1. #1
    Senior Member SAL9K's Avatar
    Join Date
    Oct 2020
    Posts
    139

    Song Stuck at End

    Occasionally a track will get stuck in an endless loop at the last second of the track (i.e. if a track is 1 min long, the play will continuously stutter btwn seconds 1:00-1:01, yes the time extends beyond the track length by one second, with no audio output), and only a manual next/stop/previous will get it out of this state. I have a video of this problem occurring, but cannot find the way to upload it to this forum.

    -- LMS runs on Intel NUC7i5BNK, Ubuntu 20.04 LTS
    -- LMS file type set to FLAC->FLAC prefer native
    -- Playing local FLAC's stored on NAS
    -- 4 synchronized SB Radio's, over WiFi

    Server

    Version: 8.3.0 - 1651382409 @ Mon 02 May 2022 09:40:41 AM CEST
    Hostname: xxx
    Server IP Address: x.x.x.x
    Operating system: Debian - EN - utf8
    Platform Architecture: x86_64-linux
    Perl Version: 5.30.0 - x86_64-linux-gnu-thread-multi
    Audio::Scan: 1.02
    IO::Socket::SSL: 2.067
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)

    Perhaps this is a synchronization issue (I do have 4 synchronized SB Radios), and LMS gets confused/stuck during track transitions?
    Last edited by SAL9K; 2022-05-10 at 12:30.

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,724
    Would the same happen with a single Radio instead of the synced group? Are they synced using the Groups plugin, or just LMS' own mechanism? Anything in server.log when this happens?
    Michael

    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
    (LMS: Settings/Information)

  3. #3
    Senior Member SAL9K's Avatar
    Join Date
    Oct 2020
    Posts
    139
    Quote Originally Posted by mherger View Post
    Would the same happen with a single Radio instead of the synced group? Are they synced using the Groups plugin, or just LMS' own mechanism? Anything in server.log when this happens?
    No Groups plugin, just native syncing. Unfortunately, I had the debug levels set to their defaults, so only caught the below today.

    [22-05-10 10:09:46.1991] Slim::Web::Cometd::handler (204) Invalid request without clientId - discarding remaining requests in packet
    [22-05-10 15:09:26.0985] Slim::Utils::Misc::msg (1325) Warning: [15:09:26.0980] Use of uninitialized value in concatenation (.) or string at /usr/share/squeezeboxserver/HTML/EN/settings/server/debugging.html line 12.

    I've enabled the Server category of logging levels, will run it until it happens again, first with all players synchronized, and then with a single player.
    Last edited by SAL9K; 2022-05-10 at 16:30.

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,724

    Song Stuck at End

    > What logging options should I set to potentially catch this?

    player.source

    Could transcoding be involved?

  5. #5
    Senior Member SAL9K's Avatar
    Join Date
    Oct 2020
    Posts
    139
    Attached is my server.log for a caught stuck-at-end event, FLAC 24b/44k stream to four (4) synchronized SB Radios.

    Logging items set to Debug:
    player.source
    player.streaming
    player.streaming.direct
    player.sync
    server

    -- Track where problem occurs
    [22-05-11 12:57:17.6118] Slim::Player::Song:pen (362) file:///pozzo/media/Music/Chris%20Thile/bach-sonatas-and-partitas-flac-24-44/12%20Partita%20No.%201%20in%20B%20minor,%20BWV%201 002%20VIII.%20Double.flac

    ... Still stuck over 3 hrs later
    [22-05-11 16:12:55.0450] Slim::Player::StreamingController::_eventAction (272) 00:04:20:2a:ee:30: StatusHeartbeat in PLAYING-STREAMOUT -> Slim::Player::StreamingController::_CheckSync
    [22-05-11 16:12:55.0453] Slim::Player::StreamingController::_CheckSync (505) 00:04:20:2a:ee:30 bailing as no playPoint

    Please see the attached server.log file (compressed to *.zip to save space).

    Thanks for any help.

    lms-server-log-20220511-1200.zip
    Last edited by SAL9K; 2022-05-11 at 17:04.

  6. #6
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,724

    Song Stuck at End

    > [22-05-11 16:12:55.0450] Slim::Player::StreamingController::_eventAction
    > (272) 00:04:20:2a:ee:30: StatusHeartbeat in PLAYING-STREAMOUT ->
    > Slim::Player::StreamingController::_CheckSync
    > [22-05-11 16:12:55.0453] Slim::Player::StreamingController::_CheckSync
    > (505) 00:04:20:2a:ee:30 bailing as no playPoint


    That's still related to player syncing. Did you try with just one single
    player?

  7. #7
    Senior Member SAL9K's Avatar
    Join Date
    Oct 2020
    Posts
    139
    Yes, I’m running it with a single player now, haven’t caught it yet, it’s been playing a random mix for about 6 hrs so far.

    Is there nothing interesting in the complete server log?

  8. #8
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    9,136
    I don't know if this is related but if I flick between songs in a Random Mix playlist using "next song" and "last song" controls sometimes I end up with a song that doesn't play and the elapsed time continuously alternates between 00 and 01 seconds in Material skin.

    Sent from my Pixel 3a using Tapatalk

  9. #9
    Senior Member SAL9K's Avatar
    Join Date
    Oct 2020
    Posts
    139
    Quote Originally Posted by slartibartfast View Post
    I don't know if this is related but if I flick between songs in a Random Mix playlist using "next song" and "last song" controls sometimes I end up with a song that doesn't play and the elapsed time continuously alternates between 00 and 01 seconds in Material skin.

    Sent from my Pixel 3a using Tapatalk
    Single player, or synchronized? Transcoding?

    I've been running a single player random mix now for ~20h continuous (all FLAC's w/ some 24b/96k to 24b/48k transcode's to Radio), and haven't replicated this stuck issue, seems to be synchronized only issue for me but will continue to let this run for a while longer. After I do this, I'll try the toggling forward/back to see if I can duplicate.
    Last edited by SAL9K; 2022-05-12 at 10:41.

  10. #10
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    9,136
    Quote Originally Posted by SAL9K View Post
    Single player, or synchronized? Transcoding?

    I've been running a single player random mix now for ~20h continuous (all FLAC's w/ some 24b/96k to 24b/48k transcode's to Radio), and haven't replicated this stuck issue, seems to be synchronized only issue for me but will continue to let this run for a while longer. After I do this, I'll try the toggling forward/back to see if I can duplicate.
    Single player no transcoding. I don't know if it would happen if I just allowed the playlist to play. I'll try leaving it running overnight and see how it goes.

    Sent from my Pixel 3a using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •