Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21
  1. #11
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,749

    FTS crashes with Out Of Memory error (using1, 6 GB of RAM)

    > So
    > - on scenario 1 (building FTS on startup), server uses more and more RAM
    > till it crashes with an out of memory error.
    > - on scenario 2 (building FTS while n&c scanning), server uses just a
    > little more RAM and scanner's RAM use stays constantly...


    Now that's interesting. The database indeed is configured differently in
    the server (mostly read-only) vs. the scanner (lots of writing going
    on). Cache and buffer sizes are different in these two environments.

    You could probably test this by setting the db memory to high instead of
    max, wipe the "popularTerms" and restart LMS to launch a re-build in the
    server. If my theory was right, that would run successfully, whereas
    "max" would make LMS crash.

    Your setup exposes quite some weaknesses and poor assumptions in LMS :-).

    > This time the FTS is in scanner.log - and the step, that let it crash
    > while startup before
    > (Slim::Plugin::FullTextSearch::Plugin::_rebuildInd ex (536) Optimize
    > fulltext index) is only taking 5 sec ...)


    Here I don't have any idea why that would be.

  2. #12
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,749

    FTS crashes with Out Of Memory error (using1, 6 GB of RAM)

    > You could probably test this by setting the db memory to high instead of
    > max, wipe the "popularTerms" and restart LMS to launch a re-build in the
    > server. If my theory was right, that would run successfully, whereas
    > "max" would make LMS crash.


    I've applied a change which _should_ address this case (if this
    configuration difference indeed was the reason for the crash). So no
    need to change the db memory setting if you tested with the latest LMS
    8.3 build.

  3. #13
    Senior Member
    Join Date
    Jun 2009
    Posts
    497
    Quote Originally Posted by mherger View Post
    > I've applied a change which _should_ address this case (if this
    configuration difference indeed was the reason for the crash). So no
    need to change the db memory setting if you tested with the latest LMS
    8.3 build.
    Yes, I tested with latest nightly ( r1651071091 ).

    Did some test scans to loacate the other bug (not-deleting deleted artists on a track), will try to analyze later.

  4. #14
    Senior Member
    Join Date
    Jun 2009
    Posts
    497
    I reported the "not-deleted artist-thing" in an issue
    https://github.com/Logitech/slimserver/issues/787
    Last edited by frank1969; 2022-05-02 at 02:16.

  5. #15
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,749

    FTS crashes with Out Of Memory error (using1, 6 GB of RAM)

    >>> I've applied a change which _should_ address this case (if this
    >> configuration difference indeed was the reason for the crash). So no
    >> need to change the db memory setting if you tested with the latest LMS
    >> 8.3 build.

    >
    > Yes, I tested with latest nightly ( r1651071091 ).


    Unfortunately I'm currently facing an issue with the build pipeline. The
    latest build hasn't been... ahm... built yet :-). I'll have to see
    what's wrong with it once I'm in the office.

  6. #16
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,749

    FTS crashes with Out Of Memory error (using1, 6 GB of RAM)

    > Unfortunately I'm currently facing an issue with the build pipeline. The
    > latest build hasn't been... ahm... built yet :-). I'll have to see
    > what's wrong with it once I'm in the office.


    There's a problem with our Windows signing host. So... I've disabled
    signing for this one build :-(. Hopefully it'll get through and not
    cause any additional issues for Windows users.

  7. #17
    Senior Member
    Join Date
    Jun 2009
    Posts
    497
    Quote Originally Posted by mherger View Post
    > Unfortunately I'm currently facing an issue with the build pipeline. The
    > latest build hasn't been... ahm... built yet :-). I'll have to see
    > what's wrong with it once I'm in the office.


    There's a problem with our Windows signing host. So... I've disabled
    signing for this one build :-(. Hopefully it'll get through and not
    cause any additional issues for Windows users.
    OK, just installed r1651382409

    Put the other thing into an issue:
    https://github.com/Logitech/slimserver/issues/787

  8. #18
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,749

    FTS crashes with Out Of Memory error (using1, 6 GB of RAM)

    > Put the other thing into an issue:
    > https://github.com/Logitech/slimserver/issues/787


    Thanks! I haven't found time to look into it yet, though.

  9. #19
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    9,452
    Quote Originally Posted by mherger View Post
    > Unfortunately I'm currently facing an issue with the build pipeline. The
    > latest build hasn't been... ahm... built yet :-). I'll have to see
    > what's wrong with it once I'm in the office.


    There's a problem with our Windows signing host. So... I've disabled
    signing for this one build :-(. Hopefully it'll get through and not
    cause any additional issues for Windows users.
    Slightly off topic but I notice recent LMS updates have lots of logging enabled by default for playlists. Is that intentional?

    Sent from my Pixel 3a using Tapatalk

  10. #20
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,749

    FTS crashes with Out Of Memory error (using1, 6 GB of RAM)

    > Slightly off topic but I notice recent LMS updates have lots of logging
    > enabled by default for playlists. Is that intentional?


    This should not have changed at all. Are you looking at a new
    installation? Or did you forget to reset some logging you enabled at
    some point?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •