Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Junior Member
    Join Date
    Feb 2022
    Posts
    2

    RPi (2012) + Picoreplayer + Topping D10s = Clicks/Pops/Dropouts

    Hello,

    I am an early user of the Slim Devices SB3 (2006) and LMS, and am excited to have recently found Picoreplayer which I have installed on an early RPi (two USB ports, circa 2012).

    I have connected a Topping D10s via USB, and all sounds fantastic, but I'm getting intermittent clicks. I have read though many posts on the forum, and tried all the settings that I can find on the excellent pCP Squeezelite webpage without any success. I have been able to make it worse!!

    I would welcome any thoughts, I really believe this setup is fantastic if only...........Thank you.

    Roger

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,897
    Those old boards had lots of usb problems. You can try to change the usb settings on the tweaks pageů.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Junior Member
    Join Date
    Feb 2022
    Posts
    2
    Quote Originally Posted by paul- View Post
    Those old boards had lots of usb problems. You can try to change the usb settings on the tweaks pageů.
    Went through all the tweaks and did manage to improve it, but no get rid of it totally.

    Tried it on a Pi 400 and problem went away! Thanks very much for your help.

    Roger

  4. #4
    Does the Topping have a DPLL setting? If so, you can try increasing it. Might be a jitter issue.

  5. #5
    Hello Rogers,

    Can you please elaborate the steps how you manage to get music finally? I'm trying to connect my Denafrips AresII with the RPI4. Squeezelite & LMS are running "green ticks" on the main page, how do I proceed from here to test if I have the much needed music indeed?

    TIA

  6. #6
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    9,410
    Quote Originally Posted by Narcos View Post
    Hello Rogers,

    Can you please elaborate the steps how you manage to get music finally? I'm trying to connect my Denafrips AresII with the RPI4. Squeezelite & LMS are running "green ticks" on the main page, how do I proceed from here to test if I have the much needed music indeed?

    TIA
    You can tell it is working if you can hear the music. If you have a spare SD card you could see if you can get your DAC working with Moode. It seems odd that your DAC doesn't appear by name in the drop down list in Squeezelite settings.

    Sent from my Pixel 3a using Tapatalk

  7. #7
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    9,410
    Quote Originally Posted by Narcos View Post
    Hello Rogers,

    Can you please elaborate the steps how you manage to get music finally? I'm trying to connect my Denafrips AresII with the RPI4. Squeezelite & LMS are running "green ticks" on the main page, how do I proceed from here to test if I have the much needed music indeed?

    TIA
    Is your DAC on and connected when you boot picoreplayer?

    Sent from my Pixel 3a using Tapatalk

  8. #8
    Gents,

    I FINALLY have music what an amazing feeling. I'm listening to radio just now, now I just need to mount my 4Tb usb external drive with 25k albums, any pointers on how to accomplish that "mount disk". I will eventually be using a 1Tb SSD attached to the Rpi, just fyi.

  9. #9
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    9,410
    Quote Originally Posted by Narcos View Post
    Gents,

    I FINALLY have music what an amazing feeling. I'm listening to radio just now, now I just need to mount my 4Tb usb external drive with 25k albums, any pointers on how to accomplish that "mount disk". I will eventually be using a 1Tb SSD attached to the Rpi, just fyi.
    Tell us how you got it working then

    Sent from my Pixel 3a using Tapatalk

  10. #10
    Senior Member
    Join Date
    Oct 2009
    Location
    Western/Northern New York
    Posts
    1,258
    Quote Originally Posted by Narcos View Post
    Gents,

    I FINALLY have music what an amazing feeling. I'm listening to radio just now, now I just need to mount my 4Tb usb external drive with 25k albums, any pointers on how to accomplish that "mount disk". I will eventually be using a 1Tb SSD attached to the Rpi, just fyi.
    Its in the "how tos": https://docs.picoreplayer.org/how-to/add_usb_hdd/

    Jim

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •