Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1

    Squeezelite app not responding on MacOS

    A few months ago I moved from running LMS on my Mac Mini (M1) to a PcP install on a Raspberry pi 4. This has since been delivering sounds quite happily to all players, including Ralph Irvine's Squeezelite app from Sourceforge, which I've been using to listen at my desk. Following a recent OS upgrade (minor, I think) to Monterey 12.0.1, the Squeezelite player will no longer launch properly. I've downloaded and reinstalled the mac app (Squeezelite-M1-1.9.9r1392) several times, using the xattr -cr command to sidestep the warning flag ("this app is damaged"), after which it appears to launch as normal. However, the player does not appear in LMS and when right-clicked in the dock it shows "Application Not Responding." Everything else is working as normal.

    Can anyone suggest a fix or let me know where I'm going wrong. I've no idea if the problem is new or whether I've overlooked something in the setup process, and I'm not sure where to look for any relevant information there might be in the logs. Thanks.

    My setup:
    RPI4 running piCorePlayer 8.0.0 and Squeezelite-1.9.9r1392:
    >(Living Room) Topping E30 DAC (via USB)> Hifi system.
    >(Bedroom) Squeezebox Touch > powered speakers.
    I use iPeng on various iOS devices to control the players.

  2. #2
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Please enable debug logging -d all=debug and -f /var/tmp/squeezelitelog.txt to redirect the output to a file.

    If you're running squeezelite from launchd then add the keys to then end and inside the <array> block of squeezelite.plist and unload/load the service.
    Hopefully that will help determine what's happening.

    1-Touch, 5-Classics, 3-Booms, 2-UE Radio
    Squeezebox client builds donations always appreciated.

  3. #3
    Thanks for getting back to me @ralphy. I tried following your advice but was getting lots of errors. So instead I had a crack at following your advice here and ran:
    sudo tar -C /opt -xvf squeezelite-
    This triggered a "bad permissions" error on the squeezelite.plist but I was able to fix that following advice from elsewhere, after which the install went fine. And lo!, I'm back in business, with the added advantage of an automatic start.
    Not sure what conclusions can be drawn from all that, but I'm grateful to you (once again) for the kind help.

  4. #4
    Quick update: I realised that the version I installed there was Intel rather than the updated M1. So even though it appeared to be working fine I reinstalled the M1 version which worked straight out of the box. So I guess it's reasonable to conclude that the issue was bad permissions all along, though I've no idea at what point they might have got changed in the past. Cheers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts