Quote Originally Posted by Jeff07971 View Post
OK

We now know that its software !

Your conf file runs OK on my pCP and enables NEC protocol but dosent on your pCP

I called your file "Nec.conf" and edited it in MS Windows Notepad

Nec.conf

Can you upload this and try "sudo ir-keytable" and "sudo ir-keytable -t" again

Jeff
[ INFO ] Uploading: jivelite keytables
[ INFO ] Backing up files to /mnt/mmcblk0p2/tce/mydata.tgz /
Done.
[ OK ] Backup successful.
[ INFO ] Loading keytable
[ INFO ] Backing up files to /mnt/mmcblk0p2/tce/mydata.tgz /
Done.
[ OK ] Backup successful.




Wahou !!!

Found /sys/class/rc/rc0/ (/dev/input/event0) with:
Name: gpio_ir_recv
Driver: gpio_ir_recv, table: rc-rc6-mce
LIRC device: /dev/lirc0
Supported kernel protocols: lirc rc-5 rc-5-sz jvc sony nec sanyo mce_kbd rc-6 sharp xmp imon
Enabled kernel protocols: lirc nec
bus: 25, vendor/product: 0001:0001, version: 0x0100
Repeat delay = 500 ms, repeat period = 125 ms

tc@pCP:~$ sudo ir-keytable -t
Testing events. Please, press CTRL-C to abort.
21908.790063: lirc protocol(nec32): scancode = 0x87eee25e
21908.790086: event type EV_MSC(0x04): scancode = 0x87eee25e
21908.790086: event type EV_SYN(0x00).
21908.880094: lirc protocol(nec32): scancode = 0x87eee204
21908.880108: event type EV_MSC(0x04): scancode = 0x87eee204
21908.880108: event type EV_SYN(0x00).

It works!!!!

I saw too late my file has a .rtf extension. That probably why it doesn't work but without any error message !!!


Thanks a lot Jeff !!!!! GREAT JOB !!!