Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 10 of 10
  1. #1
    Junior Member
    Join Date
    Jan 2022
    Posts
    6

    Externer DAC / AMP per USB an Raspberry Pi nach einschalten weg

    Hallo,

    ich hoffe hier bin ich richtig.

    Ich betreibe einen FiiO K5 Pro ESS per USB an einem Raspberry Pi 4.

    Ich habe den piCore Player installiert, in neuester Version, habe alles nach Anleitung eingerichtet, läuft hervorragend, bis zu einem bestimmten Punkt.

    Name:  Screenshot 2022-01-13 14.28.45.png
Views: 180
Size:  190.2 KB

    Sobald ich aber den Hörplatz verlasse, schalte ich den FiiO USB DAC aus, logisch.

    Gehe ich wieder an den Hörplatz, schalte wieder an, kommt kein Ton.

    Ich muss dann einen Reboot des Raspberry machen, vielleicht würde es auch reichen LMS neu zu starten.

    Was muss ich eingeben, eintragen oder einstellen um das Problem zu beheben?

    Ausgabe per SSH:

    tc@pCP:~$ cat /proc/asound/cards
    0 [Headphones ]: bcm2835_headpho - bcm2835 Headphones
    bcm2835 Headphones
    1 [Pro ]: USB-Audio - FiiO K5 Pro
    GuangZhou FiiO Electronics Co.,Ltd FiiO K5 Pro at usb-0000:01:00.0-1.4, high sp

    tc@pCP:~$ sudo aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
    Subdevices: 8/8
    Subdevice #0: subdevice #0
    Subdevice #1: subdevice #1
    Subdevice #2: subdevice #2
    Subdevice #3: subdevice #3
    Subdevice #4: subdevice #4
    Subdevice #5: subdevice #5
    Subdevice #6: subdevice #6
    Subdevice #7: subdevice #7
    card 1: Pro [FiiO K5 Pro], device 0: USB Audio [USB Audio]
    Subdevices: 0/1
    Subdevice #0: subdevice #0

    Vielen Dank für den Support!

    Ralf
    Last edited by raun; 2022-01-13 at 06:52.

  2. #2
    Junior Member
    Join Date
    Jan 2022
    Posts
    6
    Bin ich hier richtig?

    Name:  Screenshot 2022-01-13 14.56.03.png
Views: 106
Size:  57.2 KB

    Habe nun Nano installiert und folgende Datei für die Bearbeitung gefunden.

    Könnte ich hier die Soundkarte als "default" einrichten?

    Ich will am System nichts zerstören, läuft doch so schön.

    GNU nano 5.2 /etc/asound.conf
    # default - Generated by piCorePlayer
    pcm.!default {
    type plug
    slave.pcm "hw:0,0"
    }

    pcm.pcpinput {
    type hw
    card Headphones
    device 0
    }

    #---ALSA EQ Below-
    pcm.sound_device {
    type plug
    slave.pcm {
    type hw
    card Headphones
    device 0
    }
    }
    Last edited by raun; 2022-01-13 at 07:25.

  3. #3
    Junior Member
    Join Date
    Jan 2022
    Posts
    6
    Hallo,

    also leider kein Erfolg, wäre sehr dankbar wenn sich hier Hilfe findet.

    Ein schneller Squezzebox Neustart reicht, der Pi kann also weiter laufen.

    Kein Beinbruch, aber blöd

  4. #4
    Junior Member
    Join Date
    Jan 2022
    Posts
    6
    Hallo,

    anything there?

    Kind regards!

  5. #5
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    5,152
    Quote Originally Posted by raun View Post
    Hallo,

    anything there?

    Kind regards!
    There are two suggestions at the start of this thread

    https://forums.slimdevices.com/showt...lug-in-USB-dac

    If they don't work, read through the thread


    People try to respond to threads in a helpful manner. Sometimes they have experience of the problem, sometimes not. Sometimes they search the forum and provide a link (hopefully the correct one)

    It pays to be patient

    ronnie

  6. #6
    Junior Member
    Join Date
    Jan 2022
    Posts
    6
    Hey thanks, didnt check the "non-german" section!

    Will check and hopefully understand

    Kind regards from germany.

  7. #7
    Junior Member
    Join Date
    Jan 2022
    Posts
    6
    Good morning, guten Morgen.

    Leider nein, ich bekomme es nicht hin, egal was ich versuche.

    No, it is not working properly.

  8. #8
    Hallo,
    ich habe ziemlich genau das gleiche Problem:
    Der Picoreplayer mit LMS läuft super (vielen Dank an alle, die da mitgearbeitet haben) und Qobuz läuft super drauf. Das hab ich soweit alles bei mir hinbekommen.
    Als DAC läuft bei mir mein Advance Paris A10 und dies läuft auch prima über USB-audio und hw:CARD=Classic,DEV=0.

    Wenn ich jedoch den Amp zwischendurch auf einen anderen Eingang stelle oder aber ausschalte, muss ich auch den Picoreplayer neu starten.

    habe mir die oben genannten 34-Seiten auf durchgelesen (meist jedoch immer weniger verstanden und einiges ausprobiert... jedoch ohne Erfolg, was vermutlich jedoch mit meinem Nicht-Wissen zusammenhängt.

    @raun vielleicht kommen wir ja gemeinsam weiter...

    LG KM

  9. #9
    Senior Member
    Join Date
    Jun 2011
    Posts
    162
    Hallo,

    ich kann euer Problem nicht nachvollziehen. Ich betreibe einen Questyle CMA 400 i als externen DAC, den ich immer hart ausschalte (schaltbarer Stromverteiler) wenn ich nicht mehr höre und hatte noch nie das Problem. Es kommt immer sofort Musik. Vielleicht mal die -C Option versuchen.

    Viele Grüße
    Christian
    Raspi 4 as server for various things besides lms
    Raspi 3 feeding a SPL Phonitor xe for headphones
    Minidsp shd running squeezelite feeding a poweramp and a pair of Nubert nuvero 70 and 2 elac Sub 2070
    2 Squeezebox Radios (kitchen and bath)
    Nubert NuPro A200, AW350 Sub , raspi 3 with hifiberry digi+ for the bedroom
    raspi A with M2Tech HiFace usb dac and JBL Control 1 for the balcony :-)

  10. #10
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    5,152
    google translate


    @raun; @KlausMartin;

    Sie müssen beide genauere Angaben machen

    Ich habe ein rpi3b+ mit dem Signaturboard allo digione.

    Es verbindet sich mit einem Quad CD-2 über Co-ax SPDIF.

    Squeezelite hat die Einstellung -C 5

    Name:  squeezelite -C.png
Views: 65
Size:  44.1 KB

    Denken Sie daran, auf "Speichern" zu klicken

    Wenn Sie den USB-Ausgang verwenden, sollte Squeezelite so aussehen

    /usr/local/bin/squeezelite -n "USB" -o hw:CARD=Control,DEV=0 -a 80:4::0: -C 5
    Ich kann das Quad einschalten und die optische (TV-) Verbindung verwenden, auf die Co-ax-Verbindung umschalten, den Himbeer-Pi einschalten und es spielt.

    I hope this helps

    ronnie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •