Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: Empty genres

  1. #1
    Senior Member
    Join Date
    Apr 2008
    Location
    Toronto area, Canada
    Posts
    1,452

    Empty genres

    I'm on an endless task of rationalizing genres, after years of neglect. I'm trying to reduce the number of genres by eliminating overlap and correcting obvious stupidities. Perfection is not the goal.

    In a number of cases I have completely eliminated a genre and re-assigned the tracks to other genres. However, the genre often but not always remains, but shows as empty. So no tracks have that genre, but it still stays in the list.

    This is after a full rescan.

    Why is this?

    Ron
    LMS on a dedicated server (PiCorePlayer)
    Transporter (Ethernet) - main listen ining, Onkyo receiver, Paradigm speakers
    Touch (WiFi) - home theater 5.1, Sony receiver, Energy speakers
    Boom 1 (WiFi) - work-space
    Boom 2 (WiFi) - various (deck, garage, etc.)
    Radio (WiFi) - home office
    Control - Squeeze Control (Android mobile), 2 Controllers (seldom used), Squeeze Remote (on Surface Pro 4)
    Touch x 1 - spare
    UE Radio x 1 - spare
    Boom x 1 - spare
    Controller x 1 - Spare

  2. #2
    Senior Member
    Join Date
    Apr 2008
    Location
    Toronto area, Canada
    Posts
    1,452
    I was tidying up genres in preparation for migrating to a PiCorePlayer from my old and barely functional Win10 server. So I accelerated that, thinking the new scan with the new server would solve the problem.

    Sadly, no. Still empty genres. I think this means the genre category is in some way a lingering presence in the music files, although invisible in MP3tag.

    Any ideas?

    R.
    LMS on a dedicated server (PiCorePlayer)
    Transporter (Ethernet) - main listen ining, Onkyo receiver, Paradigm speakers
    Touch (WiFi) - home theater 5.1, Sony receiver, Energy speakers
    Boom 1 (WiFi) - work-space
    Boom 2 (WiFi) - various (deck, garage, etc.)
    Radio (WiFi) - home office
    Control - Squeeze Control (Android mobile), 2 Controllers (seldom used), Squeeze Remote (on Surface Pro 4)
    Touch x 1 - spare
    UE Radio x 1 - spare
    Boom x 1 - spare
    Controller x 1 - Spare

  3. #3
    Senior Member ModelCitizen's Avatar
    Join Date
    May 2005
    Location
    Sussex UK
    Posts
    3,278
    I've had a similar problem before. There are various versions of tags, not always immediately visible in MP3tag. If you delve around you'll find how to view them all. Hopefully that's your answer.

    Here:

    MP3Tag/Tools/Options/Tags.
    Last edited by ModelCitizen; 2022-01-12 at 15:50.
    Take care of your tongue. It is in a wet place and can easily slip.

    Lounge: Naim NDX with Touch as controller, Naim NAP 180, NAC 82, NAPSC, HiCap, Shahinian Arc speakers
    Kitchen/outside: Chromecast audio, Azatom iBigBoy 2 (500W)
    And... SB+, radios & tons of Chromecasts... all run from LMS and controlled via Material Skin on any nearby device and a couple of Touchs.

  4. #4
    Senior Member
    Join Date
    Apr 2008
    Location
    Toronto area, Canada
    Posts
    1,452
    I went over for advice to the MP3tag forum, and it was suggested that the residual tags might be linked to APE tags somehow. Received helpful advice on to strip these out using MP3tag, which I did. There are no remaining APE tags.

    Sadly, no joy.

    The same residual tags are showing up after having done that adjustment on some 244 files, and then doing a full rescan of the library. It's clearly something in the tag structure, not a holdover within LMS, as I did a complete conversion to a PCP server, with a complete new scan and a different file path. Still the same result -- a number of genres are shown, but they are empty. The genre is identified from somewhere, even though there are no files with that genre tag.

    This is a mystery.

    R.
    LMS on a dedicated server (PiCorePlayer)
    Transporter (Ethernet) - main listen ining, Onkyo receiver, Paradigm speakers
    Touch (WiFi) - home theater 5.1, Sony receiver, Energy speakers
    Boom 1 (WiFi) - work-space
    Boom 2 (WiFi) - various (deck, garage, etc.)
    Radio (WiFi) - home office
    Control - Squeeze Control (Android mobile), 2 Controllers (seldom used), Squeeze Remote (on Surface Pro 4)
    Touch x 1 - spare
    UE Radio x 1 - spare
    Boom x 1 - spare
    Controller x 1 - Spare

  5. #5
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    8,923
    Quote Originally Posted by RonM View Post
    I went over for advice to the MP3tag forum, and it was suggested that the residual tags might be linked to APE tags somehow. Received helpful advice on to strip these out using MP3tag, which I did. There are no remaining APE tags.

    Sadly, no joy.

    The same residual tags are showing up after having done that adjustment on some 244 files, and then doing a full rescan of the library. It's clearly something in the tag structure, not a holdover within LMS, as I did a complete conversion to a PCP server, with a complete new scan and a different file path. Still the same result -- a number of genres are shown, but they are empty. The genre is identified from somewhere, even though there are no files with that genre tag.

    This is a mystery.

    R.
    Which tags are left. I remove all tags apart from ID3v2. You might still have ID3v1 tags.

    Sent from my Pixel 3a using Tapatalk

  6. #6
    Senior Member
    Join Date
    Apr 2008
    Location
    Toronto area, Canada
    Posts
    1,452
    Quote Originally Posted by slartibartfast View Post
    Which tags are left. I remove all tags apart from ID3v2. You might still have ID3v1 tags.

    Sent from my Pixel 3a using Tapatalk
    It remains a mystery. No files/tracks are assigned the genre, but the genre still shows up in the genre list, but this is reported as "empty". All APE tags are removed, and only ID3v2 are being reported. There is no discrepancy with v1 tags. And no files at all are associated with the ghost genres.

    R.
    LMS on a dedicated server (PiCorePlayer)
    Transporter (Ethernet) - main listen ining, Onkyo receiver, Paradigm speakers
    Touch (WiFi) - home theater 5.1, Sony receiver, Energy speakers
    Boom 1 (WiFi) - work-space
    Boom 2 (WiFi) - various (deck, garage, etc.)
    Radio (WiFi) - home office
    Control - Squeeze Control (Android mobile), 2 Controllers (seldom used), Squeeze Remote (on Surface Pro 4)
    Touch x 1 - spare
    UE Radio x 1 - spare
    Boom x 1 - spare
    Controller x 1 - Spare

  7. #7
    Senior Member SlimChances's Avatar
    Join Date
    Apr 2005
    Posts
    1,836
    Not sure if this would help but did you look at Extended Tags under View in MP3Tag.
    Logitech Media Server Version: 8.3.0 - 1645717927 @ Thu 24 Feb 2022 05:23:32 PM CET
    Operating system: Debian - EN - utf8
    Platform Architecture: x86_64-linux
    Perl Version: 5.30.0 - x86_64-linux-gnu-thread-multi
    IO::Socket::SSL: 2.067
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)

    One SB Touch connected by Ethernet - Denon AVR -1912 Receiver, Paradigm 4.1 speakers
    SB Touch connected by Optical to Sabaj A4
    amp and Energy bookshelf speakers
    Two SB Radios wireless

  8. #8
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,719

    Empty genres

    > It remains a mystery. No files/tracks are assigned the genre, but the
    > genre still shows up in the genre list, but this is reported as "empty".


    Did you try a full wipe & rescan?

  9. #9
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    5,192
    Quote Originally Posted by RonM View Post
    It remains a mystery. No files/tracks are assigned the genre, but the genre still shows up in the genre list, but this is reported as "empty". All APE tags are removed, and only ID3v2 are being reported. There is no discrepancy with v1 tags. And no files at all are associated with the ghost genres.

    R.
    No discrepancy with v1 tags? Does that mean there are v1 tags? These should be removed. My mp3tag settings below.

    Name:  mp3tag.jpg
Views: 70
Size:  48.7 KB
    LMS server/study player - LMS 8.3.0 Pi4B 4GB/NanoSound ONE case/pCP 8.1.0 - 75K library, playlists & LMS cache on Sata SSD (ntfs)
    Lounge - Pi2/pCP 8.1.0 > HiFiBerry DIGI+ > Topping E30 > AVI DM5
    Dining Room - Echo Show 8
    Garage - Squeezebox Touch > Edifier

    Spares - 1xSB Touch, 1xSB3, 4xRPi, 1xDAC32, 1xCORE32

  10. #10
    Senior Member
    Join Date
    Oct 2008
    Location
    The Hague, Netherlands
    Posts
    186
    Are you using online music libraries like spotify, qobuz, etc? Maybe some genres get imported from online music files?
    Living: EtherRegen -> Ultrarendu -> Benchmark DAC2 HGC -> Benchmark AHB2 -> ATC SCM19 v2 & Sennheiser HD650
    Kitchen: SB Touch -> Audio Pro Addon T10 gen2
    Kids rooms: SB Booms
    Bedroom: SB Boom & SB Radio
    Controls: Material Skin & LMS via internet, iPeng
    Server: Windows 10 Pro with LMS 8.3
    Spare: 2 SB Touch, 1 SB3, 2 SB Radio

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •