Quote Originally Posted by mherger View Post
> Well, did all that and it didn't help. I gave perl, bash, and perl5.18
> full disk access using the instructions above; same error message.


As well as sh? Can you share screenshots of the relevant settings?
OK, added "sh" to full disk access and then cleared caches.
(I tried to clear caches before, but this time LMS gave me a warning that it would have to stop the server to do so, so I think it actually cleared them where it might not have before.)

That combination seems to have fixed the original permissions error; the scanner made its way through 28,000 files on the external drive and reported only a few minor issues with certain files.

(I'll consolidate all the steps above into one post so that the next person doesn't need to bother you.)

The scanner imported about 28,000 files (of 79,000) and then quit with this in the log:

[21-11-30 06:04:45.4193] Slim::Music::Import::runImporter (578) Starting Slim::Plugin::iTunes::Importer scan
[21-11-30 06:05:33.0586] Carp::Clan::__ANON__ (216) Warning: DBIx::Class::ResultSet::single(): Query returned more than one row. SQL that returns multiple rows is DEPRECATED for ->find and ->single at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Slim/Schema.pm line 2314
[21-11-30 06:05:33.1227] main::main (338) Error: Failed when running main scan: [Can't call method "id" on an undefined value at /Library/PreferencePanes/Squeezebox.prefPane/Contents/server/Slim/Schema.pm line 905.
]
[21-11-30 06:05:33.1230] main::main (339) Error: Skipping post-process & Not updating lastRescanTime!

I will fiddle with scanning methods and whether or not to use iTunes later to try to figure this out, but the permissions issue seems to be solved.

Thanks much for your patient help!