Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 8 FirstFirst 1234 ... LastLast
Results 11 to 20 of 77
  1. #11
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,778
    Using hifiberry os to test your board is normally the best way to get answers.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  2. #12
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    5,031
    Quote Originally Posted by Seanf View Post
    Haha, yes. Maybe I should pop over and rattle their cage, it's just across town :-) I think I will try their OS, that would tell me if the problem is with board itself, as surely it should work with their own software.

    Yep, and there is a squeezelite setting

    Let's hope it's not a load of

    Name:  small-Berliner-0068.jpg
Views: 448
Size:  81.2 KB

    ronnie

    And I have just finished a coffee

  3. #13
    Junior Member
    Join Date
    Mar 2020
    Posts
    13
    I tried the HifiBerry OS and still nothing comes out so I'm thinking the card is faulty. I'll email them for a replacement.

    Cheers

    Sean

  4. #14
    Junior Member
    Join Date
    Mar 2020
    Posts
    13
    Just to update the thread. I sent the card back, they tested it, confirmed it was faulty and sent me a new one. They even refunded the postage I paid to send it back. Good service.

    Plugged it in and it worked straight away with no settings changed from the Digi+ Pro, so I'm very happy now. The system sounds magnificent!

    Thanks for everybody's help.

    Sean

  5. #15
    I encountered a similar problem today.

    Digi2 on a Raspberry Pi 4 Model B Rev 1.5, powered by standard Pi4 power supply, no other connections other than SD card and Digi2.

    First I was using piCorePlayer 8.1.0, 64 Bit Kernel:

    I set the audio output to Hifiberry Digi+ Pro as commonly advised and squeezelite immediately stopped working after reboot. Then I began to search for explanations:


    This is pcp_boot.log:

    Code:
     [ INFO ] pcp_boot.log
    
        Starting piCorePlayer v8.1.0 startup...
        Loading aes kernel modules for faster SSL... Done.
        Starting rngd using /dev/hwrng... Done.
        Checking for boot files on mmcblk0p1...
        Trying to mount /dev/mmcblk0p1.
        ssh file found on mmcblk0p1.
        newpcp.cfg not found on mmcblk0p1.
        Setting default piCorePlayer repository...
        Generating sound card drop-down list...
        Starting WiFi on wlan0...
        udhcpc: started, v1.34.1
        udhcpc: broadcasting discover
        udhcpc: broadcasting discover
        udhcpc: broadcasting discover
        udhcpc: broadcasting select for 192.168.178.48, server 192.168.178.1
        udhcpc: lease of 192.168.178.48 obtained from 192.168.178.1, lease time 864000
        deleting routers
        route: SIOCDELRT: No such process
        adding dns 192.168.178.1
        Starting WiFi... Done.
        Loading piCorePlayer configuration file... Done.
        Loading pcp-lms-functions... Done.
        Waiting for sound card sndrpihifiberry to populate......................................... Failed to find sndrpihifiberry... Done (42).
        Waiting for network. Done (1).
        Starting OpenSSH server... Done.
        Mounting USB Drives...
        Mounting USB Drive: dcf19a53-9d0a-44e7-92b6-2ae4089c815f...
        mount: /dev/mmcblk0p3 mounted on /mnt/data.
        Disk Mounted at /mnt/data.
        Done.
        Waiting for valid date before starting LMS... Done. (0)
        Starting LMS, this can take some time...[22-01-20 12:00:40.1857] main::init (390) Starting Logitech Media Server (v8.2.0, 1627922070, Tue Aug 3 11:43:18 CEST 2021) perl 5.032001 - aarch64-linux-thread-multi
    
        Slimserver Running pid:9011
        Done.
        Waiting for LMS to initiate... Done (3).
        Starting Squeezelite and/or Shairport-sync... Done.
        Starting httpd web server... Done.
        Starting to advertise pcp.local... Done.
        Setting CPU scaling governor to ondemand... Done.
        Creating static footer... Done.
    
        Finished piCorePlayer v8.1.0 startup.
    
        To setup piCorePlayer, use the web interface via a browser:
        - http: //192. 168. 178. 48 (wlan0)
        - http: //pcp. local (mdnsd)
    
        Press [Enter] to access console.
    
        In the background, ntpd is syncing time between piCorePlayer and the internet.
        A large offset between 1970 and now is normal.

    After this, I installed HifiberryOS and after connecting to the device via Ethernet, I was presented with a "Beocreate" surface where I could choose which speaker to amplify. I think this is not correct.

    Then I tried piCorePlayer ver. 6.1, 7, 8, 8.1 all in 32 Bit Kernel, after using 64 Bit Kernel yesterday with ver 8.1.

    I could not connect to piCorePlayer versions 6.1 and 7 over Ethernet and had no patience to troubleshoot the reason why.
    The versions 8 and 8.1 do all show squeezelite not running. With 8.1 I tried to add force_eeprom_read=0 to the config.txt, but this did not change a thing.

    In the submenu "HAT information" is an entry which baffles me: although piCorePlayer cannot start the Digi2 as indicated in pcp_boot.log, there is information about a Digi2 Pro. Not even Digi+ Pro, which is the overlay used in piCorePlayer settings, but Digi2. how comes this?

    Code:
    HAT information
    
    name
    hat
    
    product
    Digi2 Pro
    
    product_id
    0x0000
    
    product_ver
    0x0000
    
    uuid
    5af941bb-4dcf-4eac-82a8-e36e84fcabef
    
    vendor
    HiFiBerry
    
    DATA:
    "hat", "Digi2 Pro", "0x0000", "0x0000", "5af941bb-4dcf-4eac-82a8-e36e84fcabef", "HiFiBerry",
    dmesg | grep soc:sound
    [ INFO ] dmesg
    Overlays in /mnt/mmcblk0p1/config.txt
    [ INFO ] Overlays
    dtoverlay=disable-bt dtoverlay=hifiberry-digi-pro
    I am about to send this board back, but would still like to get it going if it was possible. Any ideas how to continue?

  6. #16
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    5,031
    Quote Originally Posted by sheeple View Post
    I encountered a similar problem today.

    Digi2 on a Raspberry Pi 4 Model B Rev 1.5, powered by standard Pi4 power supply, no other connections other than SD card and Digi2.

    First I was using piCorePlayer 8.1.0, 64 Bit Kernel:

    I set the audio output to Hifiberry Digi+ Pro as commonly advised and squeezelite immediately stopped working after reboot. Then I began to search for explanations:

    After this, I installed HifiberryOS and after connecting to the device via Ethernet, I was presented with a "Beocreate" surface where I could choose which speaker to amplify. I think this is not correct.

    I am about to send this board back, but would still like to get it going if it was possible. Any ideas how to continue?


    I don't understand your experience with the HiFiBerry OS, I have used it several times without a problem

    However, I suggest you try a copy of

    https://downloads.raspberrypi.org/raspios_lite_armhf/images/raspios_lite_armhf-2021-11-08/2021-10-30-raspios-bullseye-armhf-lite.zip


    Install the overlay and squeezelite and see if the board is recognised

    If you need any help, just ask

    ronnie

  7. #17
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    5,031
    I have the version of the board before the update one

    pi@raspberry:~ $ squeezelite -l
    Output devices:
    null - Discard all samples (playback) or generate zero samples (capture)
    hw:CARD=Headphones,DEV=0 - bcm2835 Headphones, bcm2835 Headphones - Direct hardware device without any conversions
    plughw:CARD=Headphones,DEV=0 - bcm2835 Headphones, bcm2835 Headphones - Hardware device with all software conversions
    default:CARD=Headphones - bcm2835 Headphones, bcm2835 Headphones - Default Audio Device
    sysdefault:CARD=Headphones - bcm2835 Headphones, bcm2835 Headphones - Default Audio Device
    dmix:CARD=Headphones,DEV=0 - bcm2835 Headphones, bcm2835 Headphones - Direct sample mixing device
    hw:CARD=vc4hdmi0,DEV=0 - vc4-hdmi-0, MAI PCM i2s-hifi-0 - Direct hardware device without any conversions
    plughw:CARD=vc4hdmi0,DEV=0 - vc4-hdmi-0, MAI PCM i2s-hifi-0 - Hardware device with all software conversions
    default:CARD=vc4hdmi0 - vc4-hdmi-0, MAI PCM i2s-hifi-0 - Default Audio Device
    sysdefault:CARD=vc4hdmi0 - vc4-hdmi-0, MAI PCM i2s-hifi-0 - Default Audio Device
    hdmi:CARD=vc4hdmi0,DEV=0 - vc4-hdmi-0, MAI PCM i2s-hifi-0 - HDMI Audio Output
    dmix:CARD=vc4hdmi0,DEV=0 - vc4-hdmi-0, MAI PCM i2s-hifi-0 - Direct sample mixing device
    hw:CARD=vc4hdmi1,DEV=0 - vc4-hdmi-1, MAI PCM i2s-hifi-0 - Direct hardware device without any conversions
    plughw:CARD=vc4hdmi1,DEV=0 - vc4-hdmi-1, MAI PCM i2s-hifi-0 - Hardware device with all software conversions
    default:CARD=vc4hdmi1 - vc4-hdmi-1, MAI PCM i2s-hifi-0 - Default Audio Device
    sysdefault:CARD=vc4hdmi1 - vc4-hdmi-1, MAI PCM i2s-hifi-0 - Default Audio Device
    hdmi:CARD=vc4hdmi1,DEV=0 - vc4-hdmi-1, MAI PCM i2s-hifi-0 - HDMI Audio Output
    dmix:CARD=vc4hdmi1,DEV=0 - vc4-hdmi-1, MAI PCM i2s-hifi-0 - Direct sample mixing device
    hw:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_digi, HiFiBerry Digi+ Pro HiFi wm8804-spdif-0 - Direct hardware device without any conversions
    plughw:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_digi, HiFiBerry Digi+ Pro HiFi wm8804-spdif-0 - Hardware device with all software conversions
    default:CARD=sndrpihifiberry - snd_rpi_hifiberry_digi, HiFiBerry Digi+ Pro HiFi wm8804-spdif-0 - Default Audio Device
    sysdefault:CARD=sndrpihifiberry - snd_rpi_hifiberry_digi, HiFiBerry Digi+ Pro HiFi wm8804-spdif-0 - Default Audio Device
    iec958:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_digi, HiFiBerry Digi+ Pro HiFi wm8804-spdif-0 - IEC958 (S/PDIF) Digital Audio Output
    dmix:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_digi, HiFiBerry Digi+ Pro HiFi wm8804-spdif-0 - Direct sample mixing device
    dsnoop:CARD=sndrpihifiberry,DEV=0 - snd_rpi_hifiberry_digi, HiFiBerry Digi+ Pro HiFi wm8804-spdif-0 - Direct sample snooping device
    one can check if the overlay loaded

    pi@raspberry:~ $ sudo vcdbg log msg |& grep -v HDMI
    005355.911: arasan: arasan_emmc_open
    005801.256: brfs: File read: /mfs/sd/config.txt
    005802.235: brfs: File read: 2100 bytes
    005976.808: brfs: File read: /mfs/sd/config.txt
    007051.816: gpioman: gpioman_get_pin_num: pin DISPLAY_DSI_PORT not defined
    007054.337: *** Restart logging
    007054.358: brfs: File read: 2100 bytes
    007341.537: dtb_file 'bcm2711-rpi-4-b.dtb'
    007353.784: brfs: File read: /mfs/sd/bcm2711-rpi-4-b.dtb
    007353.815: Loading 'bcm2711-rpi-4-b.dtb' to 0x100 size 0xc957
    007386.850: brfs: File read: 51543 bytes
    007404.116: brfs: File read: /mfs/sd/overlays/overlay_map.dtb
    007572.492: brfs: File read: 1703 bytes
    007575.622: brfs: File read: /mfs/sd/config.txt
    007605.523: Loaded HAT overlay
    007605.546: dtparam: audio=on
    007693.636: brfs: File read: 2100 bytes
    007701.979: brfs: File read: /mfs/sd/overlays/hifiberry-digi.dtbo
    007739.728: Loaded overlay 'hifiberry-digi'
    007802.153: brfs: File read: 959 bytes
    007824.508: brfs: File read: /mfs/sd/overlays/vc4-kms-v3d-pi4.dtbo
    007985.804: Loaded overlay 'vc4-kms-v3d'
    008413.607: brfs: File read: 3823 bytes
    008416.193: brfs: File read: /mfs/sd/cmdline.txt
    008416.259: Read command line from file 'cmdline.txt':
    008416.281: 'console=serial0,115200 console=tty1 root=PARTUUID=38cf8b5f-02 rootfstype=ext4 fsck.repair=yes rootwait'
    008774.594: brfs: File read: 102 bytes
    010175.638: brfs: File read: /mfs/sd/kernel7l.img
    010175.676: Loading 'kernel7l.img' to 0x8000 size 0x679a48
    010175.729: Device tree loaded to 0x2eff2e00 (size 0xd18a)
    010185.961: gpioman: gpioman_get_pin_num: pin SDCARD_CONTROL_POWER not defined
    013774.965: vchiq_core: vchiq_init_state: slot_zero = 0xdad80000, is_master = 1
    013786.027: TV service:host side not connected, dropping notification 0x00000002, 0x00000001, 0x00000010
    ronnie

  8. #18
    Quote Originally Posted by Man in a van View Post
    I don't understand your experience with the HiFiBerry OS, I have used it several times without a problem
    My guess was the Digi2 is not recognized and hence misrecognized as a Beocreate amp. Maybe Beocreate is assigned when the OS sees something, but all full.

    Quote Originally Posted by Man in a van View Post
    Install the overlay and squeezelite and see if the board is recognised
    I am burning the image to the SD atm. Any manuals on how to install the overlay and squeezelite or is this a matter of clicks in the interface of the raspberry pi OS?

    I am working from a Windows 10 machine, Pi4 connected via ethernet to the router.

    edit: okay, after I tried to "open" the interface via IP adress I figured everythink needs to be done via SSH. This seems to be some work.
    Last edited by sheeple; 2022-01-22 at 06:12.

  9. #19
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    5,031
    Quote Originally Posted by sheeple View Post
    My guess was the Digi2 is not recognized and hence misrecognized as a Beocreate amp. Maybe Beocreate is assigned when the OS sees something, but all full.


    I am burning the image to the SD atm. Any manuals on how to install the overlay and squeezelite or is this a matter of clicks in the interface of the raspberry pi OS?

    I am working from a Windows 10 machine, Pi4 connected via ethernet to the router.

    SSH into the rpi (user pi default passwd raspberry ) I use Putty

    do

    Code:
    sudo apt update && sudo apt full-upgrade -y
    on completion

    do
    Code:
    sudo apt install squeezelite -y
    on completion

    do

    Code:
    sudo nano /boot/config.txt
    add the overlay here

    Name:  overlay hifiberry digi plus pro.png
Views: 230
Size:  16.8 KB

    save and exit (use these keys)

    Ctrl+x Y Enter

    Code:
    sudo reboot
    on reboot, connect by SSH and run

    Code:
    squeezelite -l


    ronnie

  10. #20
    Thank you for your detailed instructions. I used Windows Powershell instead and everything was so easy!

    After implementing each step, the command squeezelite -1 prompted the following response:

    Code:
    pi@raspberrypi:~ $ squeezelite -l
    Output devices:
      null                           - Discard all samples (playback) or generate zero samples (capture)
      hw:CARD=Headphones,DEV=0       - bcm2835 Headphones, bcm2835 Headphones - Direct hardware device without any conversions
      plughw:CARD=Headphones,DEV=0   - bcm2835 Headphones, bcm2835 Headphones - Hardware device with all software conversions
      default:CARD=Headphones        - bcm2835 Headphones, bcm2835 Headphones - Default Audio Device
      sysdefault:CARD=Headphones     - bcm2835 Headphones, bcm2835 Headphones - Default Audio Device
      dmix:CARD=Headphones,DEV=0     - bcm2835 Headphones, bcm2835 Headphones - Direct sample mixing device
      hw:CARD=vc4hdmi0,DEV=0         - vc4-hdmi-0, MAI PCM i2s-hifi-0 - Direct hardware device without any conversions
      plughw:CARD=vc4hdmi0,DEV=0     - vc4-hdmi-0, MAI PCM i2s-hifi-0 - Hardware device with all software conversions
      default:CARD=vc4hdmi0          - vc4-hdmi-0, MAI PCM i2s-hifi-0 - Default Audio Device
      sysdefault:CARD=vc4hdmi0       - vc4-hdmi-0, MAI PCM i2s-hifi-0 - Default Audio Device
      hdmi:CARD=vc4hdmi0,DEV=0       - vc4-hdmi-0, MAI PCM i2s-hifi-0 - HDMI Audio Output
      dmix:CARD=vc4hdmi0,DEV=0       - vc4-hdmi-0, MAI PCM i2s-hifi-0 - Direct sample mixing device
      hw:CARD=vc4hdmi1,DEV=0         - vc4-hdmi-1, MAI PCM i2s-hifi-0 - Direct hardware device without any conversions
      plughw:CARD=vc4hdmi1,DEV=0     - vc4-hdmi-1, MAI PCM i2s-hifi-0 - Hardware device with all software conversions
      default:CARD=vc4hdmi1          - vc4-hdmi-1, MAI PCM i2s-hifi-0 - Default Audio Device
      sysdefault:CARD=vc4hdmi1       - vc4-hdmi-1, MAI PCM i2s-hifi-0 - Default Audio Device
      hdmi:CARD=vc4hdmi1,DEV=0       - vc4-hdmi-1, MAI PCM i2s-hifi-0 - HDMI Audio Output
      dmix:CARD=vc4hdmi1,DEV=0       - vc4-hdmi-1, MAI PCM i2s-hifi-0 - Direct sample mixing device
    I guess this means the board is not recognized.
    Last edited by sheeple; 2022-01-22 at 11:49.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •