Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Junior Member threej's Avatar
    Join Date
    Jan 2017
    Posts
    17

    Empty "App Gallery" in LMS web remote control -- and cannot connect to Mysqueezebox

    This is rather sudden. Wanting to connect to my premium Spotify playlists via LMS web interface, I find "My Apps" empty. Strangely, "Favorites" which include items from Spotify, work when items are selected. I installed the latest 8.3 version of LMS, with no change. Using iPeng on an IOS 15 phone gets me full access to "My Apps". It's the desktop, using web remote, that is problematic. Any ideas?

    Wow. Went back to web remote control and see Spotty has appeared in "My Apps" -- not Pandora or any other apps, just Spotty. As I use Spotty 99.9% of the time, I'm happy, but clearly something is wrong -- maybe related to my inability to connect to mysqueezebox.com via the LMS control panel in Mac OS or via the web remote interface?

    This from my LMS log:
    [21-10-02 12:52:29.5597] Slim::Networking::SqueezeNetwork::_error (421) Unable to login to SN: Connect timed out:
    [21-10-02 12:52:29.5600] Slim::Networking::SqueezeNetwork::_init_error (145) Unable to login to mysqueezebox.com, sync is disabled: Connect timed out:
    [21-10-02 12:52:29.5603] Slim::Networking::SqueezeNetwork::_init_error (161) will retry in 16500 (https://www.mysqueezebox.com)
    [21-10-02 12:52:44.2925] Slim::Formats::XML::gotErrorViaHTTP (343) Error: getting https://www.mysqueezebox.com/api/sounds/v1/opml
    Connect timed out: Bad file descriptor
    [21-10-02 12:52:44.2927] Slim::Plugin::Sounds::Plugin::_gotSoundsError (82) Error: Unable to cache Sounds & Effects menu from SN: Connect timed out: Bad file descriptor
    [21-10-02 12:53:29.3696] Slim::Networking::SqueezeNetwork::_error (421) Unable to login to SN: Connect timed out: Bad file descriptor
    [21-10-02 12:53:29.3698] Slim::Networking::SqueezeNetwork::_init_error (145) Unable to login to mysqueezebox.com, sync is disabled: Connect timed out: Bad file descriptor
    [21-10-02 12:53:29.3702] Slim::Networking::SqueezeNetwork::_init_error (161) will retry in 16800 (https://www.mysqueezebox.com)
    [21-10-02 13:09:08.1653] Slim::Networking::SqueezeNetwork::_error (421) Unable to login to SN: Connect timed out:
    [21-10-02 13:09:41.1293] Slim::Networking::SqueezeNetwork::_error (421) Unable to login to SN: Connect timed out:
    Last edited by threej; 2021-10-03 at 08:59.

  2. #2
    Junior Member threej's Avatar
    Join Date
    Jan 2017
    Posts
    17

    Solution

    In the LMS web interface, selecting the Settings button, then going to the Security selection in the Advanced tab, I checked the Insecure HTTPS box.
    Then I could successfully fill in my Mysqueezebox.com credentials in the web interface; afterwards, in the LMS control panel in Mac's System Preferences, I could also successfully input the same information.

    The result: all my apps (Pandora, TuneIn Radio, et al.) again appear in the LMS web interface.
    Last edited by threej; 2021-10-10 at 17:17.

  3. #3
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,628

    Empty "App Gallery" in LMS webremote control -- and cannot connect to Mysqueezebox

    Most likely your system is using outdated SSL libraries or certificates.
    See eg.
    https://guce.techcrunch.com/copyCons...7a7&lang=en-US.
    There are several threads related to this issue.

    --

    Michael

  4. #4
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,950
    I can see from the LMS server.log that my pCP 8 is having a similar problem.

    I see that it still has the expired "DST Root CA X3" cert.
    Code:
    awk -v cmd='openssl x509 -issuer -enddate -noout -subject' ' 
        /BEGIN/{close(cmd)};{print | cmd}' < /etc/ssl/certs/ca-certificates.crt | grep -B 1 -e notAfter.*2021
    
    result
    issuer=O = "Cybertrust, Inc", CN = Cybertrust Global Root
    notAfter=Dec 15 08:00:00 2021 GMT
    --
    issuer=O = Digital Signature Trust Co., CN = DST Root CA X3
    notAfter=Sep 30 14:01:15 2021 GMT
    --
    issuer=OU = GlobalSign Root CA - R2, O = GlobalSign, CN = GlobalSign
    notAfter=Dec 15 08:00:00 2021 GMT
    --
    issuer=C = BM, O = QuoVadis Limited, OU = Root Certification Authority, CN = QuoVadis Root Certification Authority
    notAfter=Mar 17 18:33:33 2021 GMT
    --
    issuer=C = FI, O = Sonera, CN = Sonera Class2 CA
    notAfter=Apr  6 07:29:40 2021 GMT
    I think that it is not technically incorrect to still have it but it is known to cause problems with some software.

    Anyone else on pCP 8 with LMS 8.2.1 seeing this sort of thing in the server.log ?
    Code:
    Slim::Networking::SqueezeNetwork::Players::_players_error (377) Unable to get players from SN: Timed out waiting for data, retrying in 86400 seconds
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  5. #5
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,997
    Quote Originally Posted by Paul Webster View Post
    I can see from the LMS server.log that my pCP 8 is having a similar problem.

    I see that it still has the expired "DST Root CA X3" cert.
    Code:
    awk -v cmd='openssl x509 -issuer -enddate -noout -subject' ' 
        /BEGIN/{close(cmd)};{print | cmd}' < /etc/ssl/certs/ca-certificates.crt | grep -B 1 -e notAfter.*2021
    
    result
    issuer=O = "Cybertrust, Inc", CN = Cybertrust Global Root
    notAfter=Dec 15 08:00:00 2021 GMT
    --
    issuer=O = Digital Signature Trust Co., CN = DST Root CA X3
    notAfter=Sep 30 14:01:15 2021 GMT
    --
    issuer=OU = GlobalSign Root CA - R2, O = GlobalSign, CN = GlobalSign
    notAfter=Dec 15 08:00:00 2021 GMT
    --
    issuer=C = BM, O = QuoVadis Limited, OU = Root Certification Authority, CN = QuoVadis Root Certification Authority
    notAfter=Mar 17 18:33:33 2021 GMT
    --
    issuer=C = FI, O = Sonera, CN = Sonera Class2 CA
    notAfter=Apr  6 07:29:40 2021 GMT
    I think that it is not technically incorrect to still have it but it is known to cause problems with some software.

    Anyone else on pCP 8 with LMS 8.2.1 seeing this sort of thing in the server.log ?
    Code:
    Slim::Networking::SqueezeNetwork::Players::_players_error (377) Unable to get players from SN: Timed out waiting for data, retrying in 86400 seconds
    How would I check this on a Pi with Raspberry OS?
    openssl x509 -issuer -enddate -noout -subject
    seems to hang.

    Sent from my Pixel 3a using Tapatalk

  6. #6
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,950
    Quote Originally Posted by slartibartfast View Post
    How would I check this on a Pi with Raspberry OS?
    openssl x509 -issuer -enddate -noout -subject
    seems to hang.
    It is waiting for a file name.
    Take my awk command from above and put it all on one line.
    Then, once you have that working, you can fiddle with it to adjust the parameters.

    e.g. remove the " | grep -B 1 -e notAfter.*2021" to see the full output (it will be big).
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  7. #7
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,997
    Quote Originally Posted by Paul Webster View Post
    It is waiting for a file name.
    Take my awk command from above and put it all on one line.
    Then, once you have that working, you can fiddle with it to adjust the parameters.

    e.g. remove the " | grep -B 1 -e notAfter.*2021" to see the full output (it will be big).
    The awk command gives this.


    Sent from my Pixel 3a using Tapatalk

  8. #8
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,950
    Put the whole thing on one line ... including the stuff that starts /BEGIN
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  9. #9
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,950
    For pCP the process of updating certificates is not quite the same as for other Unix systems.
    So I am hoping that if others are seeing the same problem then we can alert the pCP team to take a look and come up with an updated .tcz that everyone can easily install from the pCP web front-end.
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  10. #10
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    7,997
    Quote Originally Posted by Paul Webster View Post
    Put the whole thing on one line ... including the stuff that starts /BEGIN
    Results below. Including the one expiring at the end of September but my "My Apps" is working normally.

    Sent from my Pixel 3a using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •