Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Junior Member
    Join Date
    Jan 2019
    Posts
    25

    pCP 8.0.0- LMS does not start after "Update Libs"

    I am running pCP 8.0.0 and also use its LMS.
    (the page footer of pCP web UI says "piCorePlayer | piCorePlayer v8.0.0 | www v00017 | linux 5.10.42-pcpCore-v8 (64) | piCore v13.0 | Squeezelite v1.9.9-1386-pCP")

    Earlier today I have pushed the "Update Libs" button on the LMS page of pCP's web UI.
    It did some updates and after the obligatory reboot LMS did not start anymore.

    Hitting the "Start LMS" button on the LMS page only gives me the following:
    Code:
    [ INFO ] Starting LMS...
    [ INFO ] 
    Slimserver is not Running
    Rebooting does not solve the problem.

    What can I do to get LMS back to functional?

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,950
    My guess is that install LMS again will resolve it.
    However, if you can access the LMS server.log to see what it is saying in there when it tries to start then it might help the diagnosis.
    If it doesn't then you could try running it from SSH session and look at the screen output

    cd /usr/local/slimserver
    perl slimserver.pl

    control-C to exit it if does manage to start
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  3. #3
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,882
    Quote Originally Posted by chrober View Post
    I am running pCP 8.0.0 and also use its LMS.
    (the page footer of pCP web UI says "piCorePlayer | piCorePlayer v8.0.0 | www v00017 | linux 5.10.42-pcpCore-v8 (64) | piCore v13.0 | Squeezelite v1.9.9-1386-pCP")

    Earlier today I have pushed the "Update Libs" button on the LMS page of pCP's web UI.
    It did some updates and after the obligatory reboot LMS did not start anymore.

    Hitting the "Start LMS" button on the LMS page only gives me the following:
    Code:
    [ INFO ] Starting LMS...
    [ INFO ] 
    Slimserver is not Running
    Rebooting does not solve the problem.

    What can I do to get LMS back to functional?
    The only thing I can suggest you try is to remove LMS (elect to keep the cache, pic below), and reinstall.

    Name:  LMSremove.jpg
Views: 115
Size:  22.5 KB
    Server - LMS 8.3.0 Pi4B 4GB/Argon one case/pCP 8.0.0 - 75K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi4/pCP 8.0.0/Topping E30 DAC/Ruark MR1 Mk2
    Lounge - Pi2/pCP 8.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3B/pCP/Bluetooth/Echo Show 8
    Garage - DAC32 > Edifier speakers

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  4. #4
    Junior Member
    Join Date
    Jan 2019
    Posts
    25
    Quote Originally Posted by Paul Webster View Post
    My guess is that install LMS again will resolve it.
    However, if you can access the LMS server.log to see what it is saying in there when it tries to start then it might help the diagnosis.
    If it doesn't then you could try running it from SSH session and look at the screen output

    cd /usr/local/slimserver
    perl slimserver.pl

    control-C to exit it if does manage to start
    All the logs are empty:
    Code:
    ls -l /var/log/slimserver/
    
    total 0
    -rw-r--r--    1 tc       staff            0 Sep 29 10:15 perfmon.log
    -rw-r--r--    1 tc       staff            0 Sep 29 10:15 scanner.log
    -rw-r--r--    1 tc       staff            0 Sep 29 10:15 server.log
    However, your second suggestion did reveal some more information:
    Code:
    perl slimserver.pl
    
    Can't load '/usr/local/slimserver/CPAN/arch/5.32/aarch64-linux-thread-multi/auto/Audio/Scan/Scan.so' for module Audio::Scan: /usr/local/slimserver/CPAN/arch/5.32/aarch64-linux-thread-multi/auto/Audio/Scan/Scan.so: wrong ELF class: ELFCLASS32 at /usr/local/lib/perl5/5.32.1/aarch64-linux-thread-multi/DynaLoader.pm line 193.
     at /usr/local/slimserver/Slim/Formats.pm line 12.
    Compilation failed in require at /usr/local/slimserver/Slim/Formats.pm line 12.
    BEGIN failed--compilation aborted at /usr/local/slimserver/Slim/Formats.pm line 12.
    Compilation failed in require at /usr/local/slimserver/Slim/Music/Info.pm line 29.
    BEGIN failed--compilation aborted at /usr/local/slimserver/Slim/Music/Info.pm line 29.
    Compilation failed in require at /usr/local/slimserver/Slim/Utils/Misc.pm line 50.
    Compilation failed in require at slimserver.pl line 234.
    BEGIN failed--compilation aborted at slimserver.pl line 234.

  5. #5
    Junior Member
    Join Date
    Jan 2019
    Posts
    25
    Quote Originally Posted by chrober View Post
    All the logs are empty:
    Code:
    Can't load '/usr/local/slimserver/CPAN/arch/5.32/aarch64-linux-thread-multi/auto/Audio/Scan/Scan.so' for module Audio::Scan: /usr/local/slimserver/CPAN/arch/5.32/aarch64-linux-thread-multi/auto/Audio/Scan/Scan.so: wrong ELF class: ELFCLASS32 at /usr/local/lib/perl5/5.32.1/aarch64-linux-thread-multi/DynaLoader.pm line 193.
    This seems to correspond to what can be seen in https://repo.picoreplayer.org/repo/1...-CPAN.tcz.info
    Code:
    Title:          slimerver-CPAN.tcz
    Description:    Logitech Media Server CPAN Binaries
    Version:        8.2.0
    Author:         Many, see source site for list
    Original-site:  https://github.com/Logitech/slimserver
    Copying-policy: GPL
    Size:           5.6M
    Extension_by:   paul_123
    Tags:           MEDIA SERVER
    Comments:       Binaries only
                    ----
                    Compiled for piCore64 12.x
                    Compiled for perl 5.32.0
                    ----
    Change-log:     2020/08/03 First verion
                    2020/11/07 Updated faad and wvunpack binaries
    Current:        2021/09/26 Updated to Audio::Scan 1.05

  6. #6
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,494
    Yes, that update was made over the weekend. Hmm. Unfortunately I won't be able to check it out until this evening.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  7. #7
    Junior Member
    Join Date
    Jan 2019
    Posts
    25
    Quote Originally Posted by paul- View Post
    Yes, that update was made over the weekend. Hmm. Unfortunately I won't be able to check it out until this evening.
    Is there any way to manually revert/downgrade these changes?

  8. #8
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    4,882
    Quote Originally Posted by chrober View Post
    Is there any way to manually revert/downgrade these changes?
    See post #3
    Server - LMS 8.3.0 Pi4B 4GB/Argon one case/pCP 8.0.0 - 75K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi4/pCP 8.0.0/Topping E30 DAC/Ruark MR1 Mk2
    Lounge - Pi2/pCP 8.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Pi3B/pCP/Bluetooth/Echo Show 8
    Garage - DAC32 > Edifier speakers

    Spares - 2xTouch, 1xSB Radio. 1xSB3, 6xRPi

  9. #9
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,494
    Quote Originally Posted by chrober View Post
    Is there any way to manually revert/downgrade these changes?
    I forgot I had a way to do that remotely... The change should be reverted. You will need update the libs again.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  10. #10
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,494
    The package has no been updated correctly. Somehow I crossed up my aarch64 and arm binaries.

    Code:
    Logitech Media Server Version: 8.2.0 - 1627922070 @ Tue Aug 3 11:43:18 CEST 2021
    Hostname: Pi4-aarch64-Devel
    Server IP Address: 192.168.0.25
    Server HTTP Port Number: 9000
    Operating system: piCore - EN - utf8
    Platform Architecture: aarch64-linux
    Perl Version: 5.32.1 - aarch64-linux-thread-multi
    Audio::Scan: 1.05
    IO::Socket::SSL: 2.068
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •