Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Senior Member
    Join Date
    Apr 2005
    Location
    Honiton, Devon, UK
    Posts
    1,970

    piCorePlayer - error when uploading custom-convert file

    I'm experimenting with some custom convert settings and prepared a suitable text file with what I need.

    When I attempted to upload it using pCP's "upload custom-convert" facility, I got the error "Invalid file format, must be a text file".
    No matter what I tried, couldn't get it to work.

    So as a tempoary measure, I manually created custom-convert.conf in /usr/local/slimserver and restarted LMS.
    That worked: the settings were applied as expected.

    But as a permanent solution, I wanted to check something with the experts here.
    I note that /usr/local/slimserver/convert.conf is a symbolic link to /tmp/tcloop/slimserver/usr/local/slimserver/convert.conf
    Should I place my custom-convert.conf inside /tmp/tcloop/... and create a symbolic link to it?
    I'm speculating that a reboot of pCP might lose the custom settings unless I get it right.

    PS. I'm using an old pCP (v4.1.0), so perhaps that might be a factor in the upload not working?
    Until recently: Transporter -> ATC SCM100A, now sold :-(
    House move forced change to: piCorePlayer(RPi2/HiFiBerry DIGI2 Pro) -> Meridian 218 -> Meridian M6

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,407
    Quote Originally Posted by cliveb View Post
    I'm experimenting with some custom convert settings and prepared a suitable text file with what I need.

    When I attempted to upload it using pCP's "upload custom-convert" facility, I got the error "Invalid file format, must be a text file".
    No matter what I tried, couldn't get it to work.
    What editor are you using to create the file? Make sure it is pure ascii, UTF-8 can contain binary data which is not compatible.

    So as a tempoary measure, I manually created custom-convert.conf in /usr/local/slimserver and restarted LMS.
    That worked: the settings were applied as expected.
    That is the correct location
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Senior Member
    Join Date
    Apr 2005
    Location
    Honiton, Devon, UK
    Posts
    1,970
    Quote Originally Posted by paul- View Post
    What editor are you using to create the file? Make sure it is pure ascii, UTF-8 can contain binary data which is not compatible.
    I used Notepad (on a Windows machine).
    It's definitely pure ASCII.
    I did wonder if the CR/LF style of newline might be the issue, so I removed the CR characters with a hex editor, but that didn't help.

    Quote Originally Posted by paul- View Post
    That is the correct location
    Thanks.
    Until recently: Transporter -> ATC SCM100A, now sold :-(
    House move forced change to: piCorePlayer(RPi2/HiFiBerry DIGI2 Pro) -> Meridian 218 -> Meridian M6

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •