Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Mar 2020
    Posts
    4

    Glitch when running LMS in Docker on Synology

    I'm close to getting LMS to run correctly in Docker on my Synology DS 218+, but I'm stuck on one final issue.

    In Docker's "Edit" window for the LMS container, the "Port Settings" screen looks like this:

    Local Port Container Port Type
    Auto 3483 TCP
    Auto 3483 UDP
    9000 9000 TCP
    9090 9090 TCP

    When I try to set Local Port to 3483 instead of Auto, I get an error message "Local port 3483,3483,9000,9090 conflicts with other ports used by other services".

    I think that's my problem, because when I run the container with the above settings, the LMS server actually runs and I can get to its web interface via port 900 on my browser, but my Squeezebox player doesn't recognize the server. I believe that's because the player is trying to connect to port 3483.

    So what is using port 3483 on my Synology, and how can I override that and let Docker LMS use that port instead? I have the old non-Docker LMS package installed, but it's not running so I'm assuming it's not reserving that port. I'd rather not uninstall the old LMS package until I have the Docker version running, in case there are problems reinstalling defunct software.

    Any ideas on what I'm doing wrong?

  2. #2
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,605

    Glitch when running LMS in Docker onSynology

    > So what is using port 3483 on my Synology, and how can I override that
    > and let Docker LMS use that port instead? I have the old non-Docker LMS
    > package installed, but it's not running so I'm assuming it's not
    > reserving that port.


    It is. Get rid of it and you'll be able to use the Docker version.

    > Any ideas on what I'm doing wrong?


    You don't want to uninstall because you don't have a backup? It's the
    only way to go.

  3. #3
    Junior Member
    Join Date
    Mar 2020
    Posts
    4

    Thanks!

    Quote Originally Posted by mherger View Post
    > So what is using port 3483 on my Synology, and how can I override that
    > and let Docker LMS use that port instead? I have the old non-Docker LMS
    > package installed, but it's not running so I'm assuming it's not
    > reserving that port.


    It is. Get rid of it and you'll be able to use the Docker version.

    > Any ideas on what I'm doing wrong?


    You don't want to uninstall because you don't have a backup? It's the
    only way to go.
    Thank you that worked! You are awesome!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •