Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20
  1. #11
    Junior Member
    Join Date
    Jan 2016
    Posts
    9
    Quote Originally Posted by bpa View Post
    I think these lines may be the issue in dmesg
    Code:
    .
    .
    [ 10.001058] wm8731 1-001a: supply DBVDD not found, using dummy regulator
    [ 10.002405] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 10.003540] ------------[ cut here ]------------
    [ 10.003636] WARNING: CPU: 0 PID: 32 at sound/core/init.c:208
    snd_card_new+0x43c/0x474 [snd]
    [ 10.003645] Modules linked in: snd_soc_wm8731(+) regmap_spi spidev(+)
    regmap_i2c snd_soc_audioinjector_pi_soundcard brcmfmac brcmutil
    sha256_generic cfg80211 rfkill raspberrypi_hwmon snd_soc_bcm2835_i2s
    spi_bcm2835 snd_soc_core snd_compress snd_pcm_dmaengine i2c_bcm2835
    .
    .
    Hi bpa

    Thank you for leading me to this error, After I got my card working I took a new dmesg read and boy its full off errors:

    7.138025] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 7.142970] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 7.147638] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 7.527869] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 7.537010] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
    [ 7.539097] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 7.808646] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
    [ 7.808829] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
    [ 7.884673] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Jan 4 2021 19:56:29 version 7.45.229 (617f1f5 CY) FWID 01-2dbd9d2e
    [ 8.532307] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 8.536466] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 11.070282] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save enabled
    [ 11.900378] process '/usr/bin/squeezelite-armv6hf' started with executable stack
    [ 12.390687] bcm2835-i2s 3f203000.i2s: I2S SYNC error!


    So I started to google for this -517 error and ended up at audio injectors forum were others back in 2019 had came to the conclusion of an kernel error with the current driver from audio injector... well my card is working so im not so keen in doing all to much but here is what I did:

    in /boot/config.txt I unmarked the on for i2s,i2c and spi
    I den upgraded to latest firmware and kernel for the RPi 3a sudo BRANCH=next rpi-update

    my new dmesg is now only have this errors:

    [ 7.191372] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 7.432707] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 7.461112] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
    [ 7.463819] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 7.507412] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.raspberrypi,3-model-b-plus.txt failed with error -2
    [ 8.349142] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 8.350999] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 11.497874] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save enabled
    [ 12.223105] process '/usr/bin/squeezelite-armv6hf' started with executable stack
    [ 12.702312] bcm2835-i2s 3f203000.i2s: I2S SYNC error!


    Back in 2019 the audio injector onto card working a work around was to add another driver to /etc/modules. snd_soc_cs42xx8_i2c

    after this the dmsg errors came down to this:

    [ 7.204357] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 7.472658] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 7.499580] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
    [ 7.502034] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
    [ 7.811501] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
    [ 7.836111] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Jan 4 2021 19:56:29 version 7.45.229 (617f1f5 CY) FWID 01-2dbd9d2e
    [ 11.096476] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save enabled
    12.213389] bcm2835-i2s 3f203000.i2s: I2S SYNC error!


    However the sound became flat so I will only use this in an emergency. I enclose the fully dmsg If you or anybody else has suggestions to fix those errors I will be happy to hear from you
    Peter
    Attached Images Attached Images

  2. #12
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    21,828
    Quote Originally Posted by cassio299 View Post
    However the sound became flat so I will only use this in an emergency.
    Are still using dmix ? This is a mixer and so another source (e.g. system sounds) can be merged and possibly affecting the audio .

    Try with plughw.

  3. #13
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,899
    The -517 errors are normal….it’s just a timing thing. The kernel only prints the errors, not the last success. Also, upgrade To the latEst kernel, don’t use the next branch.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  4. #14
    Junior Member
    Join Date
    Jan 2016
    Posts
    9
    Quote Originally Posted by bpa View Post
    Are still using dmix ? This is a mixer and so another source (e.g. system sounds) can be merged and possibly affecting the audio .

    Try with plughw.
    Hi I changed to plughw to avoid me from accidentally activating some sound in Raspian... thanks

  5. #15
    Junior Member
    Join Date
    Jan 2016
    Posts
    9
    Quote Originally Posted by paul- View Post
    The -517 errors are normal….it’s just a timing thing. The kernel only prints the errors, not the last success. Also, upgrade To the latEst kernel, don’t use the next branch.
    Thanks I will not upgrade the kernel any further unless I need to.

    I would like to setup my Oled ssd 1306 with LMSMonitor however it sems that the easiest way is via pCP. I tried googleling (a lot) and as you mentioned people are not using pCP with audio injector stereo or orcto. Maybee because our card has inputsound....

    You mentioned last year to one that he could try to add the driver to config.txt as an overlay I tried the following: #dtparam=audio=on, audio_pwm_mode=2, dtoverlay=audioinjector-wm8731-audio.

    Is there anyway I can add the card to the list in Squezzelight settings and change the alsa mixer settings ???? I enclose pictures from my alsamixer and the setup page

    PeterName:  Skærmbillede 2021-09-10 kl. 01.33.02.png
Views: 77
Size:  178.4 KBName:  Skærmbillede 2021-09-11 kl. 11.24.03.png
Views: 76
Size:  111.0 KB

  6. #16
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,899
    You can create a card config file.

    Look in /usr/local/share/pcp/cards

    After you make The file, you need to add the file to be backed up. Add usr/local/share/pcp/cards/xxxxxx.conf

    To the file /opt/.filetool.lst
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  7. #17
    Junior Member
    Join Date
    Jan 2016
    Posts
    9
    Quote Originally Posted by paul- View Post
    You can create a card config file.

    Look in /usr/local/share/pcp/cards

    After you make The file, you need to add the file to be backed up. Add usr/local/share/pcp/cards/xxxxxx.conf

    To the file /opt/.filetool.lst

    Hi Paul

    Thank you for your reply.. I am not able to open the files in /usr/local/share/pcp/cards I managed to ssh into pCP but neither nano nor apt is installed so I don't know how to open files or make new files.
    I am on a Mac so I am not able to open the root dir from the sd card.

    Is there another way to access root in piCorePlayer ??

  8. #18
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    5,221
    Quote Originally Posted by cassio299 View Post
    Hi Paul

    Thank you for your reply.. I am not able to open the files in /usr/local/share/pcp/cards I managed to ssh into pCP but neither nano nor apt is installed so I don't know how to open files or make new files.
    I am on a Mac so I am not able to open the root dir from the sd card.

    Is there another way to access root in piCorePlayer ??
    Look in the Extension list for nano.tcz

    ronnie

  9. #19
    Junior Member
    Join Date
    Jan 2016
    Posts
    9
    Quote Originally Posted by Man in a van View Post
    Look in the Extension list for nano.tcz

    ronnie
    Thankyou Ronnie ... I'm ind.......

  10. #20
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,575
    sudo?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •