Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1

    Can not mount NAS

    Dear all, I set up a new Raspberry PI 400 with piCoreplayer and LMS (both up and running now) and wanted to mount my Synology NAS 218play where my music is stored.
    I worked exactly along picoreplayer guidebook and some threads found here. When I try to mount mnt/nas via the picoreplayer LMS frontend entering my NAS IP and the folders volume1/music it gets denied with the
    Name:  LMS1.jpg
Views: 271
Size:  104.3 KB
    When I try that via putty I get:
    tc@pCPJR:~$ sudo mount -t nfs 192.168.x.xxx:/volume1/music /mnt/nas
    mount: /mnt/nas: bad option; for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount.<type> helper program.

    Mybe important: I could not run - as per doc - the commands
    Install the necessary components before proceeding with mounting.
    Ubuntu2
    sudo apt update
    sudo apt install nfs-common
    CentOS/Redhat/Fedora
    sudo yum install nfs-utils

    as there is no apt in /bin !? I have no clue as this is my first experience with Linux and Raspberry, sorry for that

    any ideas?
    many thanks
    JJR

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,929
    I am pretty sure we can get the NFS route working for you ... but try the CIFS one first as it is usually easier to get working.
    Check the Options carefully when you do it as there are similar names for CIFS and NFS.
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  3. #3
    Thx Paul, awesome!
    I tried immediately following this guidance https://tangielskyblog.wordpress.com...nas-verbinden/ (sorry I am native Austrian happy to follow any english cookbook!

    As I saw no change in behaviour and still the old error messages I gave it a try with the temporary mount command
    sudo mount -t cifs -o credentials=/home/pi/passwd-nas,uid=1000,gid=1000,dir_mode=0700,file_mode=0600 ,vers=1.0 //daten/home /mnt/daten/home
    just with my credentials and path infos
    got the same errors although cifs is enabled on my NAS

    Name:  NAS2.jpg
Views: 102
Size:  121.8 KB

  4. #4
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,929
    Try removing credentials=/home/pi/passwd-nas
    and put a username of guest into the pCP config (without a password) and try setting the vers to 2.0
    (assuming you have at least read-only access with anonymous account).
    If you do require a real username/password then put them into those fields in the pCP UI.
    Don't worry for now about it not working from the command line ... because it looks like it is a syntax error not a problem being reported by the NAS.
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  5. #5
    awesome quick reply, many thanks. Did it now via PcP GUI, homes is the top directory where the music folder is in IP is correct, user and pswd too, still I get an error, is there a log somewhere that I could check?
    Name:  nas3.jpg
Views: 95
Size:  46.5 KB

  6. #6
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,929
    Try adding
    vers=2.0
    into the options.
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  7. #7
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,490
    Synology is typically version 3 of cifs. vers=3.0

    Cifs errors are typically logged in dmesg. There is lots of help info on the pCP interface if you expand the red more> tags.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  8. #8
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,929
    Quote Originally Posted by paul- View Post
    Synology is typically version 3 of cifs. vers=3.0
    However, the pCP UI says that the default is 3.0 ... so I thought it worth trying to force to 2.0 to see if it made a difference.
    UI also says that "vers" must be specified ... so does that mean that there is no default really?
    I have mine set without a "vers" at all and it works (not to a Synology though).
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  9. #9
    thx, vers=3.0 led to the same - not working - result. how can I read the content from dmesg? when I use vi I see only special characters?

  10. #10
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,929
    Just type dmesg on console not ssh session

    You can also see the contents in pCP diagnostics page in web browser.
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •