Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    May 2022
    Posts
    3

    piCorePlayer v6.0.0 wifi working on 3A+, but not v8.1.0

    Apologies if posted before...
    I tried installing PCP 8.1.0 on Pi 3A+ but couldn't get an IP address, although I could see the Pi's MAC in router's wifi client settings.
    Then installed v6.0.0 and connected right away--all other configs were the same.
    Hope this helps anyone else with 3A+ and/or devs. Due to high Pi 4B prices currently (thanks chip shortage!) there may be more folks trying 3A+

  2. #2
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,494
    Thanks for your feedback.

    Just tested pCP8.1.0 on RPi3+. Worked for me. So we need a few more details from you.
    Attached Images Attached Images  

  3. #3
    I've never had any trouble with WiFi on any of my Raspberry Pi devices with piCorePlayer. I've been using pCP since Steen's early versions through to 8.1.0, and I've used Gen 1, 2, 3 and 4 as well as Pi Zero and Pi Zero 2 devices.

    Robert
    Home: Raspberry Pi 4/pCP7.0/LMS8.1.2/Material with files on QNAP TS-251A
    Touch > DacMagic 100 > Naim Audio Nait 3 > Mission 752 (plus Rega Planar 3 > Rega Fono Mini; Naim CD3)
    2 x Squeezebox Radios, 1 X Squeezebox 3 (retired), 1 x SqueezeAMP
    Office: LMS8.0.0 running on Raspberry Pi3; Raspberry Pi 3 player with touchscreen/piCorePlayer/IQaudIO DAC and Amp
    Portable: Raspberry Pi 3B/pCP7.0.1/LMS8.1.2/Material, files on Seagate portable drive, powered via power brick

  4. #4
    Junior Member
    Join Date
    May 2022
    Posts
    3

    Some details

    @Greg let me know what other details would help. For my part I consider things solved as I'm happy running v6.

    For both v8 and v6, only Pi setup was copying wpa_supplicant.conf.sample, modifying ssid and psk, and saving as wpa.supplicant.conf in PCP_BOOT.

    When I couldn't connect wifi on v8, I checked router admin and could intermittently see Pi's MAC but not IP address, which seemed strange as the router could see the Pi to some degree. Tried another power adapter thinking Pi wasn't getting enough juice but didn't help. Then thought problem was my router (DD-WRT TP Link AC-1750), so moved the Pi close to it and fiddled with a bunch of router settings but no joy. Finally put the router back to original settings so my other wifi stuff still worked. Tried v8 again just hoping but still no connection.

    Googled, saw old post by you about v6 working on 3A+ so I flashed v6, did wpa_supplicant.conf the same way and was really surprised when the Pi's IP address popped up in my router on the first boot.

  5. #5
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    5,476
    Unless you used exactly the same wpa_supplicant file ... my guess is that there was a mistake in the original one - perhaps the password was incorrect.
    The router might show the device trying to connect but with incorrect password.
    Easy to test if you have some spare time.
    Paul Webster
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, ABC Australia and CBC/Radio-Canada
    and, via the extra "Radio Now Playing" plugin lots more - see https://forums.slimdevices.com/showt...Playing-plugin

  6. #6
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    2,494
    Check your wpa_supplicant.conf.

    Earlier versions had:

    country="CC" <== WRONG

    not:

    country=CC

  7. #7
    Junior Member
    Join Date
    May 2022
    Posts
    3
    Appreciate the help! When i get time I'll dig up another microSD and give v8 another go

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •