Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Senior Member wortgefecht's Avatar
    Join Date
    Sep 2014
    Location
    Switzerland
    Posts
    280

    Squeezebox Classic - IR remote control problem

    Since there is no forum for the Classic, I post this here: Since yesterday I experience some strange behaviour of my classic. When I use a remote (either the original one or my Logitech Harmony) and hit a button, the Classic either behaves like the button is pressed permanently (constantly scrolling through the menu and stopping at random menu items), shuts down and restarts with setup menu or doesn't react at all. The behaviour seems completely random to me.

    When I use Squeeze Ctrl on my phone or the web interface of LMS to control it, everything works fine.

    This is the log file around the time the strange behaviour occured last:

    Code:
    [15-10-09 19:00:18.0086] Slim::Web::JSONRPC::requestMethod (443) request not dispatchable!
    [15-10-09 19:00:18.0145] Slim::Web::JSONRPC::requestMethod (443) request not dispatchable!
    [15-10-09 19:00:23.0607] Slim::Web::JSONRPC::requestMethod (443) request not dispatchable!
    [15-10-09 19:00:46.0015] Slim::Utils::Timers::__ANON__ (273) Error: Timer Slim::Plugin::UPnP::Events::expire failed: Can't call method "pluginData" on an undefined value at /usr/share/perl5/Slim/Plugin/UPnP/MediaRenderer/AVTransport.pm line 216.
    [15-10-09 19:00:46.0028] Slim::Utils::Timers::__ANON__ (273) Error: Timer Slim::Plugin::UPnP::Events::expire failed: Can't call method "pluginData" on an undefined value at /usr/share/perl5/Slim/Plugin/UPnP/MediaRenderer/RenderingControl.pm line 161.
    [15-10-09 19:07:04.6846] Slim::Display::Display::string (888) Error: missing string PLUGIN_SIRIUS_MODULE_NAME
    [15-10-09 19:07:04.6860] Slim::Display::Display::string (888) Backtrace:
    
       frame 0: Slim::Utils::Log::logBacktrace (/usr/share/perl5/Slim/Display/Display.pm line 888)
       frame 1: Slim::Display::Display::string (/usr/share/perl5/Slim/Player/Player.pm line 193)
       frame 2: Slim::Player::Player::string (/usr/share/perl5/Slim/Utils/Strings.pm line 536)
       frame 3: Slim::Utils::Strings::clientString (/usr/share/perl5/Slim/Menu/SystemInfo.pm line 430)
       frame 4: Slim::Menu::SystemInfo::infoPlugins (/usr/share/perl5/Slim/Menu/Base.pm line 172)
       frame 5: (eval) (/usr/share/perl5/Slim/Menu/Base.pm line 172)
       frame 6: Slim::Menu::Base::addItem (/usr/share/perl5/Slim/Menu/Base.pm line 142)
       frame 7: Slim::Menu::Base::menu (/usr/share/perl5/Slim/Web/Settings/Server/Status.pm line 33)
       frame 8: Slim::Web::Settings::Server::Status::handler (/usr/share/perl5/Slim/Web/HTTP.pm line 1086)
       frame 9: Slim::Web::HTTP::generateHTTPResponse (/usr/share/perl5/Slim/Web/HTTP.pm line 879)
       frame 10: Slim::Web::HTTP::processURL (/usr/share/perl5/Slim/Web/HTTP.pm line 683)
       frame 11: Slim::Web::HTTP::processHTTP (/usr/share/perl5/Slim/Networking/IO/Select.pm line 123)
       frame 12: (eval) (/usr/share/perl5/Slim/Networking/IO/Select.pm line 119)
       frame 13: Slim::Networking::IO::Select::__ANON__ (/usr/share/perl5/Slim/Networking/IO/Select.pm line 168)
       frame 14: (eval) (/usr/share/perl5/Slim/Networking/IO/Select.pm line 168)
       frame 15: Slim::Networking::IO::Select::loop (/usr/sbin/squeezeboxserver line 735)
       frame 16: main::idle (/usr/sbin/squeezeboxserver line 685)
       frame 17: main::main (/usr/sbin/squeezeboxserver line 1223)
    
    [15-10-09 19:07:27.2606] Slim::Display::Display::string (888) Error: missing string PLUGIN_SIRIUS_MODULE_NAME
    [15-10-09 19:07:27.2619] Slim::Display::Display::string (888) Backtrace:
    
       frame 0: Slim::Utils::Log::logBacktrace (/usr/share/perl5/Slim/Display/Display.pm line 888)
       frame 1: Slim::Display::Display::string (/usr/share/perl5/Slim/Player/Player.pm line 193)
       frame 2: Slim::Player::Player::string (/usr/share/perl5/Slim/Utils/Strings.pm line 536)
       frame 3: Slim::Utils::Strings::clientString (/usr/share/perl5/Slim/Menu/SystemInfo.pm line 430)
       frame 4: Slim::Menu::SystemInfo::infoPlugins (/usr/share/perl5/Slim/Menu/Base.pm line 172)
       frame 5: (eval) (/usr/share/perl5/Slim/Menu/Base.pm line 172)
       frame 6: Slim::Menu::Base::addItem (/usr/share/perl5/Slim/Menu/Base.pm line 142)
       frame 7: Slim::Menu::Base::menu (/usr/share/perl5/Slim/Web/Settings/Server/Status.pm line 33)
       frame 8: Slim::Web::Settings::Server::Status::handler (/usr/share/perl5/Slim/Web/HTTP.pm line 1086)
       frame 9: Slim::Web::HTTP::generateHTTPResponse (/usr/share/perl5/Slim/Web/HTTP.pm line 879)
       frame 10: Slim::Web::HTTP::processURL (/usr/share/perl5/Slim/Web/HTTP.pm line 683)
       frame 11: Slim::Web::HTTP::processHTTP (/usr/share/perl5/Slim/Networking/IO/Select.pm line 123)
       frame 12: (eval) (/usr/share/perl5/Slim/Networking/IO/Select.pm line 119)
       frame 13: Slim::Networking::IO::Select::__ANON__ (/usr/share/perl5/Slim/Networking/IO/Select.pm line 168)
       frame 14: (eval) (/usr/share/perl5/Slim/Networking/IO/Select.pm line 168)
       frame 15: Slim::Networking::IO::Select::loop (/usr/sbin/squeezeboxserver line 735)
       frame 16: main::idle (/usr/sbin/squeezeboxserver line 685)
       frame 17: main::main (/usr/sbin/squeezeboxserver line 1223)
    Current setup:
    • EEEBox, Xubuntu 14.04, LMS 7.9, FLAC
    • Duet > Pro-Ject DAC Box E > AKG Hearo 888 Titan (home office), Boom + Canton ASF 75 SC (master bedroom), Boom (master bathroom), 2 Radios (guest bathroom and garden deck), RPi3 + LibreELEC + XSqueeze > Samsung TV > NAD L53 > Mission 2.1 speakers (living room)
    • Transporter > vintage Wega Modul 42V amp (42E equalizer, 42T tape deck + Thorens TD 160 Mk II turntable) > Quadral Vulkan Mk II (music room)

  2. #2
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    21,045
    For Classic/SB3 all IR events are sent to LMS to interpret so I think you should check what your player is sending to LMS.

    Try enabling logging for IR (player.ir) to INFO or DEBUG and see what is logged.

    Also check with a camera (most digital camera see IR as visible) whether your IR remote is sending per press one signal or continous

  3. #3
    Senior Member wortgefecht's Avatar
    Join Date
    Sep 2014
    Location
    Switzerland
    Posts
    280
    Quote Originally Posted by bpa View Post
    For Classic/SB3 all IR events are sent to LMS to interpret so I think you should check what your player is sending to LMS.

    Try enabling logging for IR (player.ir) to INFO or DEBUG and see what is logged.

    Also check with a camera (most digital camera see IR as visible) whether your IR remote is sending per press one signal or continous
    Thanks. I'll do that tomorrow, when I have spare time. And now that you mentioned it, the problems started, after I updated LMS 7.9 to the newest build yesterday ...

    I'm pretty sure that the problem is not caused by the remote, because I tested it with 2 original ones and a Logitech Harmony. Happens with all of them.
    Current setup:
    • EEEBox, Xubuntu 14.04, LMS 7.9, FLAC
    • Duet > Pro-Ject DAC Box E > AKG Hearo 888 Titan (home office), Boom + Canton ASF 75 SC (master bedroom), Boom (master bathroom), 2 Radios (guest bathroom and garden deck), RPi3 + LibreELEC + XSqueeze > Samsung TV > NAD L53 > Mission 2.1 speakers (living room)
    • Transporter > vintage Wega Modul 42V amp (42E equalizer, 42T tape deck + Thorens TD 160 Mk II turntable) > Quadral Vulkan Mk II (music room)

  4. #4
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    6,327
    I get the same thing with an SB3 but I so rarely use the actual remote it doesn't really matter to me. When it has happened I have put the issue down to old batteries in the remote and just reached for my phone and iPeng.
    Jim
    https://jukeradio.double6.net


    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Radio
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes

  5. #5
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    21,045
    Quote Originally Posted by wortgefecht View Post
    Thanks. I'll do that tomorrow, when I have spare time. And now that you mentioned it, the problems started, after I updated LMS 7.9 to the newest build yesterday ...

    I'm pretty sure that the problem is not caused by the remote, because I tested it with 2 original ones and a Logitech Harmony. Happens with all of them.
    As a general rule with the older SB player when some "odd" behaviour happens - I make sure to do a Xlinx reset first (while holding 1 on the remote pointed at player - plugin the power to the player).

  6. #6
    Senior Member wortgefecht's Avatar
    Join Date
    Sep 2014
    Location
    Switzerland
    Posts
    280
    Quote Originally Posted by bpa View Post
    As a general rule with the older SB player when some "odd" behaviour happens - I make sure to do a Xlinx reset first (while holding 1 on the remote pointed at player - plugin the power to the player).
    I'll give that a try asap
    Current setup:
    • EEEBox, Xubuntu 14.04, LMS 7.9, FLAC
    • Duet > Pro-Ject DAC Box E > AKG Hearo 888 Titan (home office), Boom + Canton ASF 75 SC (master bedroom), Boom (master bathroom), 2 Radios (guest bathroom and garden deck), RPi3 + LibreELEC + XSqueeze > Samsung TV > NAD L53 > Mission 2.1 speakers (living room)
    • Transporter > vintage Wega Modul 42V amp (42E equalizer, 42T tape deck + Thorens TD 160 Mk II turntable) > Quadral Vulkan Mk II (music room)

  7. #7
    Senior Member wortgefecht's Avatar
    Join Date
    Sep 2014
    Location
    Switzerland
    Posts
    280
    So, Xlinx reset helped. Problem solved, thx.
    Current setup:
    • EEEBox, Xubuntu 14.04, LMS 7.9, FLAC
    • Duet > Pro-Ject DAC Box E > AKG Hearo 888 Titan (home office), Boom + Canton ASF 75 SC (master bedroom), Boom (master bathroom), 2 Radios (guest bathroom and garden deck), RPi3 + LibreELEC + XSqueeze > Samsung TV > NAD L53 > Mission 2.1 speakers (living room)
    • Transporter > vintage Wega Modul 42V amp (42E equalizer, 42T tape deck + Thorens TD 160 Mk II turntable) > Quadral Vulkan Mk II (music room)

  8. #8
    Junior Member
    Join Date
    Nov 2005
    Posts
    4

    IR repeating??

    Quote Originally Posted by wortgefecht View Post
    So, Xlinx reset helped. Problem solved, thx.
    Hey folks - I realize this thread is pretty old, but I'm running into this EXACT issue on both of my Squeezebox 3s. I happen to have been using mobile app/browser for a long time and only recently tried to use the old fashioned IR remote since getting a Harmony Hub. For the longest time, I thought it was the hub, until I whipped out the actual SB3 remote and reproduced it with the H.Hub completely out of the room. Then, I figured, hey, I have two of these Squeezebox 3s, maybe the IR receiver in the one is jacked up somehow... so I plug-in the other and get the same behavior described by the OP. Various lanes of troubleshooting have lead me to think that perhaps there really is something jacked up with the hardware. I happen to also have a SB Touch, which DOES NOT have this issue with its IR remote and, in fact, works perfectly with the remote from the SB3 as well. (assuming the touch doesn't route IR through LMS as those entries don't show up in the logs). As far as LMS versions - all devices are currently running off of one of the the latest nightly builds: 7.9.0 - 1482423225 @ Wed Dec 28 04:04:47 CUT 2016. When this all started, I was still running the final Logitech release - no difference in behavior.

    I enabled DEBUG logging for the IR module as suggested above and it appears that a single IR press is interpreted nearly endlessly:

    Code:
    [17-01-01 22:14:16.0391] Slim::Hardware::IR::lookupCodeBytes (445) 7689b04f -> code: arrow_down
    [17-01-01 22:14:16.0395] Slim::Hardware::IR::processIR (687) 7689b04f	371488.485	1483326856.03936
    [17-01-01 22:14:16.0399] Slim::Hardware::IR::lookup (474) Found button arrow_down for 7689b04f
    [17-01-01 22:14:16.0402] Slim::Hardware::IR::lookupFunction (518) Found function: down for button arrow_down in mode common (current mode: INPUT.Text)
    [17-01-01 22:14:16.0405] Slim::Hardware::IR::processIR (782) irCode = [down] timer = [371488.485] timediff = [622.977000000014] last = [dead]
    [17-01-01 22:14:16.0408] Slim::Hardware::IR::processCode (1119) irCode: down, 00:04:20:06:0b:6d
    [17-01-01 22:14:16.0413] Slim::Hardware::IR::lookupFunction (525) irCode not defined: [down] for mode: [INPUT.Text]
    [17-01-01 22:14:16.0416] Slim::Hardware::IR::executeButton (1066) Trying to execute button [down] for irCode: [down]
    [17-01-01 22:14:16.0421] Slim::Hardware::IR::executeButton (1097) Executing button [down] for irCode: [down] Slim::Buttons::Input::Text::__ANON__
    [17-01-01 22:14:16.0883] Slim::Hardware::IR::lookupCodeBytes (445) 7689b04f -> code: arrow_down
    [17-01-01 22:14:16.0886] Slim::Hardware::IR::processIR (687) 7689b04f	371488.535	1483326856.08848
    [17-01-01 22:14:16.0891] Slim::Hardware::IR::lookup (474) Found button arrow_down for 7689b04f
    [17-01-01 22:14:16.0894] Slim::Hardware::IR::lookupFunction (518) Found function: down_repeat for button arrow_down.repeat in mode common (current mode: INPUT.Text)
    [17-01-01 22:14:16.0897] Slim::Hardware::IR::repeatCode (972) irCode = [down_repeat] timer = [371488.535] timediff = [0.0499999999883585] last = [down]
    [17-01-01 22:14:16.0900] Slim::Hardware::IR::processCode (1119) irCode: down_repeat, 00:04:20:06:0b:6d
    [17-01-01 22:14:16.0904] Slim::Hardware::IR::lookupFunction (525) irCode not defined: [down_repeat] for mode: [INPUT.Text]
    [17-01-01 22:14:16.0907] Slim::Hardware::IR::executeButton (1066) Trying to execute button [down_repeat] for irCode: [down_repeat]
    [17-01-01 22:14:16.0911] Slim::Hardware::IR::executeButton (1097) Executing button [down_repeat] for irCode: [down_repeat] Slim::Buttons::Input::Text::__ANON__
    [17-01-01 22:14:16.1062] Slim::Hardware::IR::lookupCodeBytes (445) 7689b04f -> code: arrow_down
    [17-01-01 22:14:16.1066] Slim::Hardware::IR::processIR (687) 7689b04f	371488.553	1483326856.10642
    [17-01-01 22:14:16.1069] Slim::Hardware::IR::lookup (474) Found button arrow_down for 7689b04f
    [17-01-01 22:14:16.1072] Slim::Hardware::IR::lookupFunction (518) Found function: down_repeat for button arrow_down.repeat in mode common (current mode: INPUT.Text)
    [17-01-01 22:14:16.1075] Slim::Hardware::IR::repeatCode (972) irCode = [down_repeat] timer = [371488.553] timediff = [0.0180000000400469] last = [down_repeat]
    [17-01-01 22:14:16.1078] Slim::Hardware::IR::processCode (1119) irCode: down_repeat, 00:04:20:06:0b:6d
    [17-01-01 22:14:16.1082] Slim::Hardware::IR::lookupFunction (525) irCode not defined: [down_repeat] for mode: [INPUT.Text]
    [17-01-01 22:14:16.1085] Slim::Hardware::IR::executeButton (1066) Trying to execute button [down_repeat] for irCode: [down_repeat]
    [17-01-01 22:14:16.1089] Slim::Hardware::IR::executeButton (1097) Executing button [down_repeat] for irCode: [down_repeat] Slim::Buttons::Input::Text::__ANON__
    [17-01-01 22:14:16.1614] Slim::Hardware::IR::lookupCodeBytes (445) 7689b04f -> code: arrow_down
    [17-01-01 22:14:16.1617] Slim::Hardware::IR::processIR (687) 7689b04f	371488.608	1483326856.16159
    [17-01-01 22:14:16.1620] Slim::Hardware::IR::lookup (474) Found button arrow_down for 7689b04f
    [17-01-01 22:14:16.1624] Slim::Hardware::IR::lookupFunction (518) Found function: down_repeat for button arrow_down.repeat in mode common (current mode: INPUT.Text)
    [17-01-01 22:14:16.1626] Slim::Hardware::IR::repeatCode (972) irCode = [down_repeat] timer = [371488.608] timediff = [0.0549999999930151] last = [down_repeat]
    [17-01-01 22:14:16.1629] Slim::Hardware::IR::processCode (1119) irCode: down_repeat, 00:04:20:06:0b:6d
    [17-01-01 22:14:16.1633] Slim::Hardware::IR::lookupFunction (525) irCode not defined: [down_repeat] for mode: [INPUT.Text]
    [17-01-01 22:14:16.1636] Slim::Hardware::IR::executeButton (1066) Trying to execute button [down_repeat] for irCode: [down_repeat]
    [17-01-01 22:14:16.1641] Slim::Hardware::IR::executeButton (1097) Executing button [down_repeat] for irCode: [down_repeat] Slim::Buttons::Input::Text::__ANON__
    The first line is the initial button-press, then the following five are what appears to be standard lookup/execution procedures, however, after the 6th line, it just repeats this sequence endlessly until finally giving up after more than 1000 lines. I confirmed a single button-press by using my phone's camera, so it's not that. And the XLinx reset on both units didn't make any difference. Also, since it's the LMS interpreting the IR and sending commands, I wondered what would happen when removing it from the equation all together, so I rebooted the SB3 and managed to get it connected to mysqueezebox.com instead of my local LMS. I confirmed it wasn't showing in LMS and attempted to use the IR remote again and sure enough, same deal. I'm wondering if perhaps we're at a firmware issue here?

    I feel like I've chased down everything I possibly could and am hoping one of you smart folks might be able to give me a clue as to what to consider next. Thanks in advance - I hope this is enough info. Cheers!

  9. #9
    Junior Member
    Join Date
    Nov 2005
    Posts
    4
    *BUMP*

    Any thoughts? Pointers to other resources?

  10. #10
    Senior Member
    Join Date
    Dec 2007
    Location
    Home Counties, UK
    Posts
    433
    This seems to be happening to me - the constant scrolling down.
    I've found that even when I've taken out the batteries of my remote, it's still doing it so it appears to be a fault of the receiver/software rather than sticky button on the remote.
    This happens on both LMS and in MSB.
    RadioFeeds UK & Ireland.. an up-to-date radio directory for your Squeezebox/Transporter/UE Smart Radio.. available from the mysqueezebox.com App Gallery.
    Bonus: our RadioFeeds LMS plugin also lists AAC and the BBC's high-quality HLS streams on top of what's available in our MSB app.
    Now with over 1000 registered users, it's available for Logitech Media Server (and Squeezebox Server, SqueezeCenter and SlimServer).
    Click for more info: http://www.radiofeeds.co.uk/squeeze

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •