Home of the Squeezebox™ & Transporter® network music players.
Page 5 of 7 FirstFirst ... 34567 LastLast
Results 41 to 50 of 69
  1. #41
    Senior Member
    Join Date
    May 2010
    Location
    London, UK
    Posts
    976
    Quote Originally Posted by bvrulez View Post
    Indeed, thanks! Maybe I should upgrade to the nightly built LMS version to get 1.05?

    Code:
    Logitech Media Server Version: 8.2.0 - 1627922070 @ Tue Aug 3 11:39:20 CEST 2021
    Hostname: raspberrypi
    IP: 192.168.100.90
    HTTP-Port: 9000
    BS: Debian - DE - utf8
    Plattform: armv7l-linux
    Perl-Version: 5.28.1 - arm-linux-gnueabihf-thread-multi-64int
    Audio::Scan: 1.02
    IO::Socket::SSL: 2.060
    Datenbankversion: DBD::SQLite 1.58 (sqlite 3.22.0)
    Anzahl erkannter Player: 7

    Yes - an update to LMS 8.3 is required ! I missed that detail...
    EDIT: No - not yet. Just latest nightly. I'm becoming confused...
    Last edited by mrw; 2022-05-23 at 10:19. Reason: Correction

  2. #42
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,733

    Should LMS read metadata from ID3v2.4?

    > For some reason, AudioScan on perl 5.32 remains at 1.02 for the two arm
    > builds (aarch64-linux-thread-multi and
    > arm-linux-gnueabihf-thread-multi-64int), although X86_64 was updated to
    > 1.05.
    >
    > I guess they should all be updated "together".


    The reason being: it's work somebody needs to do. I don't always have
    the time and interest to compile for all platforms.

  3. #43
    Member
    Join Date
    Aug 2018
    Location
    Germany
    Posts
    45
    Quote Originally Posted by mherger View Post
    >
    The reason being: it's work somebody needs to do. I don't always have
    the time and interest to compile for all platforms.
    I gave it a try for 5.32/aarch64, seems to work but maybe someone else wants to give it a try as well

    Code:
    Logitech Media Server Version: 8.3.0 - 1652959787 @ Thu 19 May 2022 01:56:11 PM CEST
    Betriebssystem: Debian - DE - utf8
    Plattformarchitektur: aarch64-linux
    Perl-Version: 5.32.1 - aarch64-linux-gnu-thread-multi
    Audio::Scan: 1.05
    IO::Socket::SSL: 2.069
    Datenbankversion: DBD::SQLite 1.58 (sqlite 3.22.0)
    Attached Files Attached Files

  4. #44
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    9,277
    Quote Originally Posted by mherger View Post
    > For some reason, AudioScan on perl 5.32 remains at 1.02 for the two arm
    > builds (aarch64-linux-thread-multi and
    > arm-linux-gnueabihf-thread-multi-64int), although X86_64 was updated to
    > 1.05.
    >
    > I guess they should all be updated "together".


    The reason being: it's work somebody needs to do. I don't always have
    the time and interest to compile for all platforms.
    I might have a go at compiling for the arm platform. Where do I start?

    Sent from my Pixel 3a using Tapatalk

  5. #45
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    9,277
    Quote Originally Posted by Rasputin_GY View Post
    I gave it a try for 5.32/aarch64, seems to work but maybe someone else wants to give it a try as well

    Code:
    Logitech Media Server Version: 8.3.0 - 1652959787 @ Thu 19 May 2022 01:56:11 PM CEST
    Betriebssystem: Debian - DE - utf8
    Plattformarchitektur: aarch64-linux
    Perl-Version: 5.32.1 - aarch64-linux-gnu-thread-multi
    Audio::Scan: 1.05
    IO::Socket::SSL: 2.069
    Datenbankversion: DBD::SQLite 1.58 (sqlite 3.22.0)
    How did you go about this? I wanted to try compiling for the arm version but have no idea where to start. I am surprised it doesn't already exist.

    Sent from my Pixel 3a using Tapatalk

  6. #46
    Senior Member
    Join Date
    Aug 2017
    Posts
    139
    I just installed via dpgk version 8.3 from nightly builds using the file ending with ALL (for all archs).

    EDIT: When I did this I was running 32bit OS on a 64bit Raspi 4. I migrated to 64bit OS in the last week and now have this:


    Code:
    Logitech Media Server Version: 8.3.0 - 1655802730 @ Tue 21 Jun 2022 11:27:10 AM CEST
    Hostname: RPi64
    IP: 192.168.100.90
    HTTP-Port: 9000
    BS: Debian - DE - utf8
    Plattform: aarch64-linux
    Perl-Version: 5.32.1 - aarch64-linux-gnu-thread-multi
    Last edited by bvrulez; 2022-07-06 at 05:44.

  7. #47
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    4,872
    Quote Originally Posted by slartibartfast View Post
    How did you go about this? I wanted to try compiling for the arm version but have no idea where to start. I am surprised it doesn't already exist.

    Sent from my Pixel 3a using Tapatalk
    I have all of the binaries for arm in pCP distribution, I don't normally submit to github because there is normally glibc issues with pCP normally being too new.

    To maintain your own Perl binaries. Take a look

    https://github.com/Logitech/slimserv...ublic/8.3/CPAN
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  8. #48
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    9,277
    Quote Originally Posted by paul- View Post
    I have all of the binaries for arm in pCP distribution, I don't normally submit to github because there is normally glibc issues with pCP normally being too new.

    To maintain your own Perl binaries. Take a look

    https://github.com/Logitech/slimserv...ublic/8.3/CPAN
    Can I install only audio scan using buildme.sh?

    Sent from my Pixel 3a using Tapatalk

  9. #49
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    9,277
    Quote Originally Posted by paul- View Post
    I have all of the binaries for arm in pCP distribution, I don't normally submit to github because there is normally glibc issues with pCP normally being too new.

    To maintain your own Perl binaries. Take a look

    https://github.com/Logitech/slimserv...ublic/8.3/CPAN
    FWIW my glibc version is
    Debian GLIBC 2.31-13+rpt2+rpi1+deb11u2) 2.31

  10. #50
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    9,277
    Quote Originally Posted by bvrulez View Post
    I just installed via dpgk version 8.3 from nightly builds using the file ending with ALL (for all archs).

    EDIT: When I did this I was running 32bit OS on a 64bit Raspi 4. I migrated to 64bit OS in the last week and now have this:


    Code:
    Logitech Media Server Version: 8.3.0 - 1655802730 @ Tue 21 Jun 2022 11:27:10 AM CEST
    Hostname: RPi64
    IP: 192.168.100.90
    HTTP-Port: 9000
    BS: Debian - DE - utf8
    Plattform: aarch64-linux
    Perl-Version: 5.32.1 - aarch64-linux-gnu-thread-multi
    I don't think you were on Bullseye 32 bit though.

    Sent from my Pixel 3a using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •