Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 9 of 9
  1. #1
    Senior Member
    Join Date
    Aug 2017
    Posts
    139

    LMS fails reading artwork from ID3v2.4

    I use the awesome filesystem mp3fs to convert flac to mp3.

    But I have a problem with showing the artwork of my files in LMS.

    Both files contain the cover but in the case of a FLAC that was converted to mp3 it is not displayed by the server.

    First file originally mp3, second one converted from flac. First file does show artwork, second file does not. Both do show artwork in Tauon Music Box player.

    Output from ffprobe:

    Code:
    Input #0, mp3, from '01 1, 2, 3.mp3':
      Metadata:
        title           : 1, 2, 3
        artist          : 4 Lyn
        album           : 4Lyn
        genre           : Rock
        composer        : Ron Clauss/Bjorn Dussler/Sascha Carrilho/Benjamin Eckebrecht
        track           : 01/15
        disc            : 01/01
        encoded_by      : iTunes 10.7
        date            : 2011
      Duration: 00:01:46.45, start: 0.000000, bitrate: 257 kb/s
        Stream #0:0: Audio: mp3, 44100 Hz, stereo, fltp, 256 kb/s
        Stream #0:1: Video: mjpeg (Baseline), yuvj420p(pc, bt470bg/unknown/unknown), 600x588 [SAR 1:1 DAR 50:49], 90k tbr, 90k tbn, 90k tbc (attached pic)
        Metadata:
          comment         : Other
    Code:
    Input #0, mp3, from '01 - Fear Inoculum.mp3':
      Metadata:
        encoder         : MP3FS
        title           : Fear Inoculum
        artist          : Tool
        album           : Fear Inoculum
        date            : 2019
        track           : 01
        genre           : Metal
        TLEN            : 620101
      Duration: 00:10:20.15, start: 0.000000, bitrate: 194 kb/s
        Stream #0:0: Audio: mp3, 44100 Hz, stereo, fltp, 192 kb/s
        Stream #0:1: Video: mjpeg (Baseline), yuvj420p(pc, bt470bg/unknown/unknown), 1500x1500 [SAR 1:1 DAR 1:1], 90k tbr, 90k tbn, 90k tbc (attached pic)
        Metadata:
          comment         : Cover (front)
    I added the cover to the original flac with

    Code:
    metaflac --import-picture-from="$FILEPATH" "$f"
    If you want to check out for yourself here is a file that does contain a cover which does not show up: https://filehorst.de/d/dGnatFyD

    EDIT: Yes, I cleared the database and did a full rescan.

    EDIT2: Also interesting, "MediaInfo" in Linux shows artwork data for the mp3-file, but does not show this content for the file that was created from the flac file. To be clear, the last one does contain a cover which is shown by "ffprobe", but maybe LMS does read the data like "MediaInfo" (GUI application in Ubuntu) does and therefore does not discover the data?
    Last edited by bvrulez; 2021-08-17 at 21:49.

  2. #2
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    6,734
    Have you done a Clear & Rescan?
    Jim
    https://jukeradio.double6.net


    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Radio
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes

  3. #3
    Senior Member
    Join Date
    Aug 2017
    Posts
    139
    I did clear library and rescan everything. I should have added this information in the first place, sorry.

  4. #4
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    21,883
    It looks the tags are ID3 V4.* whic I think is not support ed by LMS.

    edit:
    Code:
    00000000  49 44 33 04 00 40 00 00  6d 29 00 00 00 0c 01 20  |ID3..@..m)..... |
    00000010  05 00 50 68 1b 42 54 53  53 45 00 00 00 06 00 00  |..Ph.BTSSE......|
    00000020  03 4d 50 33 46 53 54 49  54 32 00 00 00 19 00 00  |.MP3FSTIT2......|
    00000030  03 32 30 30 38 20 30 33  20 32 32 20 30 35 20 4e  |.2008 03 22 05 N|
    00000040  65 77 20 50 73 79 63 68  6f 54 50 45 31 00 00 00  |ew PsychoTPE1...|
    00000050  06 00 00 03 70 68 61 7a  65 54 50 45 32 00 00 00  |....phazeTPE2...|
    00000060  06 00 00 03 70 68 61 7a  65 54 41 4c 42 00 00 00  |....phazeTALB...|
    00000070  0a 00 00 03 50 72 6f 62  65 72 61 75 6d 54 43 4f  |....ProberaumTCO|
    00000080  4e 00 00 00 05 00 00 03  52 6f 63 6b 41 50 49 43  |N.......RockAPIC|
    00000090  00 00 6c 00 00 00 03 69  6d 61 67 65 2f 6a 70 65  |..l....image/jpe|
    000000a0  67 00 03 63 6f 76 65 72  2e 6a 70 67 00 ff d8 ff  |g..cover.jpg....|
    000000b0  e0 00 10 4a 46 49 46 00  01 01 00 00 01 00 01 00  |...JFIF.........|
    000000c0  00 ff db 00 43 00 0a 07  07 08 07 06 0a 08 08 08  |....C...........|

  5. #5
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    21,883
    Quote Originally Posted by bpa View Post
    It looks the tags are ID3 V4.* whic I think is not support ed by LMS.
    I'm wrong about version (misread the spec it is V3.2.4) . However the tags are not showing up in my LMS after scanning and drilling down to "View Tags"
    Last edited by bpa; 2021-08-17 at 12:01.

  6. #6
    Senior Member
    Join Date
    Aug 2017
    Posts
    139
    you are right, i dont see any tags, when i check for them in LMS. the original flac has all the tags and i can read them in LMS, including the artwork. however, the Tags are definitely there in other applocations. as i posted.

  7. #7
    Senior Member
    Join Date
    Aug 2017
    Posts
    139
    just checked it again. this special file might not have tags in the mp3 version. i checked it with black player on android and it seems so.

    i uploaded a file which will not give me copyright problems. originall, i uploaded the TOOL file but i figured this might cause the forum problems. so i swapped them. but i did not fully check this other file.

  8. #8
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    21,883
    Quote Originally Posted by bvrulez View Post
    just checked it again. this special file might not have tags in the mp3 version.
    The MP3 file does have ID3v2.4 tags (hex dump in previous post was from mp3 file ) but for some reason LMS scanner doesn't process them. Perhaps there is a subtle error (e.g. byte count wrong) or unsupported tag and the scan is aborted.

  9. #9
    Senior Member
    Join Date
    Aug 2017
    Posts
    139
    The artwork (!) is not read by LMS if the tags are version ID3v2.4. The other tags are there if I open the file in the browsemenu option (direct link to the directory).

    If I use easytag to automatically save as ID3v2.3 the file will show the artwork.

    Even if I set `easytag` to save it to ID3v1 (in addition), LMS is unable to read the artwork.
    Last edited by bvrulez; 2021-08-17 at 21:49.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •